vbetool 100% cpu usage on resume

Bug #130979 reported by Nobu on 2007-08-07
44
This bug affects 4 people
Affects Status Importance Assigned to Milestone
vbetool (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: vbetool

When I choose to suspend the computer it seems to work. The monitor goes blank, the power light starts blinking, and the fans turn off. When I turn the computer back on the screen remains blank and I must use ctrl + alt + (some function key) then ctrl + alt + F7 to get back to a desktop. After logging in not everything loads and the CPU usage of one of my two cores is 100% constantly(And alternating every few seconds between the two). When I open gnome-system-monitor and set it to show all processes it shows vbetool running at 50%(Or 100% of one of the two cores). Killing vbetool causes the screen to blank, where I can use the ctrl + alt + Fn then ctrl + alt + F7 key combinations to return to my desktop, with the CPU usage back to normal.

'uname -a' gives:
Linux nobu-desktop 2.6.20-16-generic #2 SMP Thu Jun 7 19:00:28 UTC 2007 x86_64 GNU/Linux

'lspci -n' :
00:00.0 0500: 10de:02f1 (rev a2)
00:00.1 0500: 10de:02fa (rev a2)
00:00.2 0500: 10de:02fe (rev a2)
00:00.3 0500: 10de:02f8 (rev a2)
00:00.4 0500: 10de:02f9 (rev a2)
00:00.5 0500: 10de:02ff (rev a2)
00:00.6 0500: 10de:027f (rev a2)
00:00.7 0500: 10de:027e (rev a2)
00:03.0 0604: 10de:02fd (rev a1)
00:04.0 0604: 10de:02fb (rev a1)
00:09.0 0500: 10de:0270 (rev a2)
00:0a.0 0601: 10de:0261 (rev a3)
00:0a.1 0c05: 10de:0264 (rev a3)
00:0a.2 0500: 10de:0272 (rev a3)
00:0b.0 0c03: 10de:026d (rev a3)
00:0b.1 0c03: 10de:026e (rev a3)
00:0d.0 0101: 10de:0265 (rev a1)
00:0e.0 0101: 10de:0266 (rev a1)
00:10.0 0604: 10de:026f (rev a2)
00:10.2 0401: 10de:026b (rev a2)
00:14.0 0680: 10de:0269 (rev a3)
00:18.0 0600: 1022:1100
00:18.1 0600: 1022:1101
00:18.2 0600: 1022:1102
00:18.3 0600: 1022:1103
02:00.0 0300: 10de:016a (rev a1)

vbetool package version:
1.0-0ubuntu1

Bottom left corner of vbetool man file:
vbetool 0.2

Chris Jones (cmsj) wrote :

I'm curious what hardware you observed this on. I have seen it a few times on my thinkpad x40, but it doesn't happen very often (and I suspend/resume several times a day).

Changed in vbetool:
status: New → Confirmed
Nobu (benjo316) wrote :

Well, it's not a notebook. ^.^
The motherboard is a Biostar GeForce 6100 AM2. As shown above, I'm using a 64-bit Processor and the 64-bit version of Ubuntu. It is completely possible that other people experience this as well, but don't know because they have a single core processor and the computer locks up because vbetool is using all of it.
I'm using the latest nVidia drivers installed through Envy, because I had trouble installing them any other way, if that may have anything to do with it. My video card is an nVidia GeForce 7100 GS.

If you need any more information I'll be glad to provide it. I had also noticed that the x40 notebooks had a similar problem(I was searching the bugs to look for others who might have the same problem.) but it wasn't exactly the same and since I didn't have a thinkpad(Or notebook, for that matter) I thought it would be better to file a new bug.

Chris Jones (cmsj) wrote :

well acpi is acpi, it shouldn't really matter whether it's a desktop or a laptop, but it is possible we are seeing different bugs here. I'll go hunt for the others :)

Nobu (benjo316) wrote :

Well, it's not working at all anymore... Probably some file I edited and forgot about. I'm going to try reinstalling Ubuntu and see if it works on a fresh install, vbetool acts up, or it doesn't work at all.

As for what it's doing now: When I resume the power light blinks for a little while, turns solid for a few seconds, then starts blinking again and doesn't stop after. Anyway, I have most of the stuff I want to keep on a separate partition so I don't have to worry about that being removed(Would like a separate drive for backup though.) and I can open synaptic and get a list of installed packages so I don't have to worry about that either. ^.^

I'll reinstall, check suspend before installing anything extra, then get situated... I'll probably check suspend in the Live CD as well, but since it has outdated packages it won't be a complete give-away. Wish me luck. ^.^

Nobu (benjo316) wrote :

I tried again after reinstalling and it didn't work. I seem to remember using uswsusp in order to get suspend working, but I'm not sure.
As far as this try goes, I have the syslog attached for anyone to look at. I'll try installing uswsusp and trying again to see if I get the expected results so that I can pursue this bug.

While I'm at it, should I file a bug about the issue I'm having now? It is a different problem, since I could at one point use suspend properly and it apparently doesn't have anything to do with vbetool.

Nobu (benjo316) wrote :

Even with uswsusp suspend (Using s2ram) still isn't working for me. I'm really stumped about why it won't work now... I'd say it's because of my recently installed dual-core processor but it was working after installing it. I would say that it's due to me using the 64-bit version of Ubuntu, but that can't be right either, since I'm pretty sure I was using that then as well.

Either way, I can't figure it out. I can use s2disk, with uswsusp, and it resumes fine.

If anybody has a hint, it'd be nice. ^.^

sebrock (sebrock) wrote :

I have the exact same issue. However, I just chmod vbetool not the be an executable thus making it never execute on suspend/resume and voila everything works. I mean everything, graphics, lan, I/O, display etc. Seems I don't even need to use vbetool. Guessing the BIOS can handle this stiff itself?

Dan Alderman (danalderman) wrote :

I am experiencing the same issues as the first poster on an IBM X61s UK43JUK with an up to date Hardy x86_64.

Linux nano 2.6.24-10-generic #1 SMP Fri Feb 22 18:26:06 UTC 2008 x86_64 GNU/Linux

Excentrik (excentrik) wrote :

I'm also experiencing exactly the same problem as mentioned in the first description, although I only have one core :P

A brief tour of what I did/had:

Using radeon driver, with some settings (in acpi-support), I had suspend working flawlessly.

Afterwards, I've tried to install the fglrx driver but suspend stopped working.
I changed a few settings, but still no good.

I uninstalled the fglrx driver and reverted to the original working settings but now I'm experiencing this bug.

Worth of mention, is that I have
SAVE_VBE_STATE=false
in /etc/default/acpi-support

so I wonder where vbetool is being called.

My hardware:
Acer Aspire 1694 WLmi
Centrino Sonoma 2.0Ghz
Ati Radeon X700
kernel 2.6.22.9
Ubuntu Gutsy

Luka Renko (lure) wrote :

I have the same problem with up-to-date Intrepid on HP nw8440 laptop with ATI card (using open source radeon driver).

diaboflo (ubuntu-diaboflo) wrote :

"vbetool post" also breaks my resume on an Acer Travelmate 4002 wlmi with an ATI Radeon Mobility 9700. Details in
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/350351

Both in jaunty beta and intrepid.

I really need --quirk-vbe-post to wake up. how does that relate to the settings in /etc/default/acpi-support?

Changed in vbetool (Ubuntu):
importance: Undecided → High
Jeremy Huddleston (jeremyhu) wrote :

I also notice "vbetool post" consuming 100% CPU during resume. See this bug report for more info on the specific problem, but there's an oops before vbetool gets run, so vbetool's hangup may be an artifact of another bug (but it should still not sit and spin).

https://bugs.launchpad.net/ubuntu/+bug/367134

Noah (noahod) wrote :

I get the same problem on my HP Compaq nx8420 laptop with Radeon Mobility X1600 and open source ati driver,

The screen backlight is off on resume, so I ctrl-alt-f7 to return to desktop and then killall vbetool to stop 100% cpu usage, which returns me to a blank screen, so I ctrl-alt-f7 and I'm back to normal.

Jaunty Jackalope fresh install up to date as of May 1, 2009.

Luka Renko (lure) wrote :

Noah: your laptop probably does not need vbetool to run on resume at all, this is why I have modified my HAL scripts to fix it for similar laptop (nw8440).

You may want to check this file:
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-hp.fdi

You could try adding ";nw8240" to the same line where you can find "nw8440"

Noah (noahod) wrote :

Confirmed, this did fix my problem, Thanks Luka.

Only change is my machine is an nx series not nw eg added ;nx8420 to /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-hp.fdi and it solved my problem.

Changed in vbetool (Ubuntu):
status: Confirmed → Triaged
Dimitrios Symeonidis (azimout) wrote :

Luka Renko has suggested a fix (the editing of the file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-hp.fdi), and Noah has confirmed this fix resolves the issue for him.

Jeremy, Diaboflo, Excentrik, Dan, Nobu, Sebrockcan you please try to verify this fix also resolves the issue for you?

Also please note that "dpkg -S /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-hp.fdi" returns the package "hal-info", in the end we might re-assign this bug...

diaboflo (ubuntu-diaboflo) wrote :

on my Acer Travelmate 4002 wlmi with an ATI Radeon Mobility 9700
I do need to use vbe-post-quirk. without it the machine won't wake up from resume.

Still the vbetool hangs and I have to kill it to turn the screen back on and continue with the resume.

On a seperate note: /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi doesn't add the right quirks for me, but that really is a different bug.

Nobu (benjo316) wrote :

Dimitrios Symeonidis, I am currently unable to suspend at all, so I can't really confirm at this point.

Normal suspend just blanks the screen, and the computer never goes into suspend mode (fans are still blowing, the power light stays solid on instead of flashing like it usually does). I've attached the log file which appears to have been created when it suspended. It seems to indicate that suspend was successful, but no amount of key presses brings it back, and pressing the power button doesn't do anything(except turn it off, if you hold it). Pressing alt+SysRq+B reboots the computer, so apparently the kernel is still functional.

My bios has an option to choose S1, S3, or both for suspend; I'm not sure which I should choose. I tried uswsusp's s2ram again, and that got further if I did `s2ram -f --acpi_sleep 1` with the bios set to S3, but that would hang on resume with the power light still flashing and the kernel unresponsive.

I'll try modifying the file and attempting suspend again, and see if that works.

Toby Smithe (tsmithe) wrote :

I also experience this bug. I'm completely ignorant apart from my knowledge of the information below:

xserver-xorg-video-ati:
  Installed: 1:6.12.99+git20090531.7599dc40-0ubuntu0tormod

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Mobility Radeon HD 3400 Series [1002:95c4]
 Subsystem: Dell Device [1028:029f]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR+ <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Region 1: I/O ports at 2000 [size=256]
 Region 2: Memory at cfef0000 (32-bit, non-prefetchable) [size=64K]
 [virtual] Expansion ROM at cfe00000 [disabled] [size=128K]
 Capabilities: <access denied>

Relevant lines from dmesg after resume:

[46786.933471] [drm] Resetting GPU
[46795.967413] Modules linked in: usblp aes_x86_64 aes_generic ecb binfmt_misc ppdev radeon drm bridge stp bnep vboxnetflt vboxdrv kqemu input_polldev dm_crypt sbp2 lp parport joydev btusb psmouse dcdbas iTCO_wdt iTCO_vendor_support serio_raw pcspkr ricoh_mmc sdhci_pci sdhci ieee80211_crypt_tkip wl(P) ieee80211_crypt uvcvideo compat_ioctl32 videodev v4l1_compat snd_hda_intel snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event video output snd_seq snd_timer snd_seq_device snd soundcore snd_page_alloc intel_agp usbhid ohci1394 ieee1394 tg3 fbcon tileblit font bitblit softcursor
[46816.902145] [drm] Loading RV620 CP Microcode
[46816.902478] [drm] Loading RV620 PFP Microcode
[46816.917417] [drm] Resetting GPU

diaboflo (ubuntu-diaboflo) wrote :

adding this file cures my problem. I know it inappropriate, but hey I can suspend and resume now.

#!/bin/sh
#/usr/lib/pm-utils/sleep.d/99zkill-vbetool
killvbe() {
        sleep 2
        killall vbetool
}

if [ "$1" = "resume" ]
  then
        killvbe &
fi
exit 0

RichardN (richardn) wrote :

I have this problem to. I'm using Karmic on an HP Dv2 laptop. I have the same issue with suspend/resume as the initial poster - I have to switch virtual terminals and then back to get output then vbetool uses (close to) 100% CPU. After that killing the vbetool post process causes another one to be spawned. Using "killall vbetool" causes the video display to crash at point I need to switch virtual terminals again and then vbetool gets restarted. Also, suspend resume only seems to work the first time. I can't do it a again.

Bowmore (bowmore) wrote :

I've run into this same problem as well. Have an old laptop Dell Latitude CPi from the late 90th and need to force acpi using the kernel option acpi=force.

I've run Xubuntu Hardy earlier where suspend to mem worked great. Now when installing Karmic the other day suspend to mem no longer works.

I have the same behaviour, i.e after recovering from suspend I have to ctrl+alt+f2/f7 to get back and then kill vbetool, use ctrl+alt+f2/f7 again to recover without vbetool running and back to normal load.

Thanx, the workaround it post #20 works for me too until fixed.

Tom Dison (fretinator) wrote :

For what it's worth, I just uninstalled the vbetool package. It also asked to uninstall the related package acpi-support. I let it. I've had no problem since. Suspend works perfectly, no acpi problems (frequency scaling, etc). Don't know why this package is enabled by default, but I kissed it good-bye. Ubuntu 9.04, 32-bit on a Toshiba Portege 3505.

Maybe I'll try to uninstall the vbetool package and the related ones.
I have ubuntu 9.04 on a Acer Aspire One D250, and to fit perfectly my
ubuntu version with my netbook, I installed a kernel properly modiefied
to support pousblo drivers for video card...so I'm a bit afraid to do
what you have done!
What do tou think about it??

Tom Dison ha scritto:
> For what it's worth, I just uninstalled the vbetool package. It also
> asked to uninstall the related package acpi-support. I let it. I've had
> no problem since. Suspend works perfectly, no acpi problems (frequency
> scaling, etc). Don't know why this package is enabled by default, but I
> kissed it good-bye. Ubuntu 9.04, 32-bit on a Toshiba Portege 3505.
>
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers