valgrind crashes on programs linked to openssl

Bug #1574437 reported by Rusty Russell on 2016-04-25
132
This bug affects 26 people
Affects Status Importance Assigned to Milestone
valgrind (Ubuntu)
High
Unassigned

Bug Description

Valgrind crashes when run on all applications linked to openssl.

Valgrind reports:

vex: the `impossible' happened:
   isZeroU

valgrind: the 'impossible' happened:
   LibVEX called failure_exit().

Upstream bug with fix is https://bugs.kde.org/show_bug.cgi?id=356393

Rusty Russell (rusty-rustcorp) wrote :

Not sure where I say this is 16.04, valgrind is: 1:3.11.0-1ubuntu4, platform amd64.

Mike Holmes (mike-holmes) wrote :

Since updating to 16.04 I see the same issues in OpenSSL linked apps.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in valgrind (Ubuntu):
status: New → Confirmed

When this issue will be fixed (on 16.10)?
It is pretty annoying as it makes valgrind completely unusable for me.
And I use it in nightly builds.
And now valgrind step is useless.

Fix it please.

Ken McDonell (kenj) wrote :

+1 for getting a fix please (like you're competitor distros have been able to do).

This is killing PCP (www.pcp.io) QA on all Ubuntu 16.04 platforms.

Dave O (cxreg) wrote :

This is pretty frustrating, can you please release the fix?

Martin Bergner (martin-bergner) wrote :

This renders valgrind in a useless state, where is the issue that hinders fixing this bug?

tags: added: xenial
description: updated
summary: - valgrind vex the `impossible' happened: isZeroU
+ valgrind crashes on programs linked to openssl
Changed in valgrind (Ubuntu):
importance: Undecided → High
Jan Wielemaker (jan-swi-prolog) wrote :

Why is a high priority bug not patched after almost two months while doing so is trivial? This blocks anyone using the most valuable debugging tool who works on an application that is linked to SSL ...

Is there a valgrind PPA as a work-around, or is compiling from source the only way?

Krishnaraj (krrishnarraj) wrote :

I upgraded manually using the deb from https://launchpad.net/ubuntu/+source/valgrind
version 3.12.0 in "The Yakkety Yak" has the fix. This deb works on xenial too

Robert (robgolebiowski) wrote :

Hi, since this patch is available in unbuntu's valgrind repo. I have created small blog post on how to get the latest valgrind repo and build it. Check it out:
https://robgolebiowski.wordpress.com/2016/08/19/valgrind-failing-on-ubuntu/

Corrado (whitefield87) wrote :

Hi I'm having a weird problem with this crash, I'm developing a server in C and if I run it on valgrind in Ubuntu 16.04 desktop I have no problem, BUT if I run it on Ubuntu Server 16.04 it crashes. Any Idea of the root cause?

Corrado (whitefield87) wrote :

ok I compiled the last version available now from source (valgrind-3.12.0.SVN) and it runs fine

Brad Parker (cbparker) wrote :

I just tried compiling the latest git version and the issue still remains for me.

On Sat, Oct 08, 2016 at 10:57:10PM -0000, Brad Parker wrote:
> Valgrind crashes when run on all applications linked to openssl.
>
> Valgrind reports:
>
> vex: the `impossible' happened:
> isZeroU
>
> valgrind: the 'impossible' happened:
> LibVEX called failure_exit().
>
>
> Upstream bug with fix is https://bugs.kde.org/show_bug.cgi?id=356393

This has been fixed upstream a very long time ago.
At this point it makes more sense to start testing and packaging
the new upstream release to see if it solves any outstanding issues
on Ubuntu. The beta is already out, final release will be October 20.

https://sourceforge.net/p/valgrind/mailman/message/35405831/

    A beta tarball for 3.12.0 is now available at
    http://www.valgrind.org/downloads/valgrind-3.12.0.BETA1.tar.bz2
    (md5sum = cb91572285f0072861a23ed8531b1829)

    Please give it a try in configurations that are important for you, and
    report any problems you have, either on this mailing list, or
    (preferably) via our bug tracker at
    https://bugs.kde.org/enter_bug.cgi?product=valgrind

    If nothing critical emerges, a final release will happen on
    Thursday 20 October.

Andrew McDermott (frobware) wrote :

Amy update on when this will land in the archives?

Sven Eppler (ubuntu-one-q) wrote :

We are affected by this bug too. HTTP SSL Tests no fail under Valgrind, so we have to disable those tests. Unsatisfying situation.

Alexander Sashnov (sashnov) wrote :

for Ubuntu 16.04 valgrind 3.12.0 from PPA https://launchpad.net/~hola-launchpad/+archive/ubuntu/valgrind works just fine :) No this crash with curl/SSL application.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.