[SRU] Update to vala 0.40.23 in bionic

Bug #1874127 reported by Rico Tzschichholz on 2020-04-21
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vala (Ubuntu)
Low
Unassigned
Bionic
Low
Unassigned

Bug Description

The 0.40.x series is maintained as LTS release and will receive further bug fix releases in the future. See https://wiki.gnome.org/Projects/Vala

Previous 0.40.19 SRU https://bugs.launchpad.net/bugs/1863609

Falls under the standing GNOME SRU exception
https://wiki.ubuntu.com/StableReleaseUpdates#GNOME

Upstream changes since 0.40.19:

Vala 0.40.23
============
 * Regression and bug fixes:
  - codegen:
    + Correctly handle cast-expression of real struct to nullable struct [#991]
    + Use loop index instead of get_ccode_pos() for ellipsis parameter [#995]
  - vala:
    + Allow node_ref being null in SemanticAnalyzer.get_instance_base_type()
    + SemanticAnalyzer.get_instance_base_type() is not allowed to return null
    + Set value_type of undefined member-access to avoid further criticals
    + Transform cast from floating-type to boxed-type [#991]
    + Transform cast from integer-type to boxed-type [#992]
  - girparser: Add support for boolean "new" argument for methods

Vala 0.40.22
============
 * Regression and bug fixes:
  - Revert "vala: Set default_construction_method in semantic-analyzer check
    if required" [#982]

Vala 0.40.21
============
 * Various improvements and bug fixes:
  - codegen:
    + Don't append unreachable clean-up section of Block [#838]
    + Emit postconditions before free'ing local variables
    + Correctly access captured parameter in precondition of method [#144]
    + Append initializer for "_*_size_" of array field in internal struct
    + Avoid critical trying to serialize an unsupported type to Variant [#952]
    + Don't free value if property setter takes ownership [#953]
    + Correct field declaration for captured inline-allocated array [#954]
    + Correctly handle transformation of translated string-literal constants
    + Don't pass CCodeCastExpression to NULL-aware free macro [#953]
    + Fix binary 'in' operator on array with boxed value-typed needle [#951]
    + Add support for delegate parameters in signals [#205]
    + Use get_value_*_function() in GSignalModule.generate_marshaller() [#468]
    + Correctly handle signals returning real non-nullable struct [#466]
    + Use specified indices to access multidimensional array constants [#905]
    + codegen: Reduce code duplications when generation base-access
    + Fix base-access to non-abstract/non-virtual properties [#204]
    + Fix default of CCode.pos for parameters in async methods
  - vala:
    + Support struct initializer list in non-constant array [#949]
    + Handle unlock() statement in CodeWriter
    + Handle all ctors and dtors in CodeWriter
    + Consider boolean types are compatible with each other
    + Parse standalone integer/real literals as expression statement [#961]
    + Set default_construction_method in semantic-analyzer check if required
    + Fix cleaning of output in CodeContext.pkg_config_modversion()
    + Don't use possibly uninitialized backing field of package_name [#971]
    + Check assigned handler of dynamic signal before proceeding further
    + Don't perform version check on internal lambda method
    + Perform version check for types of non-external variable declarations
    + Quote symbol on report by version attribute check
    + Ensure non-empty argument list for "disconnect" before accessing it
  - girparser
    + Move special handling for certain parameters to process_callable()
    + Drop special handling of GLib.Data, GLib.PtrArray and GLib.String
    + Improve detection of AsyncReadyCallback/AsyncResult parameters [#340]
  - parser: Handle incomplete expression statements
  - testrunner: Compile and run tests separately
  - testrunner: Warnings and criticals should be fatal on compile time too

 * Bindings:
  - gio-2.0: Add "async_result_pos" attributes to *.call_with_unix_fd_list()
    [#340]
  - glib-2.0: Guard Pid.to_string() with GLIB_2_50 to deal with G_PID_FORMAT
  - gstreamer-app-1.0: Don't merge Src.push_buffer_*() signal with its method
    [#968]
  - gtk+-3.0: Update to 3.24.18
  - webkit2gtk-4.0: Update to 2.28.0 [#974]

Vala 0.40.20
============
 * Various improvements and bug fixes:
  - codegen:
    + Don't initialize stack-allocated array with local-constant length [#910]
    + Add destroy of parameter in vfunc of delegate property setter [#919]
    + Reset outdated array _size_ variable after use as ref parameter [#929]
    + Use memset to init inline-allocated array with non-constant size [#910]
  - vala:
    + Properly set CodeNode.error when reporting an error
    + Improve robustness of analyzer pass for language-servers [#911]
    + Add local-variables to current scope regardless its error state
    + Fix circular reference in Property/EnumValueType
    + Report an internal error for unavailable context and bail
    + Prevent possible stack-overflow in Class.is_subtype_of()
    + Fix search for Parameter.base_parameter
    + Use error() instead of Report.error() inside of CodeContext.get()
    + Accept enum-values as length for inline allocated arrays [#935]
    + Improve copy of required attributes from delegate to lamdba method
    + Inherit lambda parameter attributes from delegate
    + Inline-allocated array aren't instantiated with creation expression [#926]
  - Add missing CodeContext.pop() calls
  - girparser:
    + Report a warning for conflicting class and instance methods
    + Decrease return_array_length_idx for transformed function
    + Delay adding of "GLib.Object" prerequisite to interfaces
  - vapigen: Define "GOBJECT" corresponding to set profile of CodeContext [#933]
  - valadoc: Create and register current Vala.CodeContext properly
  - parser: Improve error message for invalid ArrayCreationExpression [#939]
  - testrunner: Pass G_DEBUG=fatal-warnings to invalid test
  - manual: Update from wiki.gnome.org

 * Bindings:
  - Add some fundamental deps files to improve --nostdpkg support [#911]
  - glib-2.0: Add binding for g_poll() [#924]
  - glib-2.0: Add binding for g_win32_ftruncate()
  - glib-2.0: Add missing IOChannel's win32 API
  - glib-2.0: Add missing "type_id"/"has_type_id" attributes to structs [#921]
  - glib-2.0: Memory profiling ("g_mem_*") is deprecated since 2.46
  - gio-2.0: Add binding for g_io_error_from_win32_error()

summary: - [SRU] Update to vala 0.40.21 in bionic
+ [SRU] Update to vala 0.40.22 in bionic
description: updated
Mathew Hodson (mhodson) on 2020-04-29
Changed in vala (Ubuntu):
importance: Undecided → Low
Changed in vala (Ubuntu Bionic):
importance: Undecided → Low
Changed in vala (Ubuntu):
status: New → Fix Released
tags: added: upgrade-software-version
Rico Tzschichholz (ricotz) wrote :

0.40.23 will be available soon, so better to pick up this one

summary: - [SRU] Update to vala 0.40.22 in bionic
+ [SRU] Update to vala 0.40.23 in bionic
description: updated
Sebastien Bacher (seb128) wrote :

it's uploaded and waiting for SRU team review

Changed in vala (Ubuntu Bionic):
status: New → Fix Committed

Hello Rico, or anyone else affected,

Accepted vala into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vala/0.40.23-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers