Please update vala in bionic to 0.40.4

Bug #1764389 reported by Jeremy Bicha on 2018-04-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vala (Ubuntu)
Undecided
Unassigned

Bug Description

vala is part of the GNOME SRU micro release exception.

My understanding is that vala 0.40.4 fixes an issue where gitg would break if it were rebuilt against bionic's vala.

I'm filing this bug for tracking since we are late in Ubuntu 18.04's release cycle.

Rico Tzschichholz (ricotz) wrote :

The gitg problem was caused by a gtk+ binding regression which is fixed in 0.40.4.

https://git.gnome.org/browse/vala/diff/vapi/gtk+-3.0.vapi?h=0.40&id=8f9fa7cd09891f046504f296d75bd2c00c87966f

Jeremy Bicha (jbicha) on 2018-04-16
Changed in vala (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vala - 0.40.4-1

---------------
vala (0.40.4-1) unstable; urgency=medium

  * New upstream release (LP: #1764389)

 -- Jeremy Bicha <email address hidden> Mon, 16 Apr 2018 08:16:42 -0400

Changed in vala (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers