package valac-0.16-vapi (not installed) failed to install/upgrade: trying to overwrite '/usr/share/vala-0.16/vapi/ccss-1.vapi', which is also in package valac-0.16 0.15.2-0ubuntu1

Bug #961740 reported by Evan Huus on 2012-03-21
112
This bug affects 13 people
Affects Status Importance Assigned to Milestone
vala-0.16 (Ubuntu)
High
Martin Pitt
Precise
High
Martin Pitt

Bug Description

Was just running update-manager as normal and this popped up. Had to clean things up manually in synaptic.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: valac-0.16-vapi (not installed)
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Wed Mar 21 18:53:08 2012
DuplicateSignature:
 Unpacking valac-0.16-vapi (from .../valac-0.16-vapi_0.15.2-1_all.deb) ...
 dpkg: error processing /var/cache/apt/archives/valac-0.16-vapi_0.15.2-1_all.deb (--unpack):
  trying to overwrite '/usr/share/vala-0.16/vapi/ccss-1.vapi', which is also in package valac-0.16 0.15.2-0ubuntu1
ErrorMessage: trying to overwrite '/usr/share/vala-0.16/vapi/ccss-1.vapi', which is also in package valac-0.16 0.15.2-0ubuntu1
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
SourcePackage: vala-0.16
Title: package valac-0.16-vapi (not installed) failed to install/upgrade: trying to overwrite '/usr/share/vala-0.16/vapi/ccss-1.vapi', which is also in package valac-0.16 0.15.2-0ubuntu1
UpgradeStatus: Upgraded to precise on 2012-01-14 (67 days ago)

Related branches

Evan Huus (eapache) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vala-0.16 (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

I just got this, too.

Changed in vala-0.16 (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
milestone: none → ubuntu-12.04-beta-2
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vala-0.16 - 0.15.2-1ubuntu1

---------------
vala-0.16 (0.15.2-1ubuntu1) precise; urgency=low

  * debian/control: Add Breaks:/Replaces to older vala-0.16 Ubuntu versions
    which previously shipped the vapi files. (LP: #961740)
 -- Martin Pitt <email address hidden> Thu, 22 Mar 2012 20:38:28 +0100

Changed in vala-0.16 (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers