libvala-0.12-dev should conflict with libvala-0.10-dev, and viceversa ('/usr/share/aclocal/vala.m4')

Bug #843950 reported by Radu Cristescu on 2011-09-07
54
This bug affects 7 people
Affects Status Importance Assigned to Milestone
vala-0.16 (Ubuntu)
Low
Unassigned

Bug Description

package libvala-0.12-dev (not installed) failed to install/upgrade: trying to overwrite '/usr/share/aclocal/vala.m4', which is also in package libvala-0.10-dev 0.10.4-1ubuntu1

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: libvala-0.12-dev (not installed)
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic i686
NonfreeKernelModules: nvidia
AptOrdering:
 libvala-0.12-dev: Install
 libvala-0.12-dev: Configure
Architecture: i386
Date: Wed Sep 7 15:37:50 2011
DpkgTerminalLog:
 Unpacking libvala-0.12-dev (from .../libvala-0.12-dev_0.12.0-0ubuntu1_i386.deb) ...
 dpkg: error processing /var/cache/apt/archives/libvala-0.12-dev_0.12.0-0ubuntu1_i386.deb (--unpack):
  trying to overwrite '/usr/share/aclocal/vala.m4', which is also in package libvala-0.10-dev 0.10.4-1ubuntu1
ErrorMessage: trying to overwrite '/usr/share/aclocal/vala.m4', which is also in package libvala-0.10-dev 0.10.4-1ubuntu1
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
SourcePackage: vala
Title: package libvala-0.12-dev (not installed) failed to install/upgrade: trying to overwrite '/usr/share/aclocal/vala.m4', which is also in package libvala-0.10-dev 0.10.4-1ubuntu1
UpgradeStatus: Upgraded to natty on 2011-05-01 (128 days ago)

Radu Cristescu (radu.c) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vala (Ubuntu):
status: New → Confirmed
summary: libvala-0.12-dev should conflict with libvala-0.10-dev, and viceversa
+ ('/usr/share/aclocal/vala.m4')
affects: vala (Ubuntu) → vala-0.16 (Ubuntu)
Changed in vala-0.16 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vala-0.16 - 0.15.1-0ubuntu2

---------------
vala-0.16 (0.15.1-0ubuntu2) precise; urgency=low

  * debian/libvala-0.16-dev.install: updated, upstream stopped installing
    the aclocal macros when --disable-unversioned is used (lp: #843950)
 -- Sebastien Bacher <email address hidden> Thu, 26 Jan 2012 23:26:49 +0100

Changed in vala-0.16 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments