forces removal of virtualbox-4.2

Bug #1125097 reported by Andrew Schulman on 2013-02-14
This bug affects 8 people
Affects Status Importance Assigned to Milestone
vagrant (Ubuntu)

Bug Description

I'm trying to install vagrant 1.0.1-1. On my host virtualbox is not installed, but virtualbox-4.2 from is. To my surprise, installing vagrant wants to force installation of virtualbox, which forces uninstallation of virtualbox-4.2:

# apt-get install vagrant
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libgsoap1 ruby-archive-tar-minitar ruby-childprocess ruby-erubis ruby-ffi ruby-i18n ruby-json ruby-log4r ruby-net-scp
  ruby-net-ssh rubygems virtualbox virtualbox-dkms virtualbox-qt
Suggested packages:
  virtualbox-guest-additions-iso vde2
The following packages will be REMOVED:
The following NEW packages will be installed:
  libgsoap1 ruby-archive-tar-minitar ruby-childprocess ruby-erubis ruby-ffi ruby-i18n ruby-json ruby-log4r ruby-net-scp
  ruby-net-ssh rubygems vagrant virtualbox virtualbox-dkms virtualbox-qt
0 upgraded, 15 newly installed, 1 to remove and 0 not upgraded.
Need to get 24.5 MB of archives.
After this operation, 59.1 MB disk space will be freed.

I can't figure out why this should happen, because AFAICT vagrant only recommends virtualbox, it doesn't depend on it.

It would be nice if vagrant didn't force uninstallation of virtualbox-4.2. It would be even nicer if vagrant would accept virtualbox-4.2 as providing the virtualbox package.

Thanks, Andrew.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: vagrant (not installed)
ProcVersionSignature: Ubuntu 3.2.0-37.58-generic 3.2.35
Uname: Linux 3.2.0-37-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Thu Feb 14 06:20:55 2013
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MarkForUpload: True
SourcePackage: vagrant
UpgradeStatus: Upgraded to precise on 2013-01-13 (31 days ago)

Andrew Schulman (andrex) wrote :
Laurent Bigonville (bigon) wrote :


IMHO, this is a bug on the oracle virtualbox package. Their package should "Provides: virtualbox" I guess. Vagrant package is only Recommending the virtualbox package, you could try to install it with the --no-install-recommends apt-get flag.

I'm closing this bug as invalid

Changed in vagrant (Ubuntu):
status: New → Invalid
Andrei Dziahel (develop7) wrote :

@bigon: It does:
> $ aptitude show virtualbox-4.2 | grep '^Provides'
> Provides: virtualbox

Changed in vagrant (Ubuntu):
status: Invalid → Confirmed

This is because

* virtualbox is both a real (from Ubuntu) and virtual (from Oracle) package.

* The Ubuntu vagrant contains:
Recommends: virtualbox (>= 4.0)

If a relationship field has a version number attached, only real packages will be considered to see whether the relationship is satisfied (or the prohibition violated, for a conflict or breakage). In other words, if a version number is specified, this is a request to ignore all Provides for that package name and consider only real packages. The package manager will assume that a package providing that virtual package is not of the "right" version.

If you remove the version from the Recommends line it works ok.

I can also confirm using --no-install-recommends works.

Schlomo Schapiro (sschapiro) wrote :

Please remove the version requirement from the Recommends. Any recent distro will have at least virtualbox => 4.0 so that this version is not neccessary, strictly speaking.

hackel (hackel) wrote :

If you want to use the Oracle Virtualbox package, then why don't you just use the Vagrant team's (terrible) package as well? I don't think Ubuntu should be changed to accommodate poor external packages. Ubuntu Vagrant works well with Ubuntu Virtualbox, which is exactly how it should be. This should be re-closed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments