v86d prevents suspend from completing

Bug #1080530 reported by Ryan T. Sammartino on 2012-11-19
174
This bug affects 29 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury
Precise
Medium
Joseph Salisbury
v86d (Ubuntu)
Medium
Unassigned

Bug Description

After updating this system to latest packages a few days ago, suspend has stopped working.

After each attempt at suspend the following is output in dmesg:

[17195.571338] PM: Syncing filesystems ... done.
[17195.573669] PM: Preparing system for mem sleep
[17195.573677] Freezing user space processes ... (elapsed 0.01 seconds) done.
[17195.588058] Freezing remaining freezable tasks ...
[17215.604036] Freezing of tasks failed after 20.01 seconds (1 tasks refusing to freeze, wq_busy=0):
[17215.604068] v86d S ffffffff81806200 0 553 1 0x00c00000
[17215.604072] ffff88011b61d9d8 0000000000000082 ffff88011b61d9e8 ffffffff8104fc1c
[17215.604076] ffff88011b61dfd8 ffff88011b61dfd8 ffff88011b61dfd8 00000000000137c0
[17215.604079] ffffffff81c0d020 ffff88011b7c2e00 000000000001bf90 0000000000000000
[17215.604081] Call Trace:
[17215.604089] [<ffffffff8104fc1c>] ? wake_affine+0x14c/0x310
[17215.604094] [<ffffffff81659ebf>] schedule+0x3f/0x60
[17215.604097] [<ffffffff8165afed>] schedule_hrtimeout_range_clock+0x14d/0x170
[17215.604100] [<ffffffff8103dcf9>] ? default_spin_lock_flags+0x9/0x10
[17215.604103] [<ffffffff8108ad0d>] ? add_wait_queue+0x4d/0x60
[17215.604105] [<ffffffff8165b023>] schedule_hrtimeout_range+0x13/0x20
[17215.604108] [<ffffffff8118b069>] poll_schedule_timeout+0x49/0x70
[17215.604110] [<ffffffff8118b5ba>] do_poll.isra.4+0x1ca/0x290
[17215.604113] [<ffffffff8104c368>] ? __wake_up_common+0x58/0x90
[17215.604115] [<ffffffff8156c81e>] ? netlink_unicast+0x2be/0x300
[17215.604118] [<ffffffff8118c579>] do_sys_poll+0x1d9/0x260
[17215.604120] [<ffffffff8118b170>] ? poll_freewait+0xe0/0xe0
[17215.604122] [<ffffffff8118b260>] ? __pollwait+0xf0/0xf0
[17215.604124] [<ffffffff8156c996>] ? netlink_sendmsg+0x136/0x390
[17215.604127] [<ffffffff8152a94e>] ? sock_sendmsg+0x10e/0x130
[17215.604130] [<ffffffff8113d92a>] ? handle_pte_fault+0xfa/0x200
[17215.604132] [<ffffffff8113dde8>] ? handle_mm_fault+0x1f8/0x350
[17215.604135] [<ffffffff8152dfdd>] ? sys_sendto+0x13d/0x190
[17215.604137] [<ffffffff8165986c>] ? __schedule+0x3cc/0x6f0
[17215.604140] [<ffffffff81015bf8>] ? sys_ioperm+0x138/0x1f0
[17215.604143] [<ffffffff8118c6e6>] sys_poll+0x76/0x110
[17215.604145] [<ffffffff816643c2>] system_call_fastpath+0x16/0x1b
[17215.604190]
[17215.604191] Restarting tasks ... done.
[17215.606735] video LNXVIDEO:00: Restoring backlight state
[17216.403527] forcedeth 0000:00:0a.0: irq 41 for MSI/MSI-X
[17227.352029] eth0: no IPv6 routers present

Prior to the updates a few days ago suspend/wake worked perfectly on this system.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: v86d 0.1.10-1
ProcVersionSignature: Ubuntu 3.2.0-34.53-generic 3.2.33
Uname: Linux 3.2.0-34-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu15
Architecture: amd64
Date: Sun Nov 18 18:37:57 2012
EcryptfsInUse: Yes
MarkForUpload: True
SourcePackage: v86d
UpgradeStatus: Upgraded to precise on 2012-05-20 (182 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in v86d (Ubuntu):
status: New → Confirmed
Filip Milivojevic (zekica) wrote :

I'm using v86d for uvesafb, with fglrx and have the same issue.

Also, it may help that it works with linux-image-3.2.0-33-generic-pae and fails to suspend with linux-image-3.2.0-34-generic-pae

Jason Kern (jaskerx) wrote :

Sounds like what I'm experiencing as suspend will work with 3.2.0-33 but not with 3.2.0-34. I am hesitant to mark this bug as affecting me because nothing about v86d appears in dmesg log. No idea other than the kernel what is causing this.

Jason Kern (jaskerx) wrote :

After checking syslog I'm getting the same thing when trying to suspend:

[ 7354.174209] PM: Syncing filesystems ... done.
[ 7354.176280] PM: Preparing system for mem sleep
[ 7354.176291] Freezing user space processes ... (elapsed 0.01 seconds) done.
[ 7354.192042] Freezing remaining freezable tasks ...
[ 7374.208027] Freezing of tasks failed after 20.01 seconds (1 tasks refusing to freeze, wq_busy=0):
[ 7374.208049] v86d S ffffffff81806200 0 214 1 0x00c00000
[ 7374.208054] ffff880113e339d8 0000000000000082 ffff880113e339e8 ffffffff8104fc1c
[ 7374.208060] ffff880113e33fd8 ffff880113e33fd8 ffff880113e33fd8 00000000000137c0
[ 7374.208064] ffffffff81c0d020 ffff8801139bc500 00000000000137c0 0000000000000000
[ 7374.208069] Call Trace:
[ 7374.208079] [<ffffffff8104fc1c>] ? wake_affine+0x14c/0x310
[ 7374.208085] [<ffffffff81659ebf>] schedule+0x3f/0x60
[ 7374.208089] [<ffffffff8165afed>] schedule_hrtimeout_range_clock+0x14d/0x170
[ 7374.208094] [<ffffffff8103dcf9>] ? default_spin_lock_flags+0x9/0x10
[ 7374.208098] [<ffffffff8108ad0d>] ? add_wait_queue+0x4d/0x60
[ 7374.208256] [<ffffffff8165b023>] schedule_hrtimeout_range+0x13/0x20
[ 7374.208260] [<ffffffff8118b069>] poll_schedule_timeout+0x49/0x70
[ 7374.208262] [<ffffffff8118b5ba>] do_poll.isra.4+0x1ca/0x290
[ 7374.208265] [<ffffffff8104c368>] ? __wake_up_common+0x58/0x90
[ 7374.208268] [<ffffffff8156c81e>] ? netlink_unicast+0x2be/0x300
[ 7374.208271] [<ffffffff8118c579>] do_sys_poll+0x1d9/0x260
[ 7374.208273] [<ffffffff8118b170>] ? poll_freewait+0xe0/0xe0
[ 7374.208276] [<ffffffff8118b260>] ? __pollwait+0xf0/0xf0
[ 7374.208278] [<ffffffff8156c996>] ? netlink_sendmsg+0x136/0x390
[ 7374.208282] [<ffffffff8152a94e>] ? sock_sendmsg+0x10e/0x130
[ 7374.208285] [<ffffffff8113dde8>] ? handle_mm_fault+0x1f8/0x350
[ 7374.208288] [<ffffffff8152dfdd>] ? sys_sendto+0x13d/0x190
[ 7374.208291] [<ffffffff8165986c>] ? __schedule+0x3cc/0x6f0
[ 7374.208294] [<ffffffff81015bf8>] ? sys_ioperm+0x138/0x1f0
[ 7374.208297] [<ffffffff8118c6e6>] sys_poll+0x76/0x110
[ 7374.208300] [<ffffffff816643c2>] system_call_fastpath+0x16/0x1b
[ 7374.208360]

Same on MacBook Pro 7.1 - can't suspend with exactly the same message in dmesg.

Fabrizio Narni (shiba89) wrote :

Same problem here. Too bad disabling uvesafb is not an option, since I need to switch to CTRL+ALT+Fx.

Changed in v86d (Ubuntu):
importance: Undecided → Medium
tags: added: regression-update
tags: added: kernel-da-key
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in linux (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
no longer affects: v86d (Ubuntu Precise)
Joseph Salisbury (jsalisbury) wrote :

This could be related to commit a4e4c2b50ad06537f700015c22bc67bee8c05b4c

I'll build a Precise test kernel with this commit reverted. If this commit is not the cause of this regression, we can perform a kernel bisect to identify the bad commit.

I'll post a link to a test kernel shortly.

Joseph Salisbury (jsalisbury) wrote :

I built a Precise test kernel with commit a4e4c2b50ad06537f700015c22bc67bee8c05b4c reverted.

The test kernel is available at:
http://people.canonical.com/~jsalisbury/lp1080530/

Can folks affected by this bug test that kernel and report back if it solves this bug?

tags: added: performing-bisect

My installation works as it should have been with this kernel. No v86d errors in dmesg during suspend :)

jsalisbury's kernel seems to be a solution. Been trying two installations for half a dozen times - no problems.

Fabrizio Narni (shiba89) wrote :

#9 solves for me too.

Mario (mamario1962) wrote :

Why my pc stated that a later version is already installed???

Joseph Salisbury (jsalisbury) wrote :

It would be good to know if this bug was fixed in the latest mainline kernel. Can folks affected by this bug also give the latest kernel a test:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-rc8-raring/

Andre (ajx) wrote :

Joseph's kernel (#9) solves the issue for us. Suspend works again. Thank you!

#14 I see no problem related to suspend & v86d in those builds.

Jason Kern (jaskerx) wrote :

Worked for me

cement_head (andor-udel) wrote :

Ok, I have this exact same problem. Kernel in Post #9 fixes for me. I don't test upstream kernels as they bork nVIDIA and VirtualBox.

- CH

Matze (matzman) wrote :

 #9 solved the problem in my case too.

cement_head (andor-udel) wrote :

@jsalisbury

One more thing. This kernel (Post #9) also fixed the problem of immediately suspending after resuming, which has been present since 12.04. In other words, I almost always have to resume "twice". Once resumes and then immediately resuspends, the second time, the machine resumes as stays up.

Thanks,
CH

Joseph Salisbury (jsalisbury) wrote :

A patch was provided by upstream[0]. I built a new test kernel with this patch applied. Can folks affected by this bug test this new kernel, which can be downloaded from:

http://people.canonical.com/~jsalisbury/lp1080530/

Thanks in advance!

[0] https://lkml.org/lkml/2012/12/6/135

Changed in linux (Ubuntu Precise):
status: Triaged → In Progress
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Joseph Salisbury (jsalisbury)
cement_head (andor-udel) wrote :

@jsalisbury

  New kernel (Post #22) works for me.

- CH

#22 - works for me too

Matze (matzman) wrote :

The same for me: #22 seems to work. Thanks.

Fabrizio Narni (shiba89) wrote :

No problem with #22.

cement_head (andor-udel) wrote :

Did this patch make it into this AM's kernel updates (Dec 6)?

cement_head (andor-udel) wrote :

Nope, it did not...

Ryan Novosielski (novosirj) wrote :

I am also affected by this bug. I use a Dell Latitude E6420. Same symptoms, worked fine before -34.

Ryan Novosielski (novosirj) wrote :

(my system is 32-bit though)

Mario (mamario1962) wrote :

My system is 34-bit with two s.o., Ubuntu and Kubuntu , both with kernel -34,(12.04.01) I found out the 'suspend problem' on ubuntu and is still not solved with yesterday new kernel version 3.2.0-35-generic-pae.
Kubuntu has installed the -34 one since two weeks and never had the 'suspend problem'.
Just for your knowledge.

Still no fix in mainstream?

todaioan (alan-ar06) on 2012-12-11
Changed in v86d (Ubuntu):
status: Confirmed → Fix Committed
Joseph Salisbury (jsalisbury) wrote :

This has been accepted upstream and will make it's way into precise through regular stable updates:

http://lkml.indiana.edu/hypermail/linux/kernel/1212.1/00260.html

Fabrizio Narni (shiba89) wrote :

Updated to -53.55 from precise-update. Bug still present.

#34 I confirm the same.

3.2.0-35-generic #55-Ubuntu SMP Wed Dec 5 17:42:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux - bug is still here

#22 - but this kernel build is not affected by this bug.

Mario (mamario1962) wrote :

3,2,0-35 is still affected by same bug.

cement_head (andor-udel) wrote :

I'm going to LOCK VERSION of the patched kernel (Post #22).

@jsalisbury, can you post to this bug report when the patch to the 3.2 kernel has been fixed in precise-proposed/backports?

Thanks,
CH

Fix commited but there is the fix?

cement_head (andor-udel) wrote :

@jsalisbury

Can you build a new kernel on the -36 series?

Or at least let us know how to patch the kernel?

Thanks,
CH

cement_head (andor-udel) wrote :

Here's a workaround for now using the kernels in Post #22, assuming that they are pinned "Lock Version" with Synaptic

1) $ sudo gedit /etc/default/grub

Change the line for:

GRUB_DEFAULT=0

to

GRUB_DEFAULT=2>0

close the file

$ sudo update-grub

reboot

Joseph Salisbury (jsalisbury) wrote :

The patch is still making it's way into Ubuntu from upstream. The patch has been accepted into 3.2.36[0]. The patch will make it's way into precise when the 3.2.36 updates are appled to precise.

[0] https://lkml.org/lkml/2013/1/3/484

Fabrizio Narni (shiba89) wrote :

Ok, so it will most likely be -37. Here you can find the kernel version mapping (scroll to Precise):
http://kernel.ubuntu.com/~kernel-ppa/info/kernel-version-map.html

cement_head (andor-udel) wrote :

yes, Ubuntu is out by one (Ubuntu -37 is mainline -36)

Changed in v86d (Ubuntu):
status: Fix Committed → Fix Released

Please discard previous status change.

Steve Langasek (vorlon) on 2013-01-20
Changed in v86d (Ubuntu):
status: Fix Released → Confirmed
cement_head (andor-udel) wrote :

Still broken in -37 kernel release.

Not fixed upstream, or was reverted (again) by Ubuntu

Fabrizio Narni (shiba89) wrote :

@cement_head
3.2.0-37.58 == 3.2.35 (http://kernel.ubuntu.com/~kernel-ppa/info/kernel-version-map.html)
This is so frustrating...

Can this patch be backported to 3.2.0-37? I need suspension, so I'm forced to load 3.2.0-33, and that's not a good thing...

Joseph Salisbury (jsalisbury) wrote :

The fix is in upstream 3.2.36, so it should be available in the next Precise kernel update.

cement_head (andor-udel) wrote :

awesomenesslying

I just installed the available 3.2.0-37-generic-pae from Ubuntu's update manager.
And the issue is not fixed. Suspend still doesn't work. :(

David Grossberg (davidgro) wrote :

Some of you might consider a workaround that I am now using for other reasons, which also bypasses this bug:

Use TuxOnIce (formerly Suspend2) instead.

It requires installing a kernel from the TuxOnIce PPA (and at least for now that means an older kernel), or compiling one yourself with the patch (which you could also do for this bug directly of course) but at least you get the other benefits: I am using it to suspend to a non-swap file so that hibernation will always work no matter how much stuff is running and using RAM+swap.

Fabrizio Narni (shiba89) wrote :

@Joost
That's because -37 is another .35

@Fabrizio

aha I get it now. So if I'm understanding it correctly we have no idea when this fix will be out?
And that kernel map is updated every day or so?

cement_head (andor-udel) wrote :

Fixed for me in the -38 kernel.

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Changed in linux (Ubuntu Precise):
status: Fix Released → Fix Committed

Thanks Joseph! Fixed in latest kernel update for me too!

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in v86d (Ubuntu):
status: Confirmed → Invalid
Hélio Nunes (dedalu-dedalu) wrote :

-38 fixed for me too. Thanks! I am really happy it is gone.

Yeah, thanks everybody who was involved!

Klaas Kouwen (kkouwen) wrote :

The -38 kernel doesn't solve the issue for me (Dell Latitude D630 32-bit) ...

Joseph Salisbury (jsalisbury) wrote :

@Klass Kouwen,

It's probably best to open a new bug for your issue.

Volkan Gezer (volkangezer) wrote :

It is same here.

Download full text (3.9 KiB)

Hi Volkan,

TuxOnIce helped me fix the problem. At first it did not seem to work,
but later on I noticed the laptop was suspending/hibernating.

Hope this also helps you,

Klaas

On 5/1/13, Volkan Gezer <email address hidden> wrote:
> It is same here.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1080530
>
> Title:
> v86d prevents suspend from completing
>
> Status in “linux” package in Ubuntu:
> Fix Released
> Status in “v86d” package in Ubuntu:
> Invalid
> Status in “linux” source package in Precise:
> Fix Released
>
> Bug description:
> After updating this system to latest packages a few days ago, suspend
> has stopped working.
>
> After each attempt at suspend the following is output in dmesg:
>
> [17195.571338] PM: Syncing filesystems ... done.
> [17195.573669] PM: Preparing system for mem sleep
> [17195.573677] Freezing user space processes ... (elapsed 0.01 seconds)
> done.
> [17195.588058] Freezing remaining freezable tasks ...
> [17215.604036] Freezing of tasks failed after 20.01 seconds (1 tasks
> refusing to freeze, wq_busy=0):
> [17215.604068] v86d S ffffffff81806200 0 553 1
> 0x00c00000
> [17215.604072] ffff88011b61d9d8 0000000000000082 ffff88011b61d9e8
> ffffffff8104fc1c
> [17215.604076] ffff88011b61dfd8 ffff88011b61dfd8 ffff88011b61dfd8
> 00000000000137c0
> [17215.604079] ffffffff81c0d020 ffff88011b7c2e00 000000000001bf90
> 0000000000000000
> [17215.604081] Call Trace:
> [17215.604089] [<ffffffff8104fc1c>] ? wake_affine+0x14c/0x310
> [17215.604094] [<ffffffff81659ebf>] schedule+0x3f/0x60
> [17215.604097] [<ffffffff8165afed>]
> schedule_hrtimeout_range_clock+0x14d/0x170
> [17215.604100] [<ffffffff8103dcf9>] ? default_spin_lock_flags+0x9/0x10
> [17215.604103] [<ffffffff8108ad0d>] ? add_wait_queue+0x4d/0x60
> [17215.604105] [<ffffffff8165b023>] schedule_hrtimeout_range+0x13/0x20
> [17215.604108] [<ffffffff8118b069>] poll_schedule_timeout+0x49/0x70
> [17215.604110] [<ffffffff8118b5ba>] do_poll.isra.4+0x1ca/0x290
> [17215.604113] [<ffffffff8104c368>] ? __wake_up_common+0x58/0x90
> [17215.604115] [<ffffffff8156c81e>] ? netlink_unicast+0x2be/0x300
> [17215.604118] [<ffffffff8118c579>] do_sys_poll+0x1d9/0x260
> [17215.604120] [<ffffffff8118b170>] ? poll_freewait+0xe0/0xe0
> [17215.604122] [<ffffffff8118b260>] ? __pollwait+0xf0/0xf0
> [17215.604124] [<ffffffff8156c996>] ? netlink_sendmsg+0x136/0x390
> [17215.604127] [<ffffffff8152a94e>] ? sock_sendmsg+0x10e/0x130
> [17215.604130] [<ffffffff8113d92a>] ? handle_pte_fault+0xfa/0x200
> [17215.604132] [<ffffffff8113dde8>] ? handle_mm_fault+0x1f8/0x350
> [17215.604135] [<ffffffff8152dfdd>] ? sys_sendto+0x13d/0x190
> [17215.604137] [<ffffffff8165986c>] ? __schedule+0x3cc/0x6f0
> [17215.604140] [<ffffffff81015bf8>] ? sys_ioperm+0x138/0x1f0
> [17215.604143] [<ffffffff8118c6e6>] sys_poll+0x76/0x110
> [17215.604145] [<ffffffff816643c2>] system_call_fastpath+0x16/0x1b
> [17215.604190]
> [17215.604191] Restarting tasks ... done.
> [17215.606735] video LNXVIDEO:00: Restoring backlight s...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions