[FTBFS] v4l-utils: stop building biarch package

Bug #808064 reported by Gregor Jasny
100
This bug affects 15 people
Affects Status Importance Assigned to Milestone
ia32-libs (Ubuntu)
High
Steve Langasek
Oneiric
High
Steve Langasek
v4l-utils (Ubuntu)
High
Martin Pitt
Oneiric
High
Martin Pitt
wine1.2 (Ubuntu)
High
Steve Langasek
Oneiric
High
Steve Langasek
wine1.3 (Ubuntu)
High
Steve Langasek
Oneiric
High
Steve Langasek

Bug Description

Hi,

I know the days of ia32-libs are counted but until it is removed from the archive and multiarch tooks over my package v4l-utils needs the libjpeg headers and so files to build.

In Debian I simply depend on ia32-libs-dev, but there is no such package in Ubuntu. That's why compilation of recent v4l-utils versions fail on amd64. Could you please provide ia32-libs-dev within ia32-libs?

Thanks,
Gregor

Gregor Jasny (gjasny)
description: updated
Revision history for this message
Steve Langasek (vorlon) wrote :

libjpeg is already multiarch-capable in Ubuntu, and the only reason v4l-utils wants ia32-libs is to build a biarch library package. The correct solution here is for v4l-utils to stop building lib32v4l-0 and lib32v4l-dev, which aren't used by anything else in the archive, and to instead migrate to multiarch itself.

affects: ia32-libs (Ubuntu) → v4l-utils (Ubuntu)
Changed in v4l-utils (Ubuntu):
status: New → Triaged
summary: - Please provide ia32-libs-dev dependency
+ v4l-utils: stop building biarch package
Changed in v4l-utils (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Steve Langasek (vorlon) wrote : Re: v4l-utils: stop building biarch package

Ah; correction, I see (when I run the right command) that ia32-libs, wine1.2 and wine1.3 all look for lib32v4l. Still, addressing this in ia32-libs would be a move in the wrong direction. I think this should still be fixed by dropping lib32v4l and fixing up the resulting breakage.

Martin Pitt (pitti)
Changed in v4l-utils (Ubuntu Oneiric):
assignee: nobody → Martin Pitt (pitti)
importance: Medium → High
milestone: none → ubuntu-11.10-beta-1
status: Triaged → In Progress
summary: - v4l-utils: stop building biarch package
+ [FTBFS] v4l-utils: stop building biarch package
tags: added: ftbfs
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package v4l-utils - 0.8.5-3ubuntu1

---------------
v4l-utils (0.8.5-3ubuntu1) oneiric; urgency=low

  * Stop building the lib32* packages on amd64. LP: #808064.
  * Package requires symbols jpeg_mem_src and jpeg_mem_dest from jpeg8.
    Build-depend on libjpeg8-dev.
 -- Matthias Klose <email address hidden> Thu, 25 Aug 2011 18:30:26 +0200

Changed in v4l-utils (Ubuntu Oneiric):
status: In Progress → Fix Released
Matthias Klose (doko)
Changed in wine1.2 (Ubuntu Oneiric):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
milestone: none → ubuntu-11.10-beta-1
status: New → Confirmed
Changed in wine1.3 (Ubuntu Oneiric):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
milestone: none → ubuntu-11.10-beta-1
status: New → Confirmed
Revision history for this message
Roland Dreier (roland.dreier) wrote :

So if I understand things correctly, in addition to wine we also need to drop the dep from ia32-libs too?

Revision history for this message
Daniel Holbach (dholbach) wrote :

Roland: yes, I would think so.

daniel@daydream:~$ LC_ALL=C sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  google-talkplugin ia32-libs lib32v4l-0
The following NEW packages will be installed:
  libjpeg8
The following packages will be upgraded:
  libv4l-0
1 upgraded, 1 newly installed, 3 to remove and 0 not upgraded.
Need to get 232 kB of archives.
After this operation, 117 MB disk space will be freed.
Do you want to continue [Y/n]?

Opening a ia32-libs task.

Steve Langasek (vorlon)
Changed in ia32-libs (Ubuntu Oneiric):
assignee: nobody → Steve Langasek (vorlon)
Changed in ia32-libs (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon)
Changed in ia32-libs (Ubuntu Oneiric):
importance: Undecided → High
Revision history for this message
Shanekpiper (shanekpiper) wrote :

Using Ubuntu 11.10, Alpha 3.

I had to uninstall wine1.2 as it had some unmet dependancies, Now I cant reinstall wine1.2 or 1.3

$ sudo apt-get install wine1.3
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.3 : Depends: ia32-libs (>= 1.6) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Steve Langasek (vorlon)
Changed in ia32-libs (Ubuntu Oneiric):
status: Confirmed → In Progress
Steve Langasek (vorlon)
Changed in wine1.2 (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in wine1.3 (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in wine1.2 (Ubuntu Oneiric):
assignee: Martin Pitt (pitti) → Steve Langasek (vorlon)
Changed in wine1.3 (Ubuntu Oneiric):
assignee: Martin Pitt (pitti) → Steve Langasek (vorlon)
Changed in ia32-libs (Ubuntu Oneiric):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 20090808ubuntu18

---------------
ia32-libs (20090808ubuntu18) oneiric; urgency=low

  * Add libv4l and libjpeg8 to ia32-libs, since lib32v4l-0 has been dropped,
    and drop the dependency on the separate package. LP: #808064.
  * Freshen packages.
 -- Steve Langasek <email address hidden> Fri, 26 Aug 2011 12:14:52 -0700

Changed in ia32-libs (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wine1.2 - 1.2.2-0ubuntu7

---------------
wine1.2 (1.2.2-0ubuntu7) oneiric; urgency=low

  * Drop build-depends on lib32v4l-dev; this is in ia32-libs now in oneiric.
    LP: #808064.
 -- Steve Langasek <email address hidden> Fri, 26 Aug 2011 19:50:38 +0000

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wine1.3 - 1.3.15-0ubuntu6

---------------
wine1.3 (1.3.15-0ubuntu6) oneiric; urgency=low

  * Drop build-depends on lib32v4l-dev; this is in ia32-libs now in oneiric.
    LP: #808064.
 -- Steve Langasek <email address hidden> Fri, 26 Aug 2011 19:14:21 +0000

Changed in wine1.2 (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in wine1.3 (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Revision history for this message
Rovano (rovano) wrote :

Fast worker...Steve :-)

Revision history for this message
Dejan (dejan-rodiger) wrote :

This bug also removed googleearth and skype packages, which don't have installation candidates (acroread is also missing), at least I think so.

Thanks for fixing wine and picasa (picasa needed wine)

Revision history for this message
Steve Langasek (vorlon) wrote : Re: [Bug 808064] Re: [FTBFS] v4l-utils: stop building biarch package

On Sat, Aug 27, 2011 at 01:14:20PM -0000, Dejan wrote:
> This bug also removed googleearth and skype packages, which don't have
> installation candidates (acroread is also missing), at least I think so.

You need to follow the instructions at
https://lists.ubuntu.com/archives/ubuntu-devel-announce/2011-August/000886.html
and install skype:i386 from the natty partner archive. The current version
of ia32-libs no longer provides the libraries needed by skype because these
are fully available by multiarch; as soon as there's a new i386-only skype
package for oneiric, ia32-libs will make this clear in its Breaks: field.

googleearth can also be built as an i386 package and installed via
multiarch, but for now installing it with ia32-libs is still ok.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Revision history for this message
Ben Collier (bcollier) wrote :

I have this exact bug (below) but I am still running Natty and came across this issue after an upgrade. Skype and Wine1.3 no longer work. Is there a separate bug for Natty, or how should I fix this? I checked out the link above, but I'm unclear on what I should do to resolve the issue.

$ sudo apt-get build-dep wine1.3
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have unmet dependencies:
 ia32-libs : Depends: lib32v4l-0 but it is not going to be installed
 lib32v4l-dev : Depends: libv4l-0 (= 0.8.3-2~ppa1) but 0.8.5-3u1~ppa1 is to be installed
                Depends: lib32v4l-0 (= 0.8.3-2~ppa1) but it is not going to be installed
                Depends: libv4l-dev (= 0.8.3-2~ppa1) but 0.8.5-3u1~ppa1 is to be installed
E: Build-dependencies for wine1.3 could not be satisfied.
$ cat /etc/issue
Ubuntu 11.04 \n \l

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"

Revision history for this message
Alexandre Anoutchine (xirius) wrote :

I have the same problem as Ben Collier. How can we fix it ?

Revision history for this message
Ben Collier (bcollier) wrote :

Alexandre,

I fixed the problem by doing two things, I'm not sure which one of them fixed it, or if both did it.

First, I went into the source in the Ubuntu Software Center and unchecked all the ppa's and everything basically that isn't the default Ubuntu (Multiverse, Universe, etc) sources.

Then I did

sudo apt-get install -f

And it installed 200+ MB worth of software and resolved all my dependencies. Hope that is helpful. I'm not 100% sure about the above line, but it was something -f and I think that is right.

Changed in v4l-utils (Ubuntu):
assignee: Martin Pitt (pitti) → Branko Nikolic (branko-r)
Steve Langasek (vorlon)
Changed in v4l-utils (Ubuntu):
assignee: Branko Nikolic (branko-r) → Martin Pitt (pitti)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers