Loading keymaps via udev is not reliable, please use upstream rule

Bug #1903966 reported by seahawk1986 on 2020-11-12
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
v4l-utils (Debian)
New
Unknown
v4l-utils (Ubuntu)
Low
Gregor Jasny

Bug Description

Dear Maintainer,

the udev rule installed from debian/ir-keytable.udev is not guaranteed to be run at the
appropriate moment during bootup which can cause the remote not to be
configured according to the settings in /etc/rc_maps.cfg. This seems to occur more often with newer kernel versions.

Please use the upstream version
(https://git.linuxtv.org/v4l-utils.git/tree/utils/keytable/70-infrared.rules) instead.
This commit message explains the need for this change:
https://git.linuxtv.org/v4l-utils.git/commit/utils/keytable/70-infrared.rules?id=e440918467868a5f3e7f73f54ef2cbd85d68f3f1

Description: Ubuntu 20.04.1 LTS
Release: 20.04

ir-keytable version: 1.18.0-2build1 and later

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in v4l-utils (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the package is coming directly from Debian, could you report the issue to them on

https://bugs.debian.org/cgi-bin/pkgreport.cgi?repeatmerged=no&src=v4l-utils ?

Changed in v4l-utils (Ubuntu):
importance: Undecided → Low
Gregor Jasny (gjasny) wrote :

Hi,

Debian maintainer here. I'll take care of the issue during the weekend.

Thanks,
Gregor

Sebastien Bacher (seb128) wrote :

@Gregor, thanks!

Gregor Jasny (gjasny) on 2020-11-20
Changed in v4l-utils (Ubuntu):
assignee: nobody → Gregor Jasny (gjasny)
Sebastien Bacher (seb128) wrote :
Changed in v4l-utils (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package v4l-utils - 1.20.0-2

---------------
v4l-utils (1.20.0-2) unstable; urgency=medium

  * Use upstream version of ir-keytable udev rule
    (Closes: #966166) (LP: #1903966)
  * Bump standards to version 4.5.1 (no changes needed)

 -- Gregor Jasny <email address hidden> Fri, 20 Nov 2020 14:50:43 +0100

Changed in v4l-utils (Ubuntu):
status: Fix Committed → Fix Released
Changed in v4l-utils (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.