package uwsgi 2.0.12-5ubuntu3.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1719363 reported by Emanuel Costa on 2017-09-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
uwsgi (Ubuntu)
Undecided
Unassigned

Bug Description

lsb_release -rd
Description: Ubuntu 16.04.3 LTS
Release: 16.04

Job for uwsgi.service failed because the control process exited with error code. See "systemctl status uwsgi.service" and "journalctl -xe" for details.
invoke-rc.d: initscript uwsgi, action "start" failed.
● uwsgi.service - LSB: Start/stop uWSGI server instance(s)
   Loaded: loaded (/etc/init.d/uwsgi; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-09-25 09:32:58 PDT; 3ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 22861 ExecStart=/etc/init.d/uwsgi start (code=exited, status=1/FAILURE)

Sep 25 09:32:58 bhansen-Inspiron-3847 systemd[1]: Starting LSB: Start/stop uWSGI server instance(s)...
Sep 25 09:32:58 bhansen-Inspiron-3847 uwsgi[22861]: * Starting app server(s) uwsgi
Sep 25 09:32:58 bhansen-Inspiron-3847 uwsgi[22861]: ...fail!
Sep 25 09:32:58 bhansen-Inspiron-3847 systemd[1]: uwsgi.service: Control process exited, code=exite...s=1
Sep 25 09:32:58 bhansen-Inspiron-3847 systemd[1]: Failed to start LSB: Start/stop uWSGI server inst...s).
Sep 25 09:32:58 bhansen-Inspiron-3847 systemd[1]: uwsgi.service: Unit entered failed state.
Sep 25 09:32:58 bhansen-Inspiron-3847 systemd[1]: uwsgi.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package uwsgi (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 uwsgi
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo apt-cache policy uwsgi
uwsgi:
  Installed: 2.0.12-5ubuntu3.1
  Candidate: 2.0.12-5ubuntu3.1
  Version table:
 *** 2.0.12-5ubuntu3.1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     2.0.12-5ubuntu3 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: uwsgi 2.0.12-5ubuntu3.1
ProcVersionSignature: Ubuntu 4.4.0-96.119-generic 4.4.83
Uname: Linux 4.4.0-96-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
Date: Mon Sep 25 09:31:14 2017
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2016-10-04 (356 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt 1.2.24
SourcePackage: uwsgi
Title: package uwsgi 2.0.12-5ubuntu3.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Emanuel Costa (emanweb) wrote :
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers