VM creation fails on Utopic/Trusty

Bug #1372368 reported by Robie Basak on 2014-09-22
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
uvtool (Ubuntu)
High
Robie Basak
Trusty
High
Brian Murray

Bug Description

[impact]

"uvt-kvm create foo" produces the error:

uvt-kvm: error: libvirt: internal error: process exited while connecting to monitor: 2014-09-22T09:27:46.422743Z qemu-system-x86_64: -drive file=/var/lib/uvtool/libvirt/images/foo-ds.qcow,if=none,id=drive-virtio-disk1,format=iso: 'iso' invalid format

[test case]

install uvtool, use uvt-simplestreams-libvirt to sync an image locally, then use uvt-kvm to try to create an instance; it fails with the above error.

[regression potential]

since uvt-kvm does not work at all now, there is little room left for regression. however, it's possible the patch could break uvt-kvm in additional ways, which would leave uvt-kvm still broken, but with different error(s).

Stefan Bader (smb) wrote :

Looks like libvirt gets too smart for its own good. Luckily its possible to simply convert the type back to raw...

tags: added: patch
Robie Basak (racb) wrote :

Workaround uploaded. I think the proper fix is in libvirt, so I'll continue to investigate.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package uvtool - 0~bzr92-0ubuntu2

---------------
uvtool (0~bzr92-0ubuntu2) utopic; urgency=medium

  * With libvirt 1.2.8, the second disk is being reported as type iso,
    which confuses libvirt. As a temporary workaround, intercept that and call
    it raw. Thanks to Serge Hallyn and Stefan Bader for the patch (LP:
    #1372368).
 -- Robie Basak <email address hidden> Thu, 25 Sep 2014 10:45:32 +0000

Changed in uvtool (Ubuntu):
status: Triaged → Fix Released
Dan Streetman (ddstreet) wrote :

This debdiff adds the original patch from this bug to trusty.

description: updated
Dan Streetman (ddstreet) on 2016-08-29
summary: - VM creation fails on Utopic
+ VM creation fails on Utopic/Trusty
description: updated
ChristianEhrhardt (paelzer) wrote :

FYI - I just hit the same.
IMO the most likely case to hit this is by running Trusty with the Ubuntu Cloud Archive. That brings in a newer libvirt and that way makes it hit the same issue as you had for utopic here.

@Robie - do you think you would consider this for Trusty?

Also I love "As a temporary workaround", nothing endures as long as these :-)

ChristianEhrhardt (paelzer) wrote :

I just noted that if looking for a fast workaround https://launchpad.net/~uvtool-dev/+archive/ubuntu/master might be an option

Robie Basak (racb) wrote :

> @Robie - do you think you would consider this for Trusty?

Yes, I think an SRU would be fine for this issue.

Changed in uvtool (Ubuntu Trusty):
status: New → Triaged
Marc Deslauriers (mdeslaur) wrote :

The debdiff in comment #5 looks fine, but it's odd that you didn't use your own name in the changelog while still giving credit to Robie.

Please run dch -a on it and re-submit. Thanks!

Dan Streetman (ddstreet) wrote :

> The debdiff in comment #5 looks fine, but it's odd that you didn't use your own name in the
> changelog while still giving credit to Robie.

ha, oops! :)

I fixed the debdiff and re-attached, thanks!

Changed in uvtool (Ubuntu Trusty):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

I'm looking at sponsoring this, thanks!

Changed in uvtool (Ubuntu Trusty):
assignee: nobody → Brian Murray (brian-murray)
Brian Murray (brian-murray) wrote :

This is in the queue and ready for review by the SRU team.

Changed in uvtool (Ubuntu Trusty):
status: Triaged → In Progress
Robie Basak (racb) wrote :

"[regression potential] none."?

See https://wiki.ubuntu.com/StableReleaseUpdates#Procedure:

"If this section is None it is grounds for rejection, consider 1590321 which is an example of a simple fix with a legitimate Regression Potential."

Please fix.

Dan Streetman (ddstreet) wrote :

> Please fix.

fixed

description: updated

Hello Robie, or anyone else affected,

Accepted into trusty-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in uvtool (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Robie Basak (racb) wrote :

11:15 -queuebot:#ubuntu-release- Unapproved: rejected uvtool [sync] (trusty-proposed) [0~bzr92-0ubuntu2]

I swear I clicked "Accept" after using sru-accept. I'm thrown by the bileto sync. Should I have done something else? Sorry!

Dan Streetman (ddstreet) wrote :

It looks like that specific uvtool version did get released for Utopic, so maybe the build system rejected it as a duplicate...I suppose the version should be 0~bzr92-0ubuntu1.1 instead to avoid the version collision? (My bad on putting the wrong version string in the debdiff, sorry)

https://launchpad.net/ubuntu/+source/uvtool/0~bzr92-0ubuntu2

Dan Streetman (ddstreet) wrote :
Dan Streetman (ddstreet) wrote :

updated debdiff to replace the bad (duplicate in Utopic) version 0~bzr92-0ubuntu2 with version 0~bzr92-0ubuntu1.1

Brian Murray (brian-murray) wrote :

I seem to have missed the emails in this bug report, I've uploaded the new debdiff and will review and accept it since the content is the same.

Brian Murray (brian-murray) wrote :

Hello Robie, or anyone else affected,

Accepted uvtool into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/uvtool/0~bzr92-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dan Streetman (ddstreet) wrote :

With a standard trusty install, the versions installed are:
uvtool 0~bzr92-0ubuntu1
libvirt0 1.2.2-0ubuntu13.1.20

this combination does not have this problem, as libvirt hasn't yet changed to use type 'iso'.

After apt-add-repository cloud-archive:mitaka, and upgrading libvirt, the versions are:
uvtool 0~bzr92-0ubuntu1
libvirt0 1.3.1-1ubuntu10.8~cloud0

this combination does show this problem:

$ uvt-kvm create uca-test release=xenial arch=amd64
uvt-kvm: error: libvirt: internal error: process exited while connecting to monitor: 2017-04-17T16:21:41.224870Z qemu-system-x86_64: -drive file=/var/lib/uvtool/libvirt/images/uca-test-ds.qcow,format=iso,if=none,id=drive-virtio-disk1: 'iso' invalid format

upgrading uvtool (and uvtool-libvirt) does fix the problem, with versions:
uvtool 0~bzr92-0ubuntu1.1
uvtool-libvirt 0~bzr92-0ubuntu1.1
libvirt0 1.3.1-1ubuntu10.8~cloud0

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package uvtool - 0~bzr92-0ubuntu1.1

---------------
uvtool (0~bzr92-0ubuntu1.1) trusty; urgency=medium

  * With libvirt 1.2.8, the second disk is being reported as type iso,
    which confuses libvirt. As a temporary workaround, intercept that and call
    it raw. Thanks to Serge Hallyn and Stefan Bader for the patch
    (LP: #1372368).

 -- Dan Streetman <email address hidden> Thu, 25 Sep 2014 10:45:32 +0000

Changed in uvtool (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for uvtool has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers