uvccapture fails at larger resolution (1280x1024)

Bug #554059 reported by Ingo Ruhnke on 2010-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
uvccapture (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: uvccapture

The Logitech C300 (046d:0805) webcam works with other applications such as mplayer or guvcview, but with uvccapture it works only for smaller resolutions (960x720, 800x600, 640x480, ...), when selecting 1280x1024 it fails with:

$ uvccaputer -x1280 -y1024
Unable to query buffer (22).
Init v4L2 failed !! exit fatal

When doing the above, dmesg gives the following error:

$ dmesg
vmap allocation for size 36704256 failed: use vmalloc= to increase size

Following that message and adding "vmalloc=268435456" (256MiB, smaller values might work to, haven't tried) to the kernel boot parameter makes uvccapture work.

The correct fix to make it work without changing vmalloc might be to change the uvccapture code to use V4L2_MEMORY_USERPTR for larger resolutions instead of V4L2_MEMORY_MMAP, but I haven't tried that yet (I assume thats what other apps do).

Description: Ubuntu lucid (development branch)
Release: 10.04
Codename: lucid

uvccapture is 0.5-1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers