Ubuntu

Activity log for bug #742582

Date Who What changed Old value New value Message
2011-03-25 16:14:01 Duncan McGreggor bug added bug
2011-03-25 16:15:43 Duncan McGreggor utouch-grail (Ubuntu): assignee Henrik Rydberg (rydberg)
2011-03-25 16:16:02 Duncan McGreggor bug task added utouch-grail
2011-03-25 16:16:17 Duncan McGreggor utouch-grail: importance Undecided Critical
2011-03-25 16:16:20 Duncan McGreggor utouch-grail: status New In Progress
2011-03-25 16:16:41 Duncan McGreggor utouch-grail: assignee Henrik Rydberg (rydberg)
2011-03-28 21:02:11 Launchpad Janitor branch linked lp:~utouch-packaging/utouch-grail/packaging.touch-gestures
2011-03-28 21:19:59 Chase Douglas summary GEIS doesn't get touch the touch initialization signals from grail Add touch gesture events
2011-03-28 21:22:45 Chase Douglas utouch-grail (Ubuntu): status New In Progress
2011-03-28 21:22:48 Chase Douglas utouch-grail: status In Progress Fix Committed
2011-03-30 15:55:04 Chase Douglas description As reported in bug #742555, Unity is not getting what it needs from GEIS. In order for GEIS to provide the initialization signals, they need to be set up in Grail. Feature Freeze Exception: The current uTouch stack does not have any gesture events that fire when touches begin. Touches must move to cross a threshold before emitting any events. However, gestures on touch begin is a necessary functionality for Natty Unity work. The related branches include the addition of a new "touch" gesture type. This new code is in ppa:utouch-team/unstable and is being actively used and developed against by the Unity team. This feature is necessary to meet all the Natty development goals. Due to the manner in which touch gestures are implemented, the regression risk posed is moderate. However, the changes made have been viewed by the team as bringing the code more in line with the ideal logic for gesture handling. This has led to some simplification of the code and fixing of other unseen bugs. As such, though the regression risk is not trivial, we believe it is reasonable to propose inclusion of the changes into Natty at this stage. Just as a note, this inctroduces an ABI addition (no API changes, and no ABI breakages).
2011-03-30 15:55:22 Chase Douglas bug added subscriber Ubuntu Release Team
2011-03-30 15:55:30 Chase Douglas utouch-grail (Ubuntu): status In Progress New
2011-03-30 15:59:51 Chase Douglas utouch-grail (Ubuntu): milestone ubuntu-11.04-beta-2
2011-03-30 15:59:56 Chase Douglas utouch-grail (Ubuntu): importance Undecided Critical
2011-03-30 16:20:58 Chase Douglas attachment added Install log https://bugs.launchpad.net/utouch-grail/+bug/742582/+attachment/1956921/+files/log
2011-04-01 06:25:45 Henrik Rydberg utouch-grail (Ubuntu): assignee Henrik Rydberg (rydberg)
2011-04-01 06:47:38 Martin Pitt utouch-grail (Ubuntu): status New Confirmed
2011-04-01 12:56:46 Duncan McGreggor bug added subscriber Mark Shuttleworth
2011-04-01 13:20:13 Launchpad Janitor utouch-grail (Ubuntu): status Confirmed Fix Released
2011-04-01 13:23:14 Launchpad Janitor branch linked lp:~utouch-packaging/utouch-grail/packaging
2011-04-01 14:12:24 Launchpad Janitor branch linked lp:ubuntu/utouch-grail
2011-04-26 11:01:18 Scott Kitterman removed subscriber Ubuntu Release Team
2011-08-09 13:59:43 Stephen M. Webb utouch-grail: status Fix Committed Fix Released