Ubuntu

One Finger tap as mouse click is confusing

Reported by Christoph Langner on 2010-09-25
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Grail
High
Henrik Rydberg
utouch-grail (Ubuntu)
High
Open Input Framework Team
Maverick
High
Open Input Framework Team

Bug Description

Stable Release Update Information:

Impact: Users of the Apple Magic Mouse will see clicks when a finger taps, but does not depress, the mouse surface. This will cause significant issues with usability. Further, gestures of any sort are disabled for the Magic Mouse as they do not work correctly.

How Addressed: Gestures have been disabled for mixed mode relative and absolute input devices. The only known mixed mode device is the Magic Mouse.

Reproduction: Connect a Magic Mouse to a computer running Ubuntu 10.10. Tap with one finger on the surface of the mouse without actually clicking the mouse button. A mouse click event will be generated erroneously.

Regression Potential: The change only affects mixed mode devices, of which there is only one we are aware of. This fix has been tested on the Magic Mouse and many other typical devices to ensure regressions have not been introduced.

Changelog:
utouch-grail (1.0.15-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - Fix one Finger tap as mouse click is confusing LP: #647761

 -- Henrik Rydberg <email address hidden> Tue, 28 Sep 2010 13:55:19 +0200

-----

Binary package hint: utouch

I own a Apple Magic Mouse which runs under Maverick (all current updates installed) quite good. Since a couple of days ago I can "tap" on the surface and create a "click" on the mouse button without actually clicking the mouse button. This is very confusing since you've got to watch out not to touch the surface of the mouse. If you don't, you'll click accidentally on your desktop all the time.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: utouch 1.1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Sep 25 23:02:53 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
MachineType: System manufacturer System Product Name
MtDevices: Apple Wireless Mouse: /dev/input/event7
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=bb23728a-94b0-4495-8f28-06098a5d3e24 ro quiet splash nomodeset video=uvesafb:mode_option=1024x768-24,mtrr=3,scroll=ywrap
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: utouch
dmi.bios.date: 02/14/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2N-E ACPI BIOS Revision 1304
dmi.board.name: M2N-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2N-EACPIBIOSRevision1304:bd02/14/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2N-E:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Christoph Langner (chrissss) wrote :
Rafi (rafi-seas) on 2010-09-27
Changed in utouch (Ubuntu):
assignee: nobody → uTouch Team (utouch-team)
Ara Pulido (apulido) on 2010-09-27
summary: - One Finger tab as mouse click is confusing
+ One Finger tap as mouse click is confusing
Henrik Rydberg (rydberg) on 2010-09-27
Changed in utouch (Ubuntu):
status: New → Confirmed
Henrik Rydberg (rydberg) on 2010-09-28
affects: utouch (Ubuntu) → utouch-grail (Ubuntu)
Changed in utouch-grail (Ubuntu):
status: Confirmed → In Progress
Henrik Rydberg (rydberg) wrote :

Please try the attached package and see it it resolves the issue.

Henrik Rydberg (rydberg) wrote :

Please disregard the package in the previous post and use this one instead.

Changed in utouch-grail:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Henrik Rydberg (rydberg)
Changed in utouch-grail (Ubuntu):
importance: Undecided → High
Chase Douglas (chasedouglas) wrote :

The package from the utouch-team/unstable ppa works for me. We just need to coordinate the package upload now.

Chase Douglas (chasedouglas) wrote :

It doesn't seem to be noted elsewhere in this bug, but the fix is just to disable gesture support for mixed mode (relative and absolute at the same time) devices. The only mixed mode device I'm aware of is the magic mouse. With this new grail package, X will fail to open grail for the magic mouse. This will result in the following line in Xorg.0.log:

(II) evdev-grail: failed to open grail, no gesture support

My hope is that we can enable full gesture support for the magic mouse in Natty.

Duncan McGreggor (oubiwann) wrote :

This is going to be very, very disappointing for many folks (including Mark).

As such, we need to have a full report drawn up. Chase, can you draft that and email it to me? We'll go over it together, and then post it on the Ubuntu touch wiki, linking to it from here for reference/convenience.

Henrik Rydberg (rydberg) wrote :

This is only for the magic mouse - the magic trackpad will get all the gesture goodness.

Changed in utouch-grail:
status: In Progress → Fix Committed
Changed in utouch-grail (Ubuntu):
status: In Progress → Fix Committed
Duncan McGreggor (oubiwann) wrote :

Henrik, thanks for clearing up my misunderstanding. Chase, never mind ;-)

Christoph Langner (chrissss) wrote :

Thanks Henrik, with your package it's much better to work with the magic mouse. It's a pity that we've got to postpone multitouch for the magic mouse, but at least it's possible to use the mouse now (left-, middle, right-click, horizontal and vertical scrolling) without tweaking. Of course something like "gesturetest <windowid> 0 0xfff" returns nothing anymore.

description: updated
Didier Roche (didrocks) wrote :

revert the packaging to triaged and it will be fix commited once accepted to -proposed

Changed in utouch-grail (Ubuntu):
status: Fix Committed → Triaged
Chase Douglas (chasedouglas) wrote :
description: updated
Didier Roche (didrocks) on 2010-10-05
Changed in utouch-grail:
status: Fix Committed → Fix Released

Accepted utouch-grail into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in utouch-grail (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed
Chase Douglas (chasedouglas) wrote :

I have tested the updated libutouch-grail1 package in maverick-proposed. Gesture functionality still works with my magic trackpad, and the gestures are disabled for the magic mouse surface as expected.

+1

Henrik Rydberg (rydberg) wrote :

Tested on three "normal" MT touchpads and two touchscreens without regressions.

Martin Pitt (pitti) on 2010-10-12
tags: added: verification-done
removed: verification-needed
ewigsuchender (ewigsuchender) wrote :

Yesterday all my trouble seem so far away.........................

today i got the new kernel via update and the multitouch (scrolling, Magic Mouse) was gone. I don´t understand the big problem, is it difficult to add a IF button is pressed click is possible if not clicking is locked?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package utouch-grail - 1.0.15-0ubuntu1

---------------
utouch-grail (1.0.15-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - Fix one Finger tap as mouse click is confusing LP: #647761
 -- Henrik Rydberg <email address hidden> Tue, 28 Sep 2010 13:55:19 +0200

Changed in utouch-grail (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

copied to natty.

Changed in utouch-grail (Ubuntu):
status: Fix Committed → Fix Released
ewigsuchender (ewigsuchender) wrote :

Magic Mouse is working really fine now. Left, middle and right mouse click, horizontal and vertical scrolling.

thank you very much.

To post a comment you must log in.