util-vserver version 0.30.216-pre2864-2ubuntu1 failed to build on armhf

Bug #945385 reported by Ricardo Salveti on 2012-03-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
util-vserver (Debian)
Fix Released
Unknown
util-vserver (Ubuntu)
High
Unassigned

Bug Description

util-vserver version 0.30.216-pre2864-2ubuntu1 failed to build on armhf
Link to failed build: https://launchpad.net/ubuntu/+source/util-vserver/0.30.216-pre2864-2ubuntu1/+build/2968973

Direct link to the build log: https://launchpad.net/ubuntu/+source/util-vserver/0.30.216-pre2864-2ubuntu1/+build/2968973/+files/buildlog_ubuntu-precise-armhf.util-vserver_0.30.216-pre2864-2ubuntu1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 2524 lines into the build log:

 diet -Os gcc -DHAVE_CONFIG_H -I. -I ./lib -I ./ensc_wrappers -D_GNU_SOURCE -D_REENTRANT -DNDEBUG -D_FORTIFY_SOURCE=2 -Wall -g -O2 -std=c99 -Wall -pedantic -W -funit-at-a-time -MT tests/getctx.o -MD -MP -MF $depbase.Tpo -c -o tests/getctx.o tests/getctx.c &&\
 mv -f $depbase.Tpo $depbase.Po
/bin/bash ./libtool --tag=CC --mode=link diet -Os gcc -Wall -g -O2 -std=c99 -Wall -pedantic -W -funit-at-a-time -static -Wl,-Bsymbolic-functions -Wl,-z,relro -o tests/getctx tests/getctx.o lib/libvserver.a
libtool: link: diet -Os gcc -Wall -g -O2 -std=c99 -Wall -pedantic -W -funit-at-a-time -Wl,-Bsymbolic-functions -Wl,-z -Wl,relro -o tests/getctx tests/getctx.o lib/libvserver.a
lib/libvserver.a(lib_libvserver_a-syscall_gettaskxid.o): In function `vserver':
/build/buildd/util-vserver-0.30.216-pre2864/lib/vserver-internal.h:287: undefined reference to `syscall'
collect2: ld returned 1 exit status
make[3]: *** [tests/getctx] Error 1
make[3]: Leaving directory `/build/buildd/util-vserver-0.30.216-pre2864'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/util-vserver-0.30.216-pre2864'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/util-vserver-0.30.216-pre2864'
make: *** [build-stamp] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20120111-1757
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/util-vserver-0.30.216-pre2864

Changed in util-vserver (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in util-vserver (Debian):
status: Unknown → New
Changed in util-vserver (Debian):
status: New → Fix Released
James Cowgill (jcowgill) wrote :

Seems to be fixed now. All versions since 0.30.216-pre3054-1 in trusty built successfully on armhf.

Changed in util-vserver (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.