[apport] vserver-info crashed with SIGSEGV

Bug #88595 reported by Daniel Balieiro
62
This bug affects 1 person
Affects Status Importance Assigned to Milestone
util-vserver (Ubuntu)
Fix Released
Medium
Luca Falavigna

Bug Description

Binary package hint: util-vserver

uname -a
Linux mobi4life 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux

ProblemType: Crash
Architecture: i386
Date: Wed Feb 28 01:52:56 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/sbin/vserver-info
Package: util-vserver 0.30.212-1
ProcCmdline: /usr/sbin/vserver-info - SYSINFO
ProcCwd: /home/daniel
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=pt_BR.UTF-8
 LANGUAGE=pt_BR:pt:en
ProcMaps:
 08048000-0804e000 r-xp 00000000 03:01 3519644 /usr/sbin/vserver-info
 0804e000-0804f000 rwxp 00005000 03:01 3519644 /usr/sbin/vserver-info
 b7f47000-b7f48000 r-xp b7f47000 00:00 0 [vdso]
 bfa1b000-bfa30000 rwxp bfa1b000 00:00 0 [stack]
Signal: 11
SourcePackage: util-vserver
Stacktrace:
 #0 0x080484b7 in ?? ()
 #1 0x00000000 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()
ThreadStacktrace:
 .
 Thread 1 (process 6727):
 #0 0x080484b7 in ?? ()
 #1 0x00000000 in ?? ()
Uname: Linux mobi4life 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner video

Revision history for this message
Daniel Balieiro (danielbalieiro-deactivatedaccount) wrote :
Revision history for this message
Daniel Holbach (dholbach) wrote :

Thanks for your bug report.

Changed in util-vserver:
assignee: nobody → motu
importance: Undecided → Medium
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:_start ()

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in util-vserver:
status: Unconfirmed → Needs Info
Revision history for this message
tomas (tomas-truth) wrote :

i've experienced this problem today on amd64 platform, recompiled the sources by myself,
ran vserver-info under gdb and found out it sigsegv on plain stack allocation, obvious compiler
error. after recompilation with gcc-3.4 everything works nicely.

it seems the problem is relate only to feisty's gcc4.1.2, binary files compiled with non-ubuntu
gcc4.1.2 also work correctly

Revision history for this message
tomas (tomas-truth) wrote :

one more thing -- i needed to disable diet libc (in debian/rules) in order to successfully compile with gcc3.4

Changed in util-vserver:
status: Incomplete → New
Revision history for this message
fmyhr (fmyhr) wrote :

For anyone else struggling with this bug, the following works like a charm in feisty/i386:

1) purge the feisty util-vserver package (and probably vserver-debiantools package, I don't use it)

2) download the debian stable package from
http://packages.debian.org/stable/net/util-vserver

3) install the debian stable util-vserver package, which I think is built/linked against an earlier gcc:
dpkg -i util-vserver_0.30.212-1_i386.deb

4) get on with your life

I know this package is in "universe" which is unsupported. But this bug has been open for several months now with no resolution, and has caused me (and I know others) wasted hours. Can't someone simply put debian's util-vserver into the ubuntu universe repository until the problem with gcc 4.1 can be worked out?

More on gcc 4.1 problem:
http://irc.13thfloor.at/LOG/2006-11/LOG_2006-11-29.txt

There are 6 other open bugs on util-vserver that I think are caused by the same problem:
https://launchpad.net/ubuntu/+source/util-vserver/+bugs

Revision history for this message
martinlanghoff (martin-langhoff) wrote :

Hi -- I am seeing this on current gutsy as well. Strangely enough, it's being executed automatically, and I don't quite know what's calling it. The apport window appears right after gnome starts.

I am not running any vservers, nor I have enabled any vserver-related utility. So this is a bit of a mistery.

Changed in util-vserver:
status: New → Confirmed
Revision history for this message
Luca Falavigna (dktrkranz) wrote :

Wait until dietlibc 0.31-1 has been merged from Debian.

Changed in util-vserver:
assignee: motu → dktrkranz
status: Confirmed → In Progress
Revision history for this message
Luca Falavigna (dktrkranz) wrote :

Attached debdiff should fix this bug.

Changed in util-vserver:
assignee: dktrkranz → nobody
status: In Progress → Confirmed
Emmet Hikory (persia)
Changed in util-vserver:
assignee: nobody → persia
status: Confirmed → In Progress
Revision history for this message
Emmet Hikory (persia) wrote :

Possibly fixed with the sync of 0.30.214-5

Changed in util-vserver:
assignee: persia → dktrkranz
Revision history for this message
Luca Falavigna (dktrkranz) wrote :

0.30.214-5 only fixed incorrect syntax in preinst script, but segfault still happen.

Changed in util-vserver:
assignee: dktrkranz → nobody
status: In Progress → Confirmed
Revision history for this message
András Korn (kornandras) wrote :

There is indeed a discussion of this problem in the #vserver irclogs available from http://irc.13thfloor.at/LOG/2006-11/LOG_2006-11-29.txt as fmyhr pointed out.

The issue appears to arise from an incompatibility between stack-protector and dietlibc, as far as I can tell.

Look at the part where http://thread.gmane.org/gmane.linux.lib.dietlibc/989/focus=990 is referenced.

Compiling with gcc-4.0 instead of later versions appears to be a workaround.

Andras

Revision history for this message
Luca Falavigna (dktrkranz) wrote :

Thanks for your comment, Andras. I already realized this was related to dietlibc instead and I filed a new spec about it: https://blueprints.launchpad.net/ubuntu/+spec/better-dietlibc. I will investigate a bit about this and report my tests there.

In the meantime, my debdiff solves this problem until a better solution is found.

Changed in util-vserver:
assignee: nobody → dktrkranz
status: Confirmed → In Progress
Revision history for this message
Luca Falavigna (dktrkranz) wrote :

I just uploaded version 0.30.214-6build1, which should fix this issue.

Changed in util-vserver:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package util-vserver - 0.30.214-6build1

---------------
util-vserver (0.30.214-6build1) hardy; urgency=low

  * Rebuild against new dietlibc (LP: #88595).

 -- Luca Falavigna <email address hidden> Fri, 14 Mar 2008 16:31:20 +0100

Changed in util-vserver:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers