Checking disk drives for errors at every boot

Bug #998512 reported by Pascalio
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
util-linux (Ubuntu)
Expired
Medium
Unassigned

Bug Description

Ubuntu 12.04

util-linux 2.20.1-1ubuntu3

At absolutely every boot, fsck starts a disk drive check, causing a long wait with the message checking disk drives for errors. No error is found though, and the preceding shutdown is done regularly. Whether you let the check finish or cancel it, it will invariably keep coming up in the next boot.
I've tried tune2fs -c 0 -i 0 [My boot drive], no difference. However, if I check with tune2fs -l , I see the command has worked fine though.
I checked my boot partition from a live boot session with tune2fs -l, without mounting the partition of course, and saw that the filesystem state was set "not clean", whereas it wasn't mounted, which I guess is not normal and may be the cause for the needless systematic disk drive check. So, could the problem be when 12.04 unmounts the boot partition at shutdown?
Many have the same issue and you can have a look at this forum thread : http://ubuntuforums.org/showthread.php?t=1973178

This seems hugely obvious however I can't see it's been reported...

Tags: bot-comment
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/998512/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Changed in ubuntu:
status: New → Incomplete
Revision history for this message
Pascalio (pascalio432) wrote :

Well, I've tried mounting and then unmounting my filesystem from an earlier Ubuntu, and it stays "not clean" even unmounted. So, you can forget my attempt to diagnose the problem. I'll guess the concerned package is util-linux where we find fsck.

description: updated
Changed in ubuntu:
status: Incomplete → New
affects: ubuntu → util-linux (Ubuntu)
Changed in util-linux (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in util-linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Luca (edmund-1) wrote :

I see a similar problem running 32 bit ubuntu 12.04. I am using a 4GB compact flash card as my root drive. When I do a dumpe2fs /dev/sda1 I see FIlesystem state: not clean. The motherboard is zotac itx. I can provide more details if needed.

Revision history for this message
Natalie Roque (nathalieroque) wrote :

I have the same issue in 32 bit ubuntu 12.04, it keeps checking for disk errors every time it boots.

Revision history for this message
JoeGreen (hrb) wrote :

Made installations on 2 different systems and both are affected by this problem: On Intel i3-2120 Sandy Bridge a dual boot Precise / Win7 (64 bit) and on an older Intel Pentium IV Northwood a dual boot Precise /WinXP (32 bit). Both keep checking for disk errors every time they boot.

Revision history for this message
Vince O'Farrell (vof) wrote :

After upgrading from 11.10 to 12.04 Precise, I too suffered from the unclean-shutdown->disk-check-on-every-startup problem. I found the cause of my problem last week thanks to info from the various posts below. I am reporting it here in case it is relevant.

At first, I guessed that Network Manager was to blame, especially since I am also having problems with a hang at shutdown which I suspect is to do with unmounting some CIFS shares. NM however was not the cause but in following the advice in this bug report
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/963106
I added some diagnostic logging to the /etc/init.d/umountroot script as described in message #5.

This showed that plymouthd was still running at the time it should have terminated and this led me to this posting
http://ubuntuforums.org/showthread.php?t=2008576
which in turn led me to
https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/1019347

I followed the suggestion in comment #7 of bug 1019347 and added the line
/bin/plymouth quit
to the /etc/init.d/umountroot script just before root is remounted read-only. (This is the same point that the diagnostic logging described in 963106 had been inserted.)

Result: clean shutdowns and no more disk checks on each and every start.

Now, it must be said that there are other candidates for the cause of this problem and it is worth looking at these too if you find that plymouthd is behaving itself on your system. One that was relevant to me is ensuring you use the latest Nvidia driver if you use proprietary Nvidia graphics in your system. Google for
12.04 nvidia shutdown
to find lots of reports. I upgraded to the latest Nvidia driver but the unclean shutdown continued until I fixed the plymouthd problem.

Revision history for this message
JoeGreen (hrb) wrote :

Updated both of my systems today and it looks as if the problem is gone now: thank you Vince, I think it must have been your input that made this happen.

Regards, Joe

Revision history for this message
Phillip Susi (psusi) wrote :

Is anyone else still having this problem?

Changed in util-linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Francisco (editoria-francisco) wrote :

Like Natalie (#5), I have the same issue in 32 bit ubuntu 13.10, it keeps checking for disk errors every time it boots.

Revision history for this message
Phillip Susi (psusi) wrote :

Can you post the output of tune2fs -l on the volume?

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for util-linux (Ubuntu) because there has been no activity for 60 days.]

Changed in util-linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers