timestamp mismatch of fs superblock at file system check

Bug #421371 reported by Matthias Klose on 2009-08-30
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
util-linux (Ubuntu)
Undecided
Unassigned

Bug Description

seen with current karmic 20090830, this is an upgraded system. when a fsck of the root file system is required, I get a message "fsck required, timestamp of fs superblock is in the future", and a fsck -y <rootfs> is needed as a manual action. Looking at the timestamps (now, and for the superblock, it's a difference of 2h - a few seconds). The local timezone is +2, so I assume that this is a problem with timestamps. Didn't investigate further.

Yannis Tsop (ogiannhs) wrote :

I have the same problem here. After every boot Iget the same error:

" last mount is in the future ", "An automatic file system check (fsck) of the root file system failed".

It allways happens only for the root partition and always the difference is 3 hours minus 6 or 7 seconds (this is the difference of my timezone from UTC).

Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → util-linux (Ubuntu)
Yannis Tsop (ogiannhs) wrote :

I forgot to mention that this happens with the latest karmic alpha (did not happen before) and util-linux is at version 2.16-1ubuntu1

 status incomplete

On Sun, 2009-08-30 at 10:42 +0000, Launchpad Bug Tracker wrote:

> seen with current karmic 20090830, this is an upgraded system. when a
> fsck of the root file system is required, I get a message "fsck
> required, timestamp of fs superblock is in the future", and a fsck -y
> <rootfs> is needed as a manual action. Looking at the timestamps (now,
> and for the superblock, it's a difference of 2h - a few seconds). The
> local timezone is +2, so I assume that this is a problem with
> timestamps. Didn't investigate further.
>
Please supply the exact output of fsck, including the timestamps (it
should display both).

Also at this prompt please run "/sbin/hwclock --debug --show", "date"
and "cat /etc/default/rcS"

Has this machine previously had Windows installed? Did you verify that
the Hardware Clock was correct at the time you installed?

Scott
--
Scott James Remnant
<email address hidden>

Changed in util-linux (Ubuntu):
status: Confirmed → Incomplete
Yannis Tsop (ogiannhs) wrote :

My computer has only Ubuntu installed since at least 7.10. Only with karmic I have seen this happening. How can I find this log after restarting the pc?

Unfortunately you can't once you've repaired the filesystem and rebooted :-( This means I'll have to mark the bug "Invalid" as there's no way to get the data we need to debug it.

If it happens again, please do reopen the bug and attach that information.

Changed in util-linux (Ubuntu):
status: Incomplete → Invalid
Jithin Emmanuel (jithin1987) wrote :

Attaching the information you asked. I am a frequent user of RSEIUB :( because my karmic frreezes after suspend to ram. I am getting this error after this reboot. If I chose to do no action and simple exit the root shell during immediate boot it does a filesystem check normally(saying unclean shutdown detected).

The file system was mounted read only. So I could only take a picture. And I have windows installed. I always had back from the days of intrepid. And I have used RSEIUB extensively in jaunty and I never got this error

Changed in util-linux (Ubuntu):
status: Invalid → New
Jithin Emmanuel (jithin1987) wrote :

And I can reproduce this any time.

Grzegorz Sterniczuk (dzikus) wrote :

From yesterday my karmic koala do this error every time it is booted. I can't repair my filesystem.

From PLD RescueCD i fsck'd ext4 and there is no errors, i can mount this filesystem and access it without any problems.

Grzegorz Sterniczuk (dzikus) wrote :

From yesterday my karmic koala do this error every time it is booted. I can't repair my filesystem from recovery mode.

From PLD RescueCD i fsck'd ext4 and there is no errors, i can mount this filesystem and access it without any problems.

On Thu, 2009-09-03 at 00:21 +0000, Jithin Emmanuel wrote:

> Attaching the information you asked.
>
You are not the original reporter of this bug.

If you are having problems, please open a *new* bug - do not simply
hijack another report which describes similar symptoms.

 status invalid

Scott
--
Scott James Remnant
<email address hidden>

Changed in util-linux (Ubuntu):
status: New → Invalid
Jithin Emmanuel (jithin1987) wrote :

In several bugs I have seen marking as duplicate. I really do not understand why it is marked as invalid when I am facing the same bug. I didnt know that the policy changed to one bug per person. If this was announced earlier I would not have wasted my time on this bug,
So does that also imply there is no point in searching for existing bug report and users should always open new ones.

On Tue, 2009-09-08 at 15:49 +0000, Jithin Emmanuel wrote:

> So does that also imply there is no point in searching for existing bug report and users should always open new ones.
>
For packages that I maintain, yes.

*I* will determine whether or not it is a duplicate.

Scott
--
Scott James Remnant
<email address hidden>

Jithin Emmanuel (jithin1987) wrote :

This is the worst arrogant statement I heard from a ubuntu developer, though never expected to hear one. Did you check the data I posted? At least you can tell why its not the same bug.

I do have the same bug. The only hope now is to reinstall a system I think especially when the devs are considering this behaviour as normal.

On Wed, 2009-09-09 at 00:17 +0000, Jithin Emmanuel wrote:

> This is the worst arrogant statement I heard from a ubuntu developer,
> though never expected to hear one. Did you check the data I posted? At
> least you can tell why its not the same bug.
>
I did. You definitely do not have the same bug. That's why I asked you
to file a new one.

Why is this so hard to understand?

Scott
--
Scott James Remnant
<email address hidden>

On Wed, 2009-09-09 at 07:21 +0000, humufr wrote:

> I do have the same bug. The only hope now is to reinstall a system I
> think especially when the devs are considering this behaviour as normal.
>
No, it's not normal behaviour.

However Matthias had a very different bug to what you probably have, so
please FILE A NEW BUG

Scott
--
Scott James Remnant
<email address hidden>

Matthias Klose (doko) wrote :

> Please supply the exact output of fsck, including the timestamps (it
> should display both).

attached a screenshot

> Also at this prompt please run "/sbin/hwclock --debug --show", "date"
> and "cat /etc/default/rcS"

forgot about that :-/

> Has this machine previously had Windows installed? Did you verify that
> the Hardware Clock was correct at the time you installed?

windows is installed on another partition. the hardware clock is set to local time. I don't remember if the clock was correct when I did install jaunty ...

Marcin Gil (marcin.gil) wrote :

This happens also on a fresh Alpha 5 install. I have had Windows partition but removed it prior installing A5.
My timezone is UTC+2 (Poland) and so my last access timestamps are always 2hrs "in the future" when this error pops up on boot.

tags: added: iso-testing
Deepesh (deepesh-g) wrote :

Hi,
Is there a fix for this? If not, please let me know how can I help to get this problem fixed.

I installed Ubuntu 9.10 on my Dad's computer and facing the same problem (I guess). His CMOS battery is dead so it keep losing all settings including date/time. Correcting date/time from CMOS makes it boot again as normal.

I can ask my Dad to run commands on root prompt he gets on boot failure and will post the output.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers