sfdisk doesn't accept blank for start value with -uS

Bug #337321 reported by robos on 2009-03-03
2
Affects Status Importance Assigned to Milestone
util-linux (Ubuntu)
Undecided
Ayan George

Bug Description

Binary package hint: util-linux

Release: 8.10
util-linux: 2.14-1ubuntu2

According to the man-page this should work:
sfdisk -uS /dev/sdb << EOF
63,546147,82,-
,512000
EOF

I got these values by creating the 256MB partition in fdisk, then list the values with sfdisk -l /dev/sdb and then deleting all partitions again in fdisk.
The first line creates a 256MB Swap partition as /dev/sdb1. The second line should create a partition 512000 sectors large right behind that. The problem is that
,<Size>
isn't being accepted, the problem seems to be omitting the starting point.
The first line on it's own works.
Only when I enter the correct starting point (546210) at the beginning of the second line it works.
The problem seems to be -uS specific, -uM works.

Ayan George (ayan) wrote :

sfdisk has been pretty much completely re-written since v2.14. I can't reproduce this under Xenial -- sfdisk works as described in the man page.

Ayan George (ayan) on 2016-09-06
Changed in util-linux (Ubuntu):
assignee: nobody → Ayan George (ayan)
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers