Upstream 'column' is newer than bsdmainutils'

Bug #1705437 reported by Ricardo Pérez López
56
This bug affects 9 people
Affects Status Importance Assigned to Milestone
util-linux (Ubuntu)
Low
Unassigned

Bug Description

The 'column' program included in upstream util-linux (https://git.kernel.org/pub/scm/utils/util-linux/util-linux.git/tree/text-utils/column.c) is newer than the included in the bsdmainutil package (https://anonscm.debian.org/cgit/bsdmainutils/bsdmainutils.git/tree/usr.bin/column/column.c). However, debian/rules from util-linux package states the opposite, and therefore Ubuntu now is using 'column' from bsdmainutils instead of the util-linux one.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: util-linux 2.27.1-6ubuntu3.3
ProcVersionSignature: Ubuntu 4.4.0-83.106-generic 4.4.70
Uname: Linux 4.4.0-83-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
CurrentDesktop: i3
Date: Thu Jul 20 11:41:36 2017
InstallationDate: Installed on 2016-04-23 (452 days ago)
InstallationMedia: Lubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: util-linux
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Ricardo Pérez López (ricardo) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in util-linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Robie Basak (racb) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

I haven't verified the details of the versions of "column" as you describe, but it does seem that both bsdmainutils and util-linux are capable of shipping it and so it is disabled from util-linux at the moment. This is derived directly from Debian packaging.

I think it is unlikely that Ubuntu will accept the maintenance cost of a divergence from Debian on this point since this difference only affects a minority of Ubuntu users. If you'd like to see this changed, I think the most productive path forward would be to ask/convince the Debian maintainers of these packages to make this change in Debian. This would best be done by filing a bug in Debian for this. See https://www.debian.org/Bugs/Reporting for information on how to do this.

Please see also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=908975#10

I'm going to set this bug to Won't Fix to Ubuntu to make it clear that I don't believe there will be any intention by Ubuntu developers to make this change. If other Ubuntu developers disagree then we can reopen the bug. Note that if the change is made in Debian then the change will happen in Ubuntu by default regardless of the bug status in Ubuntu (and the status should then be changed).

Changed in util-linux (Ubuntu):
status: Confirmed → Won't Fix
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.