[SRU] exfat not detected by blkid

Bug #1393542 reported by Martin Matuska on 2014-11-17
90
This bug affects 41 people
Affects Status Importance Assigned to Milestone
util-linux (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Felipe Reyes

Bug Description

[Impact]

Due to a upstream bug blkid is unable to detect exfat partitions. This breaks proper detection and automount of exfat formatted partitions (e.g. SD cards or USB sticks) in Ubuntu 14.10.

[Test Case]

Insert an exfat formatted SD Card (card is neither detected nor automounted)
or
run as root: blkid [partition]

Without the fix:
sudo blkid -p /dev/sde1
/dev/sde1: ambivalent result (probably more filesystems on the device, use wipefs(8) to see more details)

With the fix applied:
sudo blkid -p /dev/sde1
/dev/sde1: UUID="BE12-8543" VERSION="1.0" TYPE="exfat" USAGE="filesystem" PTTYPE="dos" PART_ENTRY_SCHEME="dos" PART_ENTRY_TYPE="0x7" PART_ENTRY_FLAGS="0x80" PART_ENTRY_NUMBER="1" PART_ENTRY_OFFSET="32768" PART_ENTRY_SIZE="124702720" PART_ENTRY_DISK="8:64"

[Regression Potential]

None known, the bugfix is simple and part of already released upstream stable release (2.25.2).

[Other Info]

Bug reference: bug #1389021
Upstream issue: https://github.com/karelzak/util-linux/issues/119
Upstream bugfix commit: https://github.com/karelzak/util-linux/commit/98b539c25caede8534ffaf06e67a694eeb3bc6cb

Michael Vogt (mvo) on 2014-11-17
Changed in util-linux (Ubuntu Trusty):
status: New → Invalid
Martin Matuska (mm-vx) on 2014-11-19
description: updated
description: updated
Laurent (l-perlat) on 2014-11-23
Changed in util-linux (Ubuntu Utopic):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in util-linux (Ubuntu):
status: New → Confirmed
Jarl (jarl-dk) wrote :

Can we expect to get a fix for this in Utopic?

Luigi (b-luigi) wrote :

Affected as per Kubuntu 14.10
Very annoying but as per solution on #6 https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/1389021/comments/6
After upgrading the lib AND RESTARTING the pc all is fine.
Thanks

Felipe Reyes (freyes) wrote :

Here I'm attaching a debdiff with the backported fix.

Changed in util-linux (Ubuntu Utopic):
assignee: nobody → Felipe Reyes (freyes)
summary: - SRU: exfat not detected by blkid
+ [SRU] exfat not detected by blkid
Changed in util-linux (Ubuntu Utopic):
status: Confirmed → In Progress
description: updated
tags: added: cts
Martin Pitt (pitti) wrote :

This patch is in vivid.

Changed in util-linux (Ubuntu):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

Sponsored the utopic fix with a better changelog. Thanks!

Hello Martin, or anyone else affected,

Accepted util-linux into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/util-linux/2.25.1-3ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in util-linux (Ubuntu Utopic):
status: In Progress → Fix Committed
Mark Russell (marrusl) wrote :

Fix works for me. Thanks!

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package util-linux - 2.25.1-3ubuntu4.1

---------------
util-linux (2.25.1-3ubuntu4.1) utopic; urgency=medium

  * Add libblkid-zeroize_errno_on_blkid_probe_get_buffer_success.patch: Detect
    exfat file system in blkid. (LP: #1393542)
 -- Felipe Reyes <email address hidden> Mon, 16 Mar 2015 11:24:39 -0300

Changed in util-linux (Ubuntu Utopic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for util-linux has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

tags: added: utopic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers