Broken link /etc/blkid.tab in libblkid1:amd64 2.20.1-5.1ubuntu9

Bug #1244595 reported by Pander on 2013-10-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
util-linux (Ubuntu)
Undecided
Unassigned

Bug Description

Please fix broken link /etc/blkid.tab in package libblkid1:amd64 with version 2.20.1-5.1ubuntu9

Pander (pander) on 2013-10-25
tags: added: 13.10
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in util-linux (Ubuntu):
status: New → Confirmed
Phillip Susi (psusi) wrote :

You mean you don't have a /dev/.blkid.tab?

Changed in util-linux (Ubuntu):
status: Confirmed → Incomplete
Pander (pander) wrote :

Nope. Should it be there? What package should have created it for me?

Phillip Susi (psusi) wrote :

Yes, it should be created by blkid automatically when udev runs it to probe detected disks. The fact that /etc/blkid.tab is a symlink is just to allow the file to be read/write even when / is mounted read/only.

Can you run blkid -p /dev/sda and post the output, and see if that creates the /dev/.blkid.tab?

Pander (pander) wrote :

# blkid -p /dev/sda
/dev/sda: PTTYPE="dos"

# blkid -p /dev/sda1
/dev/sda1: UUID="b511f63d-6002-47a5-98f8-edf2c7b63277" VERSION="1.0" TYPE="ext4" USAGE="filesystem" PART_ENTRY_SCHEME="dos" PART_ENTRY_TYPE="0x83" PART_ENTRY_FLAGS="0x80" PART_ENTRY_NUMBER="1" PART_ENTRY_OFFSET="2048" PART_ENTRY_SIZE="31248384" PART_ENTRY_DISK="8:0"

# date
Mon Oct 28 16:30:17 CET 2013
# ls -lta /dev
total 4
crw-rw-rw- 1 root tty 5, 2 Oct 28 16:30 ptmx
crw-rw-rw- 1 root tty 5, 0 Oct 28 16:28 tty
drwxr-xr-x 2 root root 80 Oct 28 08:37 ati
crw--w---- 1 root tty 4, 7 Oct 28 08:37 tty7
drwxr-xr-x 15 root root 4100 Oct 28 08:37 .
crw-rw-rw- 1 root root 14, 12 Oct 28 08:37 adsp
drwxr-xr-x 2 root root 3840 Oct 28 08:37 char
...

Phillip Susi (psusi) wrote :

Strange, it seems that -p prevents blkid from writing the cache; you have to run it without -p for it to generate the cache. Only thing is, all of the udev rules that run blkid do so with -p, so I don't see how the cache ever gets created.

Changed in util-linux (Ubuntu):
status: Incomplete → Confirmed
Martin Pitt (pitti) on 2014-08-19
Changed in util-linux (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (14.2 KiB)

This bug was fixed in the package util-linux - 2.25-8ubuntu1

---------------
util-linux (2.25-8ubuntu1) utopic; urgency=medium

  * Merge with Debian experimental.
    - This is now a non-ancient version. (LP: #1012081)
    - No longer uses /etc/blkid.tab by default, but a file in /run/.
      (LP: #1244595)
    - mkswap wipes fs signatures (LP: #1047666)
    - Fix "reatime" manpage typo (LP: #1047666)
    - wipefs properly cleans up fs signatures (LP: #1059872)
    Remaining Ubuntu changes:
    - Regularly trim SSDs automatically (core-1311-ssd-trimming):
      + Add debian/fstrim-all: Script to detect which mounted partitions
        need/support trimming, and call fstrim(8) on all of them.
        Install into /usr/sbin/.
      + Add debian/fstrim-all.8: Manpage for the above.
      + Add debian/fstrim-all.cron: Trivial shell script to call fstrim-all,
        so that admins can easily adjust/disable it. Installed as
        /etc/cron.weekly/fstrim.
    - Upstart support:
      + Add hwclock{-save}.upstart, and install them in debian/rules.
      + Drop initscripts dependency.
      + Drop debian/hwclock.rules and hwclock.default.
    - Add mountall-options.patch, see patch header.
    - uuid-runtime.postinst: Due to the way the uuidd account is created, it
      will get a uid/gid allocation for userns use. This isn't needed and is a
      waste of uid/gid so always clear uuidd from subuid/subgid.
  * Drop /lib/init/fstab parsing fallback in mount. Patch does not apply at
    all any more, is specific to mountall (and thus should not be relied
    upon), and not very useful; all init systems, schroot, debootstrap etc.
    mount /sys, /proc/ and friends by themselves already.

util-linux (2.25-8) experimental; urgency=medium

  * Only install linux32/64 manpages on linux-any
  * Fix uuid-runtime.postinst to skip rmdir when not needed (Closes: #757432)
  * fdisk-udeb: use dh-exec to skip sfdisk install on sparc

util-linux (2.25-7) experimental; urgency=medium

  * Mangle installed files on sparc (sfdisk)
  * Fix sparc install mangling
  * Use --disable-mountpoint instead of rm
  * Use dh-exec (>= 0.13)
  * Install mips,ppc,s390 setarch symlinks and manpages

util-linux (2.25-6) experimental; urgency=medium

  The "Jonno was here" release.

  [ Jon Severinsson ]
  * Drop changelog file from the ancient mount source package.

  [ Andreas Henriksson ]
  * util-linux: Drop all (obsolete) Replaces/Conflicts

  [ Jon Severinsson ]
  * Add Replaces/Breaks bash-completion (<< 1:2.1-3).
  * Multiple cleanups in debian/control.
  * Minor cleanup of debian/rules.
  * Use filter, not findstring, for arch matching
  * Simplify linux-only install file handling
  * Use debian/*-udeb.install files for udeb packages.
  * Fix util-linux lintian override.

  [ Andreas Henriksson ]
  * Minor uuid-runtime.postinst cleanup
  * Add d/p/cfdisk-reenable-cursor-when-quitting.patch (Closes: #755991)

util-linux (2.25-5) experimental; urgency=medium

  The "big maintainer-script cleanup" release

  * Drop debian/uuid-runtime.prerm (and related lintian override)
    - dh_installinit will automatically start and stop services as needed.
  * Drop debian/libuuid1.postin...

Changed in util-linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers