Manpage for mount list different options in same paragraph (keybits, nofail, iversion)

Bug #1095521 reported by Chris Good on 2013-01-03
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
util-linux (Debian)
Fix Released
Unknown
util-linux (Ubuntu)
Medium
Alessandro Losavio

Bug Description

man mount shows under section 'FILESYSTEM INDEPENDENT MOUNT OPTIONS' :

       keybits
              Specifies the key size to use for an encryption algorithm. Used
              in conjunction with the loop and encryption options. nofail Do
              not report errors for this device if it does not exist. iver-
              sion Every time the inode is modified, the i_version field will
              be incremented.

The nofail and iversion options should be their own options, not a continuation of 'keybits'.

apt-cache policy util-linux :

util-linux:
  Installed: 2.20.1-1ubuntu3
  Candidate: 2.20.1-1ubuntu3
  Version table:
 *** 2.20.1-1ubuntu3 0
        500 http://au.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue and help making Ubuntu better.

I can confirm these three paragraphs are combined into one in mount's manpage on Ubuntu Raring (util-linux 2.20.1-5.1ubuntu3) as well.

Changed in util-linux (Ubuntu):
status: New → Confirmed
tags: added: bitesize manpage precise quantal raring string-fix
summary: - manpage for mount 12.04.1 LTS corrupted
+ Manpage for mount list different options in same paragraph (keybits,
+ nofail, iversion)
Changed in util-linux (Ubuntu):
assignee: nobody → Alessandro Losavio (alo21)
status: Confirmed → In Progress
Alessandro Losavio (alo21) wrote :

This is the patch, to correct the manpage in mount

The attachment "fix_1095521.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in util-linux (Ubuntu):
importance: Undecided → Medium
Didier Roche (didrocks) wrote :

Thanks alo21 for this fix!

However, we tend to not directly patch the upstream files for that, but rather using a patch against it. Please read https://wiki.ubuntu.com/PackagingGuide/PatchSystems and provide a patch against that file (and report it to debian/upstream as well ;)).

Thanks again for your work there, asking to unsuscribe the sponsoring team meanwhile.

Changed in util-linux (Debian):
importance: Undecided → Unknown
status: New → Unknown
Alessandro Losavio (alo21) wrote :

I attached a debdiff to be applied in Ubuntu Raring. I did it because I think is important fix this bug to avoid wrong understandings. Also a patch has been sent in debain/upstream (patch, not debdiff - as Didier Roche (didrocks) said). I hope this patch is fine, and it will be upload if we will not have time to merge from Debian.

Also, as you can see in the patch, I deleted a nofail option, because it is some lines below too.

Changed in util-linux (Debian):
status: Unknown → Confirmed
Michael Terry (mterry) wrote :

Thanks Alessandro for the patch!

I'm going to disagree with Didier here. We do sometimes directly modify source files, depending on the package (like if Debian isn't using a patch system, we don't generally add one).

Since the other changes to util-linux are direct modifiications, I don't think we need to add a patch system. I'll upload your patch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package util-linux - 2.20.1-5.1ubuntu6

---------------
util-linux (2.20.1-5.1ubuntu6) raring; urgency=low

  * Set iversion as option itself and delete double nofail options
    in mount/mount.8 (LP: #1095521)
 -- Alessandro Losavio <email address hidden> Thu, 24 Jan 2013 21:02:16 +0000

Changed in util-linux (Ubuntu):
status: In Progress → Fix Released
Changed in util-linux (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.