resume after s2disk fails in jaunty

Bug #364360 reported by Erik de Castro Lopo on 2009-04-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
uswsusp (Ubuntu)
Undecided
Unassigned

Bug Description

Machine is a Dell latittude X1.

I had s2disk working well in Intrepid (and also hardy I think), but in jaunty it doesn't work.

Suspend is triggered by "sudo s2disk" and seems to progress as it did on intrepid all the way to power down.

On power up, the kernel doesn't even seem to check to a resume image.

Kernel is:

    Linux mingus 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

The relevant versions are as follows:

     ii uswsusp 0.8-1.1ubuntu3 tools to use userspace software suspend provided by Li
     ii linux-image 2.6.28.11.15 Generic Linux kernel image.

    mingus > lsb_release -rd
    Description: Ubuntu 9.04
    Release: 9.04

    mingus > apt-cache policy uswsusp
    uswsusp:
      Installed: 0.8-1.1ubuntu3
      Candidate: 0.8-1.1ubuntu3
      Version table:
     *** 0.8-1.1ubuntu3 0
            500 http://au.archive.ubuntu.com jaunty/universe Packages
            100 /var/lib/dpkg/status

Matthew Mueller (donut) wrote :

I hit the same problem. I had to add resume=/dev/sda2 to the defoptions line in /boot/grub/menu.lst (and run update-grub.) My /etc/uswsusp.conf already had "resume device = /dev/sda2", but that wasn't good enough (could hibernate, but like the OP it wouldn't even try to resume.)

Matthew Mueller wrote:

> I hit the same problem. I had to add resume=/dev/sda2 to the defoptions
> line in /boot/grub/menu.lst (and run update-grub.)

Good work Mathew. Thats working for me too.

It sure is good to have suspend to disk working again.

Cheers,
Erik
--
----------------------------------------------------------------------
Erik de Castro Lopo
http://www.mega-nerd.com/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers