Gnome closing splash screen doesn't match the desktop being used

Bug #97552 reported by Sam Williams on 2007-03-28
10
Affects Status Importance Assigned to Milestone
usplash (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ubuntu-desktop

I've seen an interesting problem occur when you switch from one desktop to another. In ubuntu, you start with the gnome-desktop and you see the appropriate splash screen when starting up or shutdown. The world is good. If you change to kubuntu or xubuntu you will then see the appropriate splash screens depending on which desktop you have chosen. The world is still good.\

If you move back to the ubuntu-desktop you will see the appropriate starting splash screen, but when shutdown you will see the splash screen of the last desktop used before returning to gnome. The issues persists from one login session to the next. It never automatically corrects itself.

The problem is cosmetic in nature, but might cause many to might wonder why using the ubuntu-desktop they see either the Xubuntu or Kubuntu closing splash screens.... Its pretty insignificant, but something new users might grasp right away.

ProblemType: Bug
Architecture: i386
Date: Wed Mar 28 14:41:00 2007
DistroRelease: Ubuntu 7.04
Uname: Linux samdesk 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

Markus Majer (mpathy) wrote :

I can confirm this bug.
Its not really nice on the eyes and might confuse new users.
Perhaps there should be an question like the question for GDM or KDM, for the splash screens - which flavour someone would like to use.

Another thing could be a dialog in the preferences where someone could switch that - and, which I would appreciate very much, a graphical dialog to switch it off completely and instead switch on verbose text messages.

Also the support of text messages while the splash screen is on should be activated - because if the computer does nothing, noboby can find out why.

There are so many good examples of doing good splash screens out there. Especially those who people can see what and if something is happening.

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release, Hardy Heron 8.04? Thanks in advance.

Changed in ubuntu-meta:
assignee: nobody → charlie-tca
status: New → Incomplete
Broomer68 (jbezemer) wrote :

I don't know if it is the same, but after adding Kubuntu-Desktop and Ubuntu-studio, to a standard Ubuntu install the boot-splash and closing splash do refer to Kubuntu, even if Ubuntu-desktop is reinstalled.
This is with 8.10 beta (and with 8.04.1 and even earlier.
Grub-update does mention that there is _NO_ splash image.

In GDM I don't see any splash (maybe I turned it off years ago)
KDE does have a splash.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Package changed to usplash.

Changed in ubuntu-meta:
assignee: charlie-tca → nobody
importance: Undecided → Low
status: Incomplete → Confirmed
Phillip Susi (psusi) wrote :

The usplash package has been superseded by plymouth and has been removed from the Ubuntu archive. Closing all related bugs.

Changed in usplash (Ubuntu):
status: Confirmed → Invalid
Charlie Kravetz (charlie-tca) wrote :

Usplash is still present in active releases, to include Ubuntu 10.04 and 10.10. It may still be used. The reason given to close this bug is not a valid reason as such.

rmadison usplash
   usplash | 0.2-4 | dapper | source, amd64, i386, powerpc
   usplash | 0.5.19 | hardy | source, amd64, i386
   usplash | 0.5.49 | karmic | source, amd64, i386
   usplash | 0.5.51 | lucid/universe | source, amd64, i386
   usplash | 0.5.52 | maverick/universe | source, amd64, i386

Changed in usplash (Ubuntu):
status: Invalid → Triaged
Phillip Susi (psusi) wrote :

Actually Charlie, it is a valid reason. The default bugtask targets the development release, and in the development release the package has been removed. When bugs are fixed in the development release, they are marked as fixed even though they still exist in older releases. If the bug rises to the level of an SRU, a bug task should be opened targeting that release, otherwise, it will not be fixed there.

Changed in usplash (Ubuntu):
status: Triaged → Invalid
Charlie Kravetz (charlie-tca) wrote :

AS the triager and bug-control member, you have the responsibility to determine if these bugs are indeed valid. It is not up to the reporter to tell you that you made a mistake.

Changed in usplash (Ubuntu):
status: Invalid → Triaged
Phillip Susi (psusi) wrote :

Charlie, it is not valid *in the development release*, therefore the bug task *in the development release* is invalid.

Changed in usplash (Ubuntu):
status: Triaged → Invalid
Charlie Kravetz (charlie-tca) wrote :

Every bug not in the development release is NOT invalid. Please stop playing dangerous games in bug-control now. Your reasoning is not valid, and is not justified.

Changed in usplash (Ubuntu):
status: Invalid → Triaged
Phillip Susi (psusi) wrote :

Charlie, we discussed this on IRC and bdmurray agreed that the correct status for the default task is invalid. Please stop changing it back.

<bdmurray> I can understand the logic behind it usplash doesn't exist in the development release and the default task is for the development release so it is Invalid for Natty+, but each bug should be reviewed to ensure they aren't SRU worthy.

Since this bug is only cosmetic in nature and thus of low importance, it is not an SRU candidate and so will not be fixed.

As of next week, there will not even be any supported releases affected by it anymore since usplash was replaced in 10.04, and it is not part of 8.04's extended 5 year server support.

Please, let this one go; he's dead Jim.

Changed in usplash (Ubuntu):
status: Triaged → Invalid
Charlie Kravetz (charlie-tca) wrote :

Phillip:
Please learn to use the package searches correctly. As I noted way above for your benefit, usplash is very much an active package in both Ubuntu 10.04 and Ubuntu 10.10. Have you honestly decided that since the package was removed from Natty Narwhal, it can not be used in those releases? When did you become so powerful as to make such a ridiculous decision? Are you removing the package from those active releases? Please become the responsible member you should be by now. The usplash package will be supported in Ubuntu 10.04 LTS for the next four (4) years. I am sorry you could not read what I copied from rmadison, but at least now you do know.

Changed in usplash (Ubuntu):
status: Invalid → Triaged
Charlie Kravetz (charlie-tca) wrote :

Should I also remind you that I asked you personally some time ago on IRC to please leave the bugs I triage alone. That was when you were also being a jerk about closing valid bugs because you felt like it.

Phillip Susi (psusi) wrote :

Part of the reason that the package was dropped was because it is not possible to install due to plymouth conflicting with it, and also being required. This is true in 10.04 as well. The package should have been removed in 10.04, but wasn't. As of next week, the only release that can possibly have this package installed is 8.04 and this package is no longer supported there since it is not part of the 5 year extended server support, and this bug does not warrant an SRU there.

Regardless of the above, the status of this task is unquestionably invalid, since this task refers to the development release, and the package does not exist there. bdmurray was clear on this point.

Whether you have triaged a bug or not does not matter; the correct status is the correct status, whether you like it or not.

Changed in usplash (Ubuntu):
status: Triaged → Invalid
Charlie Kravetz (charlie-tca) wrote :

Did you forget already that bdmurray also said the bugs against usplash should not have been closed without reviewing them? Have you considered you might not be correct when you make a decision to do things that others advise against? Are you really so powerful as to ignore all others?

Changed in usplash (Ubuntu):
status: Invalid → Triaged
Phillip Susi (psusi) wrote :

And this bug has been so reviewed. If you feel I am wrong about this bug being a candidate for SRU, then state your case and/or open an appropriate release task. Continuing to change the status of the development task when it has been established that you are wrong is not an appropriate response.

You seem to be having an irrational emotional reaction here. It is not a personal affront that you triaged this bug in the past and the situation has changed causing it to become invalid.

Yes, I considered that I might not be correct, which is why we discussed it on IRC and got bdmurray's input. That should have ended the matter, but you insist on defying established procedure, so you need to ask your question of yourself; Are YOU really so important as to ignore all others? You seem to feel that because you triaged it in the past, you "own" this bug now, and don't care what the proper procedures say -- you're going to stick to your guns no matter what.

If you continue to act irrationally here, I will have to take the matter up with the community council.

Changed in usplash (Ubuntu):
status: Triaged → Invalid
Charlie Kravetz (charlie-tca) wrote :

Do you really think making threats is the way to push your own agenda now? You have declared more powerful than any other triager. It always makes me laugh when the individual that makes the mistake manages to only log and quote the parts of a conversation that make them more powerful in their own mind. Where is the parts that said you were wrong? If you insist on being irrational yourself, feel free to take this to the community council. It is your choice, although if you can declare so many other things as you choose, do you need that to get your own way?

Changed in usplash (Ubuntu):
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers