Usplash artwork missing on upgrades

Bug #61313 reported by Nicolas DERIVE on 2006-09-19
18
Affects Status Importance Assigned to Milestone
usplash (Ubuntu)
Medium
Matt Zimmerman

Bug Description

Binary package hint: usplash

I have the ubuntu-usplash-theme package installed and new usplash theme doesn't displayed on my computer, whereas in knot3 release notes from Corey Burger, it is written that it is now available.

Matt Zimmerman (mdz) wrote :

Is this a fresh install or an upgrade?

If it is an upgrade, I can confirm this.

Changed in usplash:
status: Unconfirmed → Needs Info
Nicolas DERIVE (kalon33) wrote :

An upgrade, like you and all early Edgy testers I presume, so if you confirm it... this is a bug !

Nicolas DERIVE (kalon33) wrote :

I've notice a broken "usplash-artwork.so" symlink in usr/lib/usplash, if it can help...

Matt Zimmerman (mdz) wrote :

I think this is because the usplash-artwork alternative symlink is broken:

mizar:[~/src/canonical/usplash] readlink -f /usr/lib/usplash/usplash-artwork.so
/usr/lib/usplash/usplash-default.so
mizar:[~/src/canonical/usplash] ls -l `!!`
ls -l `readlink -f /usr/lib/usplash/usplash-artwork.so`
ls: /usr/lib/usplash/usplash-default.so: No such file or directory

Changed in usplash:
importance: Untriaged → Medium
status: Needs Info → Confirmed
Matt Zimmerman (mdz) wrote :

Hmm, looking at it, it seems that this setup is now obsolete and should have been removed. Probably what happened was that the alternative was removed before the new artwork was installed, so the alternative was switched to manual.

Mumble mumble alternatives mumble mumble error-prone...

Ricardo Pérez López (ricardo) wrote :

I can confirm this, too, in my Edgy (upgraded from Dapper). Instead of the ubuntu artwork, I have a "screen test" usplash.

Ricardo Pérez López (ricardo) wrote :

Shoot for my Usplash artwork.

(By the way... Is it normal to have a too much little Usplash? The screen test doesn't fill the screen fully.)

Arne309 (arne-mo) wrote :

I can confirm this. I get the same usplash, and it doesn't fill my screen totally.
I also upgraded from Dapper - reinstalling usplash and the theme didn't help..

Misha Koshelev (misha680) wrote :

I have the same thing as the posted screenshot. But I don't think my progress bar is working either. I just upgraded from ubuntu.

Matt Zimmerman (mdz) wrote :

usplash (0.4-31) edgy; urgency=low

  * Attempt to clean up broken artwork alternatives mess by forcing it to auto
    if upgrading from pre-0.4-31 and the target does not exist
    (Closes: LP#61313)

 -- Matt Zimmerman <email address hidden> Sat, 30 Sep 2006 10:59:21 -0700

Changed in usplash:
status: Confirmed → Fix Released
Matt Zimmerman (mdz) on 2006-09-30
Changed in usplash:
assignee: nobody → mdz
Nicolas DERIVE (kalon33) wrote :

It works very great for me ! Thanks for the fix ! :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers