xorg crashes at start with nvidia drivers. Karmic Koala. Nvidia Drivers.

Bug #493384 reported by Julien Soubielle on 2009-12-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usplash (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xorg

Xorg crashes at start since xorg's packages recent updates. I use a Nvidia geforce 5200 on Karmic.

Timo Aaltonen (tjaalton) on 2009-12-07
affects: xorg (Ubuntu) → nvidia-graphics-drivers-173 (Ubuntu)
Neil Perry (nperry) wrote :

Thanks for your bug report and for your contribution to ubuntu. In order to determine if this issue is usplash related, please boot your computer with usplash disabled and then shutdown to see if you can reproduce the issue? To disable usplash for a single boot, follow these steps:

1. Press Esc during Grub boot delay to access the boot menu.
2. Select your actual Ubuntu boot line and press "e" to edit it.
3. Select the "kernel" line and press "e" to edit it.
4. At the end of the line, remove "splash" and "quiet" and press "enter".
5. Type "b" to boot the custom boot line.

Thanks!

Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: New → Incomplete

I have followed your instructions. When i disable usplash, the system start
correctly. when i restart with usplash on, it crashes. So the bug seems to be
related to usplash as you think.

Thanks.

Neil Perry (nperry) wrote :

Can you provide the following information?
 1. A detailed description of the problem, including any error message or special visual phenomenon you might notice.
 2. The file created by this command on a terminal : sudo lspci -vvnn > lspci-vvnn.txt
 3. The file created by this command in a terminal : cat /boot/grub/menu.lst > menu.lst
 4. The file created by this command in a terminal : cat /etc/usplash.conf > usplash.conf
 5. The file created by this command in a terminal : uname -a > uname-a.txt
 6. A photo of the problem (if possible).

Thanks

Neil

Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: Incomplete → Invalid
Changed in usplash:
status: New → Incomplete
Neil Perry (nperry) wrote :

Sorry 3 should be, cat /boot/grub/grub.cfg > grub.cfg

1: When Kubuntu usplash is loading, the screen becomes black before the
end of the loading, sometimes there's a little flash on the screen, then my
monitor says : "there's no signal.

A window appears with : "Ubuntu is running in low graphics mode. Your
screen, graphics card, and input device settings could not be detected
correctly. You will need to configure these yourself."

When i press ok, there's different choices (create a new xorg conf, backup
confi). If i choose : "open console", sometimes there is a black screen,
sometimes the login window appears and i can use Kubuntu.

Neil Perry (nperry) on 2009-12-11
affects: nvidia-graphics-drivers-173 (Ubuntu) → usplash (Ubuntu)
Changed in usplash (Ubuntu):
status: Invalid → Incomplete
Micah Gersten (micahg) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as Triaged and let them handle it from here. Thanks for taking the time to make Ubuntu better! Please report any other issues you may find.

Triager's Note:
Marking bug Low since there's a workaround.

Changed in usplash (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged
Micah Gersten (micahg) wrote :

Resetting upstream to null as it's not needed.

affects: usplash → null
Changed in null:
status: Incomplete → New
Michael Nagel (nailor) wrote :

closing task on NULL project

Changed in null:
status: New → Invalid
Phillip Susi (psusi) wrote :

The usplash package has been superseded by plymouth and has been removed from the Ubuntu archive. Closing all related bugs.

Changed in usplash (Ubuntu):
status: Triaged → Invalid
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers