Usplash not visible on boot

Bug #27837 reported by Florian Zeitz on 2006-01-01
62
Affects Status Importance Assigned to Milestone
Baltix
High
Mantas Kriaučiūnas
usplash (Ubuntu)
Medium
Unassigned

Bug Description

Using an up to date Dapper Drake install usplash is not visible. Instead i just
get a black screen.
I have a GeForce 4 Ti 4200 (if that matters).
On the first Terminal it says:
"usplash: bogl-vga16.c:437: bogl_vga16_put: Assertion `yy + pixmap->height <=
bogl_yres´ failed"

Pascal Vincent (pvincent00) wrote :

On Dapper today, same problem with same message on my compaq armada E500.
Here is my video card :
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M
AGP 2x (rev 64)

Jim McCormick (rantman-2000) wrote :

I have the same problem with a fresh upgrade made last night between 04:30 and 08:30 UTC on 22 January. The problem is exactly identical, same output and everything. Video card is ATI Rage Mobility P/M AGP 2x on a Sony Vaio PCG-9B8L.

David (david-evilduckie) wrote :

I also am experiencing the same problem. Same error message.
Computer is a Toshiba Satellite 1110. Video Card is an ATI Radeom Mobility M6, 16MB Video memory.

This has been happening for a while.

LGB [Gábor Lénárt] (lgb) wrote :

Same problem here after upgrading breezy. Same message on console (viewed from xterm after start of gdm with command cat /dev/vcs1). Besides X, screen is fully blue, no usplash, text or anything. My video hw is nVidia Corporation NV43 [GeForce 6200] (rev a2), arch is amd64-k8.

LGB [Gábor Lénárt] (lgb) wrote :

Another comment: on a i386-P4 system with the same result with nVidia Corporation NV11 [GeForce2 MX/MX 400]. I had grub splash image installed, after starting booting kernel, only a garbage of the grub install screen remains (it reminds me to a corrupted bitplane based screen where bitplanes for various colours differs in horizontal offsets with some garbage on them). Using nosplash kernel parameter, cures the problem of course no usplash then ...

Willi K. (willi-kraml) wrote :

Same here, tested on two machines, one with ATI, the other with Intel i810. Same message on console as reported before....

Florian Zeitz (florian-zeitz) wrote :

Setting vga boot option fixed this for me. Should that be figured out by the installer normally?

Willi K. (willi-kraml) wrote :

I had to use VGA=773 as boot option to make it work...

Raoul Verveer (lazy-r) wrote :

I never got the error message, but using a splash image othe that the default was giving me a black screen during boot. I tried to use VGA=773, but that also didn't work: the screen still was black. Setting VGA to 791 did work though...

Raoul Verveer (lazy-r) wrote :

Excuse me... I was a bit to quick with my previous comment... please ignore.

I fiddled around some more with different splash images and video modes.

VGA=773 DID work! VGA=791 also works, and also 788 (wich is 800x600x16) gave me a splash image.
If i choose one of the 640x480 modes, the screen isn't black, but has the background color from the splash image. After booting, on tty1 the error message from the description is visible. The same can be said if I just leave out the VGA= option (wich defaults to 640x480 i suppose)

I have attached a splash image with an blue background, so you can see what I'm talking about.

My graphic card is also a GeForce4 Ti 4400 by the way...

Yuki Izumi (kivikakk) wrote :

This occurs to the best of us.

Changed in usplash:
status: Unconfirmed → Confirmed
LGB [Gábor Lénárt] (lgb) wrote :

I had this problem on EVERY system I've upgraded from breezy to dapper. It seems that regenerating the initrd (as written in custom usplash howto on ubuntu wiki) cures the problem. The only issue with this: not everybody can do this task without help so it should be done by the upgrading process (I don't know which change created the problem in the system).

On my laptop, this bug was introduced with this morning's update ( usplash 0.1-36). Worked perfecly before.

0000:01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]

Matthew Garrett (mjg59) wrote :

Adam, I suspect that this is the initramfs being generated before the new usplash is installed - can we avoid this with tightened dependencies somewhere?

Raoul Verveer (lazy-r) wrote :

Please ignore my previous comments (heheh... again yeah ;-)

I wondered why my splashimage wasn't working with a 640x480 setting...
...Well, that was because the splashimage should be 640x400, and my (attached) image is also 640x480.

I think I was concentrating on the Vesa resolution so much that I forgot the usplash specs. Why a 640x480 image doesn't work on a 640x480 resolution is still a mystery to me, but anyhow... a 640x400 splash image does work... ...for me.

Anybody else who dares to admit this stoopid mistake ;-) or am I just lucky?

Mantas Kriaučiūnas (mantas) wrote :

I'm confirming this bug on Baltix GNU/Linux (which stable version is still based on breezy).
Baltix has own usplash theme package (like xubuntu and kubuntu has e.g. kubuntu-artwork-usplash), and, problem is, that Ubuntu usplash from doesn't work with older usplash artwork packages (from breezy) - some dependancies should be thightened, maybe usplash in Dapper should conflict with older *-artwork-usplash packages ?
Or maybe *-artwork-usplash packages should behave like libraries and change API version from time to time, when API becomes incompatible?

Pascal Vincent (pvincent00) wrote :

Sorry for being late but i wasn't affect any more by this bug on dapper final. I guess my problem was due to incorrect usplash during development on xubuntu (the distro i have on my old laptop)

Matthew Garrett (mjg59) wrote :

Excellent

Changed in usplash:
status: Confirmed → Fix Released

Seems to be resolved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.