usplash cause reboot when fsck routine check fails

Bug #197302 reported by barbex on 2008-03-01
6
Affects Status Importance Assigned to Milestone
sysvinit (Ubuntu)
Undecided
Unassigned
usplash (Ubuntu)
Undecided
Unassigned

Bug Description

My Laptop keeps rebooting.
The system boots, grub loads, the splash screen appears and the bar moves to the right for about a quarter of the distance. Then I get my reflexes tested because a message appears at the bottom for a few milliseconds that says something like (paraphrasing, it is gone so fast!):
Routine check of sda1 0% progress
press ESC to skip

If I don't hit ESC in that millisecond, the system keeps rebooting forever.

This is new problem that appeared after the updates on Febr. 29.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 650/M650 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS961 [MuTIOL Media IO]
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:06.0 Communication controller: Agere Systems LT WinModem
00:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0c.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus Controller
00:0d.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 04)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 65x/M650/740 PCI/AGP VGA Display Adapter

James Westby (james-w) wrote :

Hi,

Can you boot in to single user mode and run fsck and see if that
crashes the machine?

When you get the grub prompt hit "e", then press "down" once,
then "e" and replace "splash" at the end of the line with "single",
hit "enter" and then "b". This should bring up a menu when booting
and allow you to select a root shell.

Once there then run

  fsck -a /dev/sda

and see if you get the instant reboot.

If simply removing splas from the kernel command line
(as above) works then this is indeed a usplash bug.

If the above procedure does not work then it is a bug lower
down.

Thanks,

James

barbex (barbex) wrote :

(ok, I did e, down, e, single, b)

Before I could even enter fsck I got a forced check by fsck and my screen filled up with error messages. It ended with
/dev/sda1: UNEXPECTED INCONSISTENCY: run fsck manually
fsck died with exit status 4

Then I got errors like
bash: The: command not found

After all that I entered fsck -a /dev/sda1

This brought me to the same messages. Then I ran fsck /dev/sda1 and said "yes" to any suggested fixes. Nothing happened for a while, then I got my root-shell back. I shut down (weird recovery menu appeared on the way out) and booted again.
Apparently all this has killed my X-Server and that is a problem for another time and forum.

In my limited knowledge I would say that my faulty file system has thrown errors in fsck and usplash was unable to deal with that correctly. It could be difficult to recreate this bug.

Andrea Gasparini (gaspa) wrote :

I don't think It's an usplash issue, and mainly that usplash could 'reboot' the machine on his own.

fsck is managed by /lib/init/usplash-fsck-functions.sh (package initscripts) and is his aim to handling fsck error
Perhaps an error like "UNEXPECTED INCONSISTENCY" isn't handled by initstcripts, that doesn't show anything about it??

I feel that the right package that should handle this report is initscript.
I'm going to invalid in usplash and assign to initscript. Please feel free everybody to correct me if i'm not clear or even wrong.

Changed in usplash:
status: New → Invalid
barbex (barbex) wrote :

As the OP I would like to confirm that this bug did not appear again on my system after some time in July. The last time the fsck routine check started it worked as expected.
Thanks for the good work.

Marking bug as fixed.

Changed in sysvinit (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers