Ubuntu/Kubuntu (Xserver?) hangs after logoff with Gainnward 8600GT and Eizo S2411W

Bug #183340 reported by anton on 2008-01-15
6
Affects Status Importance Assigned to Milestone
usplash (Ubuntu)
Undecided
Unassigned

Bug Description

This bug appears in Kubuntu 7.04 / Kubuntu 7.10 and Ubuntu 7.10

I can work normally with my Kubuntu 7.10.

If at the logout I say shutdown, this works.

But if I try to close only the session at logoff
(to login from kdm as another user),
then my monitor switches to 80x25 (?)
Text mode showing me random chars/colors

I wait 5 min, but nothing happens, so it means the PC hangs.

I suppose it's the XServer but I don't know how to determine this.

So if I want lo log off and to log in as an other user,
I always need to reboot my PC.

This is my hardware configuration:

kubuntu 7.10 i386 on an AMD64 bit

Graphic card:
Gainward GF 8600 GT
256MB DDR3 128Bit

Monitor:
Eizo S4211W-WS 1920x1200

anton (antonxx) on 2008-01-15
description: updated
anton (antonxx) wrote :

I forgot to say:
  I use the i386 Kubuntu distribution (NOT the 64 bit version)

By the way ... is there any chance to get a response to this subject?

Mehul J. Rajput (mehulrajput) wrote :

I can confirm that. I am using kubuntu hardy and whenever I log off the kdm login screen does not come up. I have to do a hard reset i.e. shut down to login again.

anton (antonxx) wrote :

Nice to hear that others have the problem too, but since this bug is undecided now since 3 months ...

I don't think that there is interest in solving it.

If I could I would close this bug :-( because it make no sense
having a buglist which is not considered.

Anyway I will not file any bugs concerning kubuntu/ubuntu any more.

rokenn (rokenn) wrote :

I can confirm this problem (on Hardy Heron).

Try to activate the following option in /etc/kde3/kdm/kdmrc:

TerminateServer=true

That will kill and restart the X server on logout - helps for me.

anton (antonxx) wrote :

Thanks a lot rokenn,

  at least this works :-)

anton (antonxx) wrote :

This bug is still present in Kubuntu 8.04

rokenn (rokenn) wrote :

You're welcome. :) And I just noticed that I forgot to give the gdm variant, assuming everyone uses kdm...

I saw yesterday that it does not _always_ work on my machine. But if it doesn't, it helps to switch to a
text console and back to the X console, with 5 seconds wait before each step.

JakobH (j-hansen-566) wrote :

I have a very similar problem where the machine hangs at login or around then. i have tried intalling

Ubuntu 8.04 - Froze during installation - in safe graphics mode :-(
Ubuntu Studio 8.04 - installs in safe graphics mode but only boots to black screen
Kubuntu 8.04 (KDE 3.x) - installed and worked for about 10-15 seconds after login, once it froze during draw of the desktop background so ½ a blue and ½ a black screen
and finally yesterday I tried Wubi, selecting the Kubuntu 8.04 (KDE 4) same ol' same ol'

btw - cant get Knoppix to start. A Debian install started rambling about "an unknown key has been released" and Xserver would start at all so they went down the drain

I will try to reconfigure xserver as described in the wubiguide https://wiki.ubuntu.com/WubiGuide

I belive this works (if indeed it does) on all installations wether Wubi or not.

My graphics card is a Asus EN8600GT, 256MB ddr3, cpu is a Pentium D 915 (or 925) 3.0Ghz, 2 cores. Kernel is the AMD64

I am about to give up on ubuntu/kubuntu - eventhough Kubuntu loads wickedly fast. or even Linux at all, I have down loaded close to 30GB of installs and the only one that works is Mandriva but it's rather sluggish, (but then the kernel is i586) so not interesting.

I have googled but found nothing usable (at least to me but some of that may be because of me being a newbie), this is the first post involving a GF86xx+ graphics chip I found and I strongly suspect the driver (read some xorg file in one of the inststallations where I believe the newest chip mentioned was 7900) but I am not even trying to comprehend howto update the driver via command line. Just now I did find an old link in ubuntuforums re a legacy driver that may/may not work http://ubuntuforums.org/showthread.php?t=213119

hope some one is looking :-)

anton (antonxx) wrote :

I installed a fresh kubuntu 9.04.

With this version all wors fine even sound and 3d acceleration.

Changed in usplash (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers