Ubuntu

blank screen during boot on amd64

Reported by Todd Deshane on 2007-09-18
6
Affects Status Importance Assigned to Milestone
base-installer (Ubuntu)
Undecided
Unassigned
usplash (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: base-installer

gusty tribe 5 desktop live CD for amd64

initial screen with options to choose install, safe graphics mode etc. shows, but then then screen goes blank for awhile.

When X finally loads, the desktop shows up.

It's an Nvidia GeForce 8600GT 256MB card.

Dual monitor acer AL2016W (20 inch wide screens)

Only one of the monitors shows up, which should be another bug, but the new X gtk config stuff may fix this (we hope).

There are similar bugs, but they don't seem to be the same. Listed below are some of them.

#
#138084 [gutsy tribe 5] Screen goes blank booting live CD
New, last updated 2007-09-07
#
 (undecided)
#64502 desktop-cd ubuntu 6.10 beta boots but 'blank screen' only
Incomplete, last updated 2007-01-15
#
 (undecided)
#69609 Live CD boots without screen display on dual head
New, last updated 2007-03-06
#
 (undecided)
#59314 Knot2 Desktop CD Blank Screen / Hangs
Invalid, last updated 2006-10-30
#
 (undecided)
#68905 Live CD unusable with HP Pavillion desktop due to screen resolution
Invalid, last updated 2007-04-14
#
 (medium)
#13785 Hoary Preview Live CD - Blank Screen with Intel 865 On-Board Video
Fix Released, last updated 2005-03-10
#
 (high)
#32815 X server fails to start when booting dapper flight 4 i386 live cd. Produces error message “no screens found”.
Fix Released, last updated 2006-05-03
#
 (undecided)
#124575 Gutsy-Desktop-PPC Build20070705 Not Booting on Live CD
Invalid, last updated 2007-07-07
#
 (undecided)
#71142 Kubuntu 6.10 i386 install CD or DVD cannot start live desktop for installation...
New, last updated 2007-03-10
#
 (undecided)
#69979 Screen goes blank during boot of install CD

Todd Deshane (deshantm) wrote :

attaching /var/log/Xorg.0.log

Todd Deshane (deshantm) wrote :

attaching /etc/X11/xorg.conf

Todd Deshane (deshantm) wrote :

attaching /var/log/messages

Todd Deshane (deshantm) wrote :

$ lspci
00:00.0 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP55 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP55 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP55 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP55 USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP55 USB Controller (rev a2)
00:04.0 IDE interface: nVidia Corporation MCP55 IDE (rev a1)
00:05.0 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:05.1 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:05.2 IDE interface: nVidia Corporation MCP55 SATA Controller (rev a2)
00:06.0 PCI bridge: nVidia Corporation MCP55 PCI bridge (rev a2)
00:06.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
00:08.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
00:09.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)
00:0a.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0d.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:0f.0 PCI bridge: nVidia Corporation MCP55 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:07.0 Ethernet controller: Intel Corporation 82541PI Gigabit Ethernet Controller (rev 05)
01:08.0 Ethernet controller: Intel Corporation 82541PI Gigabit Ethernet Controller (rev 05)
01:0b.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
05:00.0 PCI bridge: PLX Technology, Inc. PEX 8114 PCI Express-to-PCI/PCI-X Bridge (rev bc)
06:04.0 SCSI storage controller: Adaptec ASC-29320ALP U320 (rev 10)
07:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 03)
07:00.1 IDE interface: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 03)
08:00.0 VGA compatible controller: nVidia Corporation Unknown device 0402 (rev a1)

Todd Deshane (deshantm) wrote :

This problem is not limited only to the live CD. after the system is installed same issue exists.

I am doing an apt-get update && apt-get dist-upgrade and will see if it is fixed.

I will report any relevant logs and findings as I can

Todd Deshane (deshantm) wrote :

I remember why I never reported this before... I installed Xen and that shows a text boot up, which is better than a blank screen.

For me this a workaround, but others will not like this.

Evan Dandrea (ev) on 2007-09-19
Changed in base-installer:
status: New → Invalid
Todd Deshane (deshantm) wrote :

I just tested on i386 and the problem doesn't exist.

So this is an amd64 problem. What would be different with the usplash setup/configs for amd64 vs. i386?

I can boot a live CD on another amd64 box later today to see if it is common or just with this video card and/or monitor combination.

Todd Deshane (deshantm) wrote :

It works on the other amd64 box that I tested on a different amd64 box with ATI card
Display controller: ATI Technologies Inc RV370 [Radeon X300SE]
with dual monitors Acer AL1912 and dell 1704FPT digital.

So the problem seems to be with compatibility the Nvidia card that was originally reported.

Let me know what information that I can provide to help this bug to be fixed. As this would be a good one that have working before beta/final release this month/next month.

Todd Deshane (deshantm) wrote :

This is still a bug running the latest beta version of gusty

Tormod Volden (tormodvolden) wrote :

I see you're using the vesa driver. Is it the same with the nv driver?

Todd Deshane (deshantm) wrote :

I am actually using the nvidia driver in my Xorg.conf.

Is there a different setting for usplash?

I just found this thread:
http://ubuntuforums.org/showthread.php?t=275391

It mentions that usplash sometimes doesn't work on amd64. I would be willing to play around with settings, but also a generic good solution to the problem would be good.

Again, it is not simply a amd64 problem, as my other amd64 boxes that I have tested on didn't have the problem.

Is there a good way to get the usplash specific log(s) that would may help diagnose my problem?

Sitsofe Wheeler (sitsofe) wrote :

(This sounds like a dup of other usplash+new nvidia card bugs like Bug #116103 ...)

Tormod Volden (tormodvolden) wrote :

Sorry, I didn't read your description well enough: it's blank _until_ X starts, so of course it's not a X driver issue like I thought.

It must be the way usplash selects and sets the video mode, using the BIOS.

Changed in usplash:
status: New → Confirmed
Todd Deshane (deshantm) wrote :

adding vga=<an appropriate number here> seems to work fine. Although, as it finishing loading there is a long period of blank screen.

Is there a reason why vga= can't be exist by default? Could it be added dynamically? other options for it to work out of the box?

Tormod Volden (tormodvolden) wrote :

Is there a good way to find the appropriate number automatically?

Todd Deshane (deshantm) wrote :

After install, the default resolution would work. I personally would like it to be most conservative before that if it can't be detected right. So, default to 640x480 maybe.

Tormod Volden (tormodvolden) wrote :

So this happens only when you boot the live CD, and it works fine after installation?

Todd Deshane (deshantm) wrote :

No it happens everytime. I had originally thought that it was only the liveCD. The reason that I thought that was I had installed Xen, which gives the console by default so I never reported the problem at that point.

But once the system actually boot, the Xorg configuration works fine enough. The resolution that it chose (or the default resolution that the user chooses) could be put into the grub.conf file as the vga option. That could solve the problem from that point forward.

Being conservative on the liveCD, would be best that way more hardware is supported and works out of the box.

Rion Aoki (aoki) wrote :

I just booted with Gutsy RC amd64 and the same thing happend to my machine with an Nvidia GeForce 8600GT 256MB card.

Rohaq (rohaq) wrote :

Getting the same problem here on AMD64 Gutsy, with an AMD Turion 64 MT-40 (2.2GHz) and an ATI Mobility X1600 with the ATI drivers. Ubuntu starts up, then there's a blank screen for a good 3 or 4 minutes before the login screen appears. No splash screen.

This wasn't happening on the 32 bit version of Feisty, same hardware and ATI drivers :(

Rohaq (rohaq) wrote :

Okay, so I installed Startup Manager through Synaptic, and used that to configure the splash screen VGA options to 800x600x8bits (VGA=771 in menu.lst), and now I have a splash screen and a hugely decreased startup time.

So that's sorted it, awesome.

rhi (rhi-deactivatedaccount) wrote :

Have the same problem.

01:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)

rhi (rhi-deactivatedaccount) wrote :

Related to bug #116103?

Saivann Carignan (oxmosys) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 147623, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers