[SiS] 'Inappropriate ioctl for device' and no splash screen at shutdown

Bug #102894 reported by Lucy Bate
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usplash (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xorg

I currently have the Beta release of Feisty installed. When I shut the computer down, I do not see a graphical shutdown screen with progress bar, but instead a series of messages. One of these is as follows:

bog1_init failed: : reading screen info : Inappropriate ioctl for device
screen init failed

I'm assuming that this is a problem with X, although everything else seems to work fine. Here is the information about my graphics card from lspci -vv:

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter (prog-if 00 [VGA])
        Subsystem: Foxconn International, Inc. Unknown device 0c4c
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        BIST result: 00
        Region 0: Memory at d8000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at e1000000 (32-bit, non-prefetchable) [size=128K]
        Region 2: I/O ports at 9000 [size=128]
        Capabilities: <access denied>

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

I guess the problem is with usplash.. could be wrong though.

Revision history for this message
James Bostian (stoney57) wrote :

I also have the same Sis integrated video controller(VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760) and am getting the same error message at shutdown.

Revision history for this message
SteBo (stebo) wrote :

I see the same problem with two computers (one Ubuntu, one Kubuntu) that I upgrade from Edgy final to Feisty final.

Both computer also have SIS graphics hardware.

sudo lspci -vv:
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 65x/M650/740 PCI/AGP VGA Display Adapter (prog-if 00 [VGA])
        Subsystem: Micro-Star International Co., Ltd. Unknown device 5350
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 3
        BIST result: 00
        Region 0: Memory at d0000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at dfee0000 (32-bit, non-prefetchable) [size=128K]
        Region 2: I/O ports at bc00 [size=128]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] AGP version 2.0
                Status: RQ=16 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3- Rate=x1,x2,x4
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=<none>

Revision history for this message
Keidson Paiva de Freitas (keidson) wrote :

I have the same problem here. My laptop is one Acer Aspire 3003LCi and on shutdown/reboot there's no splash screen, just text mode, and the same message 'bog1_init failed : reading screen info : Inappropriate ioctl for device screen init failed' appears.

Revision history for this message
Keidson Paiva de Freitas (keidson) wrote :

I forget to show my video card info. Sorry about that.

Here is it:

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter (prog-if 00 [VGA])
        Subsystem: Acer Incorporated [ALI] Unknown device 0083
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 7
        BIST result: 00
        Region 0: Memory at e8000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at e2100000 (32-bit, non-prefetchable) [size=128K]
        Region 2: I/O ports at a000 [size=128]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] AGP version 3.0
                Status: RQ=256 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3+ Rate=x4,x8
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=<none>

Revision history for this message
Roman Polach (rpolach) wrote :

I have the same problem with SiS 661GX graphics in Feisty

Revision history for this message
Saivann Carignan (oxmosys) wrote :

Thanks for your bug report and for your contribution to ubuntu. Can your confirm if this bug still happens with latest Gutsy release? I've already seen this problem in the past (not sure if it was with a SiS graphic card) and it was fixed in Gutsy.

Changed in usplash:
assignee: nobody → saivann
status: New → Incomplete
Revision history for this message
Saivann Carignan (oxmosys) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in usplash:
status: Incomplete → Invalid
assignee: saivann → nobody
Revision history for this message
Steve Magoun (smagoun) wrote :

I reproduced this on Hardy (with all updates as of 16Jun08 including -19 kernel) with an SiS 740 hooked up to a KDS Rad-5 15" monitor.

An additional symptom, I get the same "inappropriate ioctl" error if I switch to a VT and run 'sudo usplash -c -v'. strace reports that the FBIOGET_FSCREENINFO ioctl is the one that fails in this case.

Changed in usplash:
status: Invalid → New
Revision history for this message
Steve Magoun (smagoun) wrote :
Revision history for this message
Steve Magoun (smagoun) wrote :
Revision history for this message
Steve Magoun (smagoun) wrote :
Revision history for this message
Steve Magoun (smagoun) wrote :
Revision history for this message
Saivann Carignan (oxmosys) wrote :

Thanks for your confirmation. Since duplicate bug 151692 confirms the problem and that we have sufficient informations about this problem, I set the status to Triaged.

Changed in usplash:
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Steve Magoun (smagoun) wrote :

Re: comment #9

'sudo usplash -c -v -x 1024 -y 768' works fine if I first load the sisfb driver (modprobe sisfb). The usplash screen also appears on shutdown after loading the sisfb driver, though the image is distorted unless I first change the vt to the right resolution (e.g. via usplash -c -x 1024 -y 768).

Revision history for this message
notoriousdbp (david-baird-parker) wrote :

If you edit /etc/modules and add sisfb to the bottom of it, sisfb loads up at boot time so you get the splash screen on shutdown. I have tested this in Hardy and can confirm it works.

Revision history for this message
notoriousdbp (david-baird-parker) wrote :

Although not necessarily with every sis card it would appear by looking at my other machine

Revision history for this message
Phillip Susi (psusi) wrote :

The usplash package has been superseded by plymouth and has been removed from the Ubuntu archive. Closing all related bugs.

Changed in usplash (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers