Display gets corrupted with 0.22

Bug #345269 reported by Andrea Cimitan on 2009-03-19
24
Affects Status Importance Assigned to Milestone
kubuntu-default-settings (Ubuntu)
Undecided
Martin Pitt
Jaunty
Undecided
Martin Pitt
usplash-theme-ubuntu (Ubuntu)
High
Martin Pitt
Jaunty
High
Martin Pitt
xubuntu-artwork (Ubuntu)
Medium
Martin Pitt
Jaunty
Medium
Martin Pitt

Bug Description

Binary package hint: usplash-theme-ubuntu

After the pulsing, when the bar starts loading the scripts, the screen is corrupted.
No corruption with the old theme.

Ubuntu Jaunty LPIA.

lanzen (lanzen) wrote :

Well, looking for a bug similar to what I get I've found this though '0m on Jaunty standard, not LPIA, running on a eeepc 1000H.

Also, I cannot access to virtual terminal tty1 to 6 anymore. It all started since the new upslash was installed.

exactly, same issue with the tty

Martin Pitt (pitti) wrote :

Confirmed here, too, when running the usplash test suite.

Changed in usplash-theme-ubuntu (Ubuntu):
assignee: nobody → pitti
importance: Undecided → High
status: New → In Progress
tags: added: regression-potential
Martin Pitt (pitti) wrote :

I nailed it down. It didn't occur to me when testing the previous update, since the 1280x1024 resolution is not affected.

Martin Pitt (pitti) wrote :

Same problem in the kubuntu usplash theme, will fix as well.

Changed in kubuntu-default-settings (Ubuntu Jaunty):
assignee: nobody → pitti
status: New → In Progress
Martin Pitt (pitti) wrote :

Uploaded, waiting in unapproved now.

Changed in usplash-theme-ubuntu (Ubuntu Jaunty):
status: In Progress → Fix Committed
lanzen (lanzen) wrote :

Nice one Martin.
BTW, what about xubuntu, is it going to be affected also?

Martin Pitt (pitti) wrote :

kubuntu usplash fix uploaded as well.

Changed in kubuntu-default-settings (Ubuntu Jaunty):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

For the record, ubuntustudio usplash is unaffected.

I checked the xubuntu theme, and indeed it does have this problem.

Martin Pitt (pitti) wrote :

The xubuntu usplash theme didn't change recently, so I guess it's a much less severe problem. It should still be fixed, though.

Changed in xubuntu-artwork (Ubuntu Jaunty):
assignee: nobody → pitti
importance: Undecided → Medium
status: New → In Progress
Martin Pitt (pitti) wrote :

xubuntu fix uploaded

Changed in xubuntu-artwork (Ubuntu Jaunty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usplash-theme-ubuntu - 0.23

---------------
usplash-theme-ubuntu (0.23) jaunty; urgency=low

  * usplash-theme-ubuntu.c, t_animate_step_{16,32}: Use the correct image's
    width for calculating the number of pulsating steps. Previously, this
    triggered integer, and thus buffer overflows, which caused screen
    corruption and sometimes complete corruption of the VTs. (LP: #345269)

 -- Martin Pitt <email address hidden> Thu, 19 Mar 2009 22:03:02 +0100

Changed in usplash-theme-ubuntu:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-default-settings - 1:9.04.23

---------------
kubuntu-default-settings (1:9.04.23) jaunty; urgency=low

  * usplash/usplash-theme-kubuntu.c, t_animate_step_{16,32}: Use the correct
    image's width for calculating the number of pulsating steps. Previously,
    this triggered integer, and thus buffer overflows, which caused screen
    corruption and sometimes complete corruption of the VTs. (LP: #345269)

 -- Martin Pitt <email address hidden> Thu, 19 Mar 2009 22:11:47 +0100

Changed in kubuntu-default-settings:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-artwork - 0.23

---------------
xubuntu-artwork (0.23) jaunty; urgency=low

  * usplash-theme-xubuntu.c, t_animate_step_16: Use the correct image's
    width for calculating the number of pulsating steps. Previously, this
    triggered integer, and thus buffer overflows, which caused screen
    corruption and sometimes complete corruption of the VTs. (LP: #345269)

 -- Martin Pitt <email address hidden> Thu, 19 Mar 2009 22:42:34 +0100

Changed in xubuntu-artwork:
status: Fix Committed → Fix Released
lanzen (lanzen) wrote :

Indeed it is. Nice and fast, thank you.

Hi,
I bought a TV last week from a website:www.hkeles.com. I have
received the product. The quality is very good. They also sell
phones,motor,psp and so on. Because of the financial crisis, their
products are very cheap. by the way, they only sell new and original
products .If you need these products, you can have a look . I think
you will get many benefits.
Greetings!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers