wrong aspect ratio for 1680x1050 wide screen

Bug #245437 reported by Leonard Michlmayr on 2008-07-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usplash-theme-ubuntu (Ubuntu)
Undecided
Unassigned
Declined for Hardy by Martin Pitt
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

For high resolution wide screen configurations usplash-theme-ubuntu 0.19 will display an boot screen image that appears to be squeezed horizontally.

How it is fixed in jaunty: usplash-theme-ubuntu 0.20 has fixed this problem by choosing the correct image for high resolution wide screen. Version 0.19 chose usplash_1365_768_scaled.png, version 0.20 now chooses usplash_1365_768.png. Some parameters for the geometry of the progress bar and text box have been adapted.

Minimal patch: a minimal patch is attached to this bug report.

TEST CASE: edit /etc/usplash.conf to contain xres=1680 and yres=1050, use the the boot option vga=873. (You will have to use an appropriate screen with a 16:10 aspect ratio.)

Example hardware: Compal FL90 laptop with a 1680x1050 wide screen panel and an nvidia 8600 GT. Use grub with vga=873.

A fixed package can be found at https://launchpad.net/~leonard-michlmayr/+archive/ppa
Please test it and report your results. (Even if you have a different screen resolution.)

Regression potential: the package has an important influence on user experience, but no influence on the system. Therefore I think the change does not have much potential of negative side effects.

Michael Nagel (nailor) wrote :

confirming, usplash logos look weird on my 1680x1050-display since dapper and it never improved

Changed in usplash-theme-ubuntu:
status: New → Confirmed

Ok. The patch that I attach to this comment fixes things for me. It fixes the distortion and also puts the progressbar and text box in a nice position.

I will provide a fixed package in my PPA

Changed in usplash-theme-ubuntu:
assignee: nobody → leonard-michlmayr-first
status: Confirmed → In Progress

Fix available at my PPA

description: updated
Changed in usplash-theme-ubuntu:
status: In Progress → Fix Committed

Since I am not a MOTU, assign to nobody

Changed in usplash-theme-ubuntu:
assignee: leonard-michlmayr-first → nobody
description: updated

Maybe »committed« is the wrong word. There is a fix available, please commit it!

Changed in usplash-theme-ubuntu:
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usplash-theme-ubuntu - 0.20

---------------
usplash-theme-ubuntu (0.20) jaunty; urgency=low

  * fix layout for big wide screens. (LP: #245437)

 -- Leonard Michlmayr <email address hidden> Mon, 02 Feb 2009 10:31:55 +0100

Changed in usplash-theme-ubuntu:
status: In Progress → Fix Released
Bryce Harrington (bryce) wrote :

Thanks; uploaded to jaunty.

If it is verified to work on Jaunty, an SRU would be acceptable; please follow the SRU process for doing this - https://wiki.ubuntu.com/StableReleaseUpdates

Changed in usplash-theme-ubuntu:
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Chris Jones (cmsj) wrote :

Without wishing to seem overly pedantic, 1680x1050, 1365x768 (and other increasingly common resolutions like 1440x900 and 1280x800) are 16:10, not 16:9. My laptop is 16:10 and has always shown the usplash image squashed vertically (I have never made any attempt to configure usplash, and I'm pretty sure that one generally shouldn't assume people will).
I'll test out the jaunty upload and see how it looks :)

(IME uplash always gets things right on 4:3 screens and 16:9 screens, but I've not tested it beyond 1920x1080)

philinux (philcb) wrote :

Jaunty 64 bit fully up to date.

Just changed usplash.conf to show 1680x1050 and rebooted. My usplash is still squashed vertically.

Ad Chris Jones
I am aware that 1680x1050 is 16:10 and not 16:9. usplash chooses the aspect ratio that fits best. 16:9 is better than 4:3 for a 1680x1050 screen.

My patch will not fix the problem that usplash does not offer other aspect ratios than 4:3 and 16:9. However, I just made sure that 16:9 really is 16:9 and not 64:27.

I hope we can have a more general solution in usplash some day. I will have a look at https://bugs.launchpad.net/ubuntu/+source/usplash/+bug/64147 which I have not noticed earlier.

Ad phillinux:
Thank you for your comment!

Please list the files /etc/usplash.conf, /etc/modprobe.d/uvesafb, and /proc/cmdline

Try to compare the intrepid version with the jaunty version. Which looks better?
In my experience the intrepid version is squashed horizontally massively.

It may depend on the framebuffer. If you have a 16:10 screen, but a 4:3 framebuffer, then pixels will not be squares.

Ad Chris Jones:
Sorry. Thank you for your comment too. I am looking forward to hear the results of your testing.

description: updated

I am sorry, I wanted to nominate this bug for release in intrepid, but accidenlty chose hardy.

description: updated
Martin Pitt (pitti) wrote :

This doesn't meet the SRU criteria for updates (https://wiki.ubuntu.com/StableReleaseUpdates). Given how brittle usplash is in general, I'd rather not touch it in stable releases for cosmetical bugs.

Changed in usplash-theme-ubuntu:
status: New → Won't Fix

This sounds equitable. Sorry to bother you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers