Progress bar flickers during redraw

Bug #205854 reported by Daniel Sargeant on 2008-03-24
20
Affects Status Importance Assigned to Milestone
usplash-theme-ubuntu (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: usplash

Using Hardy with usplash 0.5.16. The progress bar flickers / flashes black when being redrawn to the screen. It appears that the entire progress bar background is being redrawn over the foreground. Could this be caused by incorrect parameters to usplash_put_part?

Saivann Carignan (oxmosys) wrote :

Thanks for your bug report. Can you try with 0.5.17 if your can still reproduce that issue? Also can you maybe provide a little video that shows the problem?

  • unnamed Edit (1.5 KiB, text/html; charset=ISO-8859-1)

I tested it again after the update and it still flickers. Unfortunately I
do not have a camera to record a video with. To be a little more
descriptive, the orange of the progress bar will occasionally flash black.
By the way, I have an intel x3100 graphics chip. Others might not be seeing
the flicker because vsync works with their graphics chip and the frame is
drawn during the screen refresh. The theme shouldn't have to rely on this,
though, and should only redraw what is necessary. The progress bar
background should only be drawn to the frame on the parts that were orange
before and aren't any longer. Glancing through the code, I think that
usplash_put_part can be used to only draw a portion of the image.

On Wed, Mar 26, 2008 at 3:31 PM, Saïvann Carignan <email address hidden> wrote:

> Thanks for your bug report. Can you try with 0.5.17 if your can still
> reproduce that issue? Also can you maybe provide a little video that
> shows the problem?
>
> --
> Progress bar flickers during redraw
> https://bugs.launchpad.net/bugs/205854
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in usplash:
status: New → Fix Committed
Daniel Sargeant (dsargeant) wrote :

This is really a usplash-theme-ubuntu bug.

Alexander Jones (alex-weej) wrote :

The correct solution here is proper double-buffering, no? FTR, this has been an active bug since the introduction of usplash.

Saivann Carignan (oxmosys) wrote :

Since a bazaar branch is availabe, shouldn't we subscribe the Main Sponsor Team? Thanks for this great work on this!

Daniel Sargeant (dsargeant) wrote :

Alexander, I agree, double buffering would be an ideal solution for usplash in general. It would avoid problems of this nature in the future. Until double buffering is the default, though, this will fix the current theme.

Daniel Sargeant (dsargeant) wrote :

Subscribed Main Sponsor Team as Saïvann suggested.

Daniel Holbach (dholbach) wrote :

Martin: can you take a look at it?

Martin Pitt (pitti) on 2008-03-31
Changed in usplash-theme-ubuntu:
assignee: nobody → pitti
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usplash-theme-ubuntu - 0.18

---------------
usplash-theme-ubuntu (0.18) hardy; urgency=low

  * Fix flickering of the progress bar. Thanks to Daniel Sargeant for the
    patch! (LP: #205854)

 -- Martin Pitt <email address hidden> Tue, 01 Apr 2008 16:15:40 +0200

Changed in usplash-theme-ubuntu:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments