User not created with encrypted home partition: user-setup exit code 32

Bug #820460 reported by Charlie Kravetz on 2011-08-03
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
user-setup (Ubuntu)
Critical
Colin Watson
Oneiric
Critical
Colin Watson

Bug Description

RELEASE: Oneiric Ocelot Alpha3 candidate
CD/DVD VARIANT: Xubuntu Alternate i386 and amd64 images
ISO BUILD: 20110802.1

SYMPTOMS:
After installing using the instructions provided at http://testcases.qa.ubuntu.com/Install/AlternateEncryptedLvm , when restarting, I can enter the passphrase. When lightdm starts, entering the username and password results in "Incorrect password". Switching to a tty, entering the same information results in "login incorrect". Since this is an encrypted drive, I can not access any logs.

STEPS TO REPRODUCE:

    Step 1: install Xubuntu using the instructions for the encrypted LVM install:
                 http://testcases.qa.ubuntu.com/Install/AlternateEncryptedLvm
    Step 2: Attempt to login to lightdm

This has failed for me using two different hardware computers and VirtualBox.

tags: added: iso-testing
Charlie Kravetz (charlie-tca) wrote :

Simply encrypting /home will also cause login to fail for bad password.

Since I can reproduce this on any of my hardware systems, if someone can tell me how to get the logs from the encrypted drive, I will attach them.

madnick (dr-madnick) wrote :

I have the same issue, the ISO I use is the 20110805 xubuntu alt-i386 image.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

why do you think it's a lightdm issue if the login doesn't work on a normal vt either?

Jean-Baptiste Lallement (jibel) wrote :

Brian, could you have a look at it, that looks more like a general authentication issue than lightdm specific.

Changed in lightdm (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Confirmed → Incomplete
Sebastian Bengtsson (5ebastian) wrote :

I have some results from actual usage more similar to
http://testcases.qa.ubuntu.com/Install/AlternateEncryptedHome

Ubuntu alternate i386 alpha3:
LVM install, no encrypted volumes. After I set up a default user, debinstall prompts if I want encrypted home dir, and I choose yes. Finnish install but don't reboot. Get shell and cat /target/etc/passwd. Default user (uid=1000) has NOT been added.

Jean-Baptiste Lallement (jibel) wrote :

Could you please attach the installer log from /var/log/installer ?
You can collect the installer logs by booting in rescue mode and mounting LVM root partition. Thanks in advance.

affects: lightdm (Ubuntu) → debian-installer (Ubuntu)
Changed in debian-installer (Ubuntu):
importance: Undecided → Critical
importance: Critical → High
summary: - Encrypted LVM install will not allow login in Xubuntu Alpha3
+ User not created with LVM and encrypted home partition
Jean-Baptiste Lallement (jibel) wrote :

I reproduced it with d-i and selecting 'Encrypted Home' (LVM or not doesn't matter)
syslog (attached) contains the following warning:
 finish-install: warning: /usr/lib/finish-install.d/06user-setup returned error code 32

the user is not created at all (no home directory, no password entry added)

summary: - User not created with LVM and encrypted home partition
+ User not created with encrypted home partition: user-setup exit code 32
Changed in debian-installer (Ubuntu Oneiric):
importance: High → Critical
status: Incomplete → Triaged
Changed in debian-installer (Ubuntu Oneiric):
assignee: Brian Murray (brian-murray) → Canonical Foundations Team (canonical-foundations)
Sebastian Bengtsson (5ebastian) wrote :

My installer syslog might be a bit messy as I did hands-on (chroot) to get the system up.
The line "finish-install: warning: /usr/lib/finish-install.d/06user-setup returned error code 32" is present.

Brian Murray (brian-murray) wrote :

A bit more context regarding the error follows:

Aug 11 08:21:41 finish-install: + log-output -t user-setup chroot /target mount -t sysfs sysfs /sys
Aug 11 08:21:41 finish-install: + umountsys=:
Aug 11 08:21:41 finish-install: + log-output -t user-setup chroot /target mount -t tmpfs tmpfs /dev/shm
Aug 11 08:21:41 user-setup: mount: mount point /dev/shm does not exist
Aug 11 08:21:41 user-setup:
Aug 11 08:21:41 finish-install: warning: /usr/lib/finish-install.d/06user-setup returned error code 32

Changed in debian-installer (Ubuntu Oneiric):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
Colin Watson (cjwatson) on 2011-08-12
affects: debian-installer (Ubuntu Oneiric) → user-setup (Ubuntu Oneiric)
Changed in user-setup (Ubuntu Oneiric):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package user-setup - 1.28ubuntu18

---------------
user-setup (1.28ubuntu18) oneiric; urgency=low

  * Make sure /dev/shm exists before mounting it for ecryptfs (LP: #820460).
 -- Colin Watson <email address hidden> Fri, 12 Aug 2011 15:45:53 +0100

Changed in user-setup (Ubuntu Oneiric):
status: In Progress → Fix Released
Daniel Swarbrick (pressureman) wrote :

I still had problems with an amd64-alternate installer from 2011-08-15. I don't have the installer logs, but it appeared that the installer kernel did not support ecryptfs (not shown in /proc/filesystems) and there was no ecryptfs.ko to be found. When user-setup tried to create the ecryptfs home dir, it naturally failed.

I managed to work around this upon the second attempt by chdir'ing into the target install's /lib/modules directory, and manually insmod'ing the ecryptfs.ko before responding to the debconf question, whether I wanted to encrypt my home directory. That seemed to work ok.

However, after rebooting into the new install, lightdm fails to transition to the desktop after entering the password. If I switch to another text mode vty and log in, it mounts my ecryptfs home dir fine, and if I then switch back to lightdm and log in graphically, that also succeeds. So it would appear that lightdm has problems mounting the ecryptfs directory.

Daniel Swarbrick (pressureman) wrote :

This is probably unrelated to the original bug, but I found that installing gdm and setting it as the default login manager, I was then able to successfully log in (and the ecryptfs home dir was successfully mounted). Not too surprising, since lightdm is still under heavy development from what I've seen.

Daniel, thanks for your comment. This is a different problem. I've been able to reproduce and filed report 827197. You may wish to subscribe to this report to track the status.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers