[PATCH] Initial user should be added to sambashare group if it exist

Bug #238224 reported by Mantas Kriaučiūnas on 2008-06-07
12
Affects Status Importance Assigned to Milestone
user-setup (Baltix)
Undecided
Unassigned
user-setup (Ubuntu)
Medium
Unassigned
Hardy
Medium
Colin Watson

Bug Description

Binary package hint: user-setup

Initial user should be added to sambashare group if it exist. I'm developing Ubuntu-Desktop 8.04 based distribution, with samba package included as default, but after installation with Ubiquity initial user isn't added to sambashare group :(

I'm attaching a patch against /usr/lib/user-setup/user-setup-apply - it should add initial user to sambashare group, but it seems this patch isn't enough, as initial user still isn't added to sambashare group after installation from Hardy-based LiveCD this patch applied and samba package installed :(

Please, fix the Ubiquity installation system to add initial user to sambashare group if it exist.

Michael Rooney (mrooney) wrote :

Thanks Mantas. Could you just clarify, this patch does in fact NOT address the issue? Should it be used for any reason?

Also, what is the rationale for adding the initial user to the sambashare group if it exists? Thanks for adding this extra information, thanks!

Changed in user-setup:
status: New → Incomplete

On Sat, Jun 07, 2008 at 10:38:37PM -0000, Mike Rooney wrote:
> Thanks Mantas. Could you just clarify, this patch does in fact NOT
> address the issue? Should it be used for any reason?

This patch should fix the issue, but after testing I've noticed, that this
patch doesn't help (I don't know why, it seems more debugging is needed).

> Also, what is the rationale for adding the initial user to the
> sambashare group if it exists? Thanks for adding this extra information,

Initial user is added to all administrative groups, like admin, dip, adm,
so, why we should to forbid file sharing for user with all administrative
rights? You can see how many people meets simmilar problem at bug #212098

Default Ubuntu-Desktop CD doesn't have samba package included, so, there
are no sambashare group in Ubuntu CD, but several Ubuntu-based distributions
include samba as default and in these distros there is sambashare group,
adding initial user to this group would solve bug #212098 for such distros.

> --
> [PATCH] Initial user should be added to sambashare group if it exist

--
Labanaktis/Good luck,
Mantas Kriaučiūnas Jabber ID: <email address hidden> GPG ID: 43535BD5
Public organization "Open Source for Lithuania" - www.akl.lt

Michael Rooney (mrooney) wrote :

Thanks Mantas, confirming this issue thanks to your explanation. Do you plan on doing more work in an attempt to get a functional patch (should we assign the bug to you?). Hopefully someone from user-setup can take a look at your patch to see if they understand why it might fail.

Changed in user-setup:
importance: Undecided → Low
status: Incomplete → Confirmed
Colin Watson (cjwatson) wrote :

Err, why not just add sambashare to passwd/user-default-groups?

Colin Watson (cjwatson) on 2008-07-03
Changed in user-setup:
importance: Low → Medium
Colin Watson (cjwatson) wrote :

Attaching this to Hardy as well. This isn't the only thing that needs to be fixed to make this a decently smooth process (see bug 212098), so, since at this point we have to wait for 8.04.2 anyway before new installer code can effectively be rolled out, I'd like to let it shake out in Intrepid first.

Changed in user-setup:
importance: Undecided → Medium
milestone: none → ubuntu-8.04.2
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package user-setup - 1.20ubuntu2

---------------
user-setup (1.20ubuntu2) intrepid; urgency=low

  * Create sambashare group and add the initial user to it (thanks, Mantas
    Kriaučiūnas; LP: #238224).
  * Stop creating /etc/aliases, since apparently postfix would rather have a
    blank slate (LP: #228391).

 -- Colin Watson <email address hidden> Thu, 03 Jul 2008 01:27:31 +0100

Changed in user-setup:
status: Confirmed → Fix Released
Colin Watson (cjwatson) on 2008-11-03
Changed in user-setup:
assignee: nobody → kamion
Colin Watson (cjwatson) wrote :

I've uploaded this to hardy-proposed now, since bug 212098 saw a hardy-proposed upload recently.

Changed in user-setup:
status: Confirmed → In Progress
Steve Langasek (vorlon) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in user-setup:
milestone: ubuntu-8.04.2 → none
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

I've just uploaded ubiquity 1.8.13 to hardy-proposed, including this fix. (Prior to this, testing was only possible with alternate/server CDs.)

Dave Morley (davmor2) wrote :

Tested on cd 20090112.1.

Sambashare is now listed under Groups settings for initial user.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package user-setup - 1.16ubuntu6

---------------
user-setup (1.16ubuntu6) hardy-proposed; urgency=low

  * Create sambashare group and add the initial user to it (thanks, Mantas
    Kriaučiūnas; LP: #238224).

 -- Colin Watson <email address hidden> Mon, 15 Dec 2008 12:19:21 +0000

Changed in user-setup:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions