Autologin not correctly enabled on 15.10 installations

Bug #1498544 reported by Kev Bowring on 2015-09-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
user-setup (Ubuntu)
High
Sebastien Bacher

Bug Description

Installed 15.04, using autologin.

Updated and upgraded 15.04.

System autologin works correctly.

Upgraded (via image http://iso.qa.ubuntu.com/qatracker/testcases/1498/info) then rebooted.

Autologin fails.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: lightdm 1.16.2-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-10.12-generic 4.2.0
Uname: Linux 4.2.0-10-generic x86_64
ApportVersion: 2.18.1-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue Sep 22 16:10:39 2015
InstallationDate: Installed on 2015-09-21 (0 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150921)
LightdmConfig: [Seat:*]
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

Kev Bowring (flocculant) wrote :
Kev Bowring (flocculant) wrote :

/etc/lightdm/lightdm.conf contains

[Seat:*]

/usr/share/lightdm/lightdm.conf.d/60-xubuntu.conf contains

[Seat:*]
user-session=xubuntu

Added

autologin-user='username'

System autologins correctly.

Also seen in Ubuntu Mate and Ubuntu (wily dailies)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
tags: added: rls-w-incoming
Changed in lightdm (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High

This also affects new installs from wily dailies.

summary: - Autlogin lost after 15.04 to 15.10 upgrade
+ Autologin lost after 15.04 to 15.10 upgrade
summary: - Autologin lost after 15.04 to 15.10 upgrade
+ Autologin lost after 15.04 to 15.10 upgrades and/or 15.10 clean installs

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1498544

tags: added: iso-testing
affects: lightdm (Ubuntu) → user-setup (Ubuntu)
Changed in user-setup (Ubuntu):
assignee: Robert Ancell (robert-ancell) → Sebastien Bacher (seb128)
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

Retitling the bug and using it for new installs, if there is an issue with upgrades it should be reported as a different bug since that's on another component

summary: - Autologin lost after 15.04 to 15.10 upgrades and/or 15.10 clean installs
+ Autologin not correctly enabled on 15.10 installations
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package user-setup - 1.48ubuntu7

---------------
user-setup (1.48ubuntu7) wily; urgency=medium

  * user-setup-apply: use correct syntax escaping, fix the lightdm
    configuration to enable autologin on new installations (lp: #1498544)

 -- Sebastien Bacher <email address hidden> Wed, 23 Sep 2015 10:09:41 +0200

Changed in user-setup (Ubuntu):
status: In Progress → Fix Released

I have a new 15.10 install (XUbuntu) and auto-login is not working for me.

How can I check if I have this fix or not? I've done all system updates.

My /etc/lightdm/lightdm-gtk-greeter.conf.d/99_autologin.conf contain:

[greeter]
background=/etc/lightdm/wallpaper.png

[SeatDefaults]
user-session=xfce
autologin-user=myuserid
autologin-user-timeout=0
autologin-user-session=xfce

the wallpaper shows up so I know this conf is picked up, but autologin does not work.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 15.10
Release: 15.10
Codename: wily
$ uname -a
Linux d77781 4.2.0-23-generic #28-Ubuntu SMP Sun Dec 27 17:47:31 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Kev Bowring (flocculant) wrote :

[SeatDefaults] isn't used any longer as you can see above, it uses [Seat:*] now.

Can someone please update the doc at https://wiki.ubuntu.com/LightDM
It does not mention [Seat:*].
thanks

I found http://wiki.debian.org/LightDM which is more current and matches what I have in 15.10 Wily

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers