expert install produced passwordless root account

Bug #107042 reported by Ian Jackson on 2007-04-16
2
Affects Status Importance Assigned to Milestone
user-setup (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: debian-installer

I installed in expert mode using d-i rc 20070415 (feisty i386). After I had finished the installation, I found that:
 * The user I had asked to create had not been created
 * The root account was enabled with no password
 * gdm would not allow me to log in as root although login would

During the installation I said that I would like a useable root account and answered the prompt for a password for it, and also asked to create a normal user for myself.

I'm pretty sure I did do all of the things necessary to make this work correctly although (a) I was installing in German and (b) there are lots and lots of questions so it is possible that I made some kind of mistake.

I preserved the install logs (before knowing that it hadn't worked right!) and will attach the install/syslog,

Ian Jackson (ijackson) wrote :
Martin Pitt (pitti) wrote :

Just for the record and triagers, I did several expert installs recently with root users, and it has always worked fine so far. I'm not denying a bug in here, just saying that it does not seem to happen every time/with every combination of d-i answers.

Colin Watson (cjwatson) wrote :

Ian, is it possible that you chose a root filesystem that already had an installation of some kind on it, and opted not to format it?

Changed in user-setup:
status: Unconfirmed → Needs Info

Colin Watson writes ("[Bug 107042] Re: expert install produced passwordless root account"):
> Ian, is it possible that you chose a root filesystem that already had an
> installation of some kind on it, and opted not to format it?

It seems unlikely. I expect I would have been warned about that ?

IIRC I did do manual partitioning and I may well have intended to
reuse a partition; I can't remember any more exactly what sequence of
things I did.

Ian.

description: updated
Launchpad Janitor (janitor) wrote :

[Expired for user-setup (Ubuntu) because there has been no activity for 60 days.]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments