installer let us choose a system user as our primary user account, without warning

Bug #1069684 reported by Nick Moffitt on 2012-10-22
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
user-setup (Ubuntu)
High
Colin Watson

Bug Description

We just now installed a quantal MAAS server via USB key from this image: 4bd3270bde86d7e4e017e3847a4af485 ubuntu-12.10-server-amd64.iso

We successfully made it through the installation (creating a new MAAS) and rebooted. However, when logging in via ssh or at the console, we get kicked out because /home/maas (our chosen username) does not exist. The password succeeds. Here's an example via SSH:

 $ ssh <email address hidden>
 <email address hidden>'s password:

 The programs included with the Ubuntu system are free software;
 the exact distribution terms for each program are described in the
 individual files in /usr/share/doc/*/copyright.

 Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
 applicable law.

 Welcome to Ubuntu 12.10 (GNU/Linux 3.5.0-17-generic x86_64)

  * Documentation: https://help.ubuntu.com/

 The programs included with the Ubuntu system are free software;
 the exact distribution terms for each program are described in the
 individual files in /usr/share/doc/*/copyright.

 Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
 applicable law.

 Could not chdir to home directory /home/maas: No such file or directory
 Connection to my-maas.example.com closed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
description: updated
Nick Moffitt (nick-moffitt) wrote :

Upon reflection, it appears that the installer let us choose a system user as our primary user account, without warning.

tags: added: quantal
summary: - quantal server MAAS installer does not make home directory for primary
- user
+ installer let us choose a system user as our primary user account,
+ without warning
Changed in debian-installer (Ubuntu):
importance: Undecided → High
Colin Watson (cjwatson) on 2012-11-16
affects: debian-installer (Ubuntu) → user-setup (Ubuntu)
Colin Watson (cjwatson) on 2014-04-08
Changed in user-setup (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package user-setup - 1.48ubuntu2

---------------
user-setup (1.48ubuntu2) trusty; urgency=medium

  * Add the initial user to the libvirtd group (LP: #1304008).
  * Add maas to reserved-usernames (LP: #1069684).
 -- Colin Watson <email address hidden> Tue, 08 Apr 2014 15:13:12 +0100

Changed in user-setup (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers