[FFe] Add new Apple iPad USB IDs

Bug #555358 reported by Paul Sladen on 2010-04-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Wishlist
gvfs (Ubuntu)
Wishlist
Unassigned
libgpod (Ubuntu)
Wishlist
Unassigned
libimobiledevice (Ubuntu)
Wishlist
Unassigned
usbmuxd (Debian)
Fix Released
Unknown
usbmuxd (Ubuntu)
Wishlist
Unassigned
usbutils (Ubuntu)
Wishlist
Unassigned
Paul Sladen (sladen) on 2010-04-04
Changed in usbmuxd (Ubuntu):
milestone: none → ubuntu-10.04
status: New → Incomplete
importance: Undecided → Wishlist
description: updated
Changed in libimobiledevice (Ubuntu):
milestone: none → ubuntu-10.04
Paul Sladen (sladen) on 2010-04-04
Changed in libimobiledevice (Ubuntu):
status: New → Incomplete
Changed in libgpod (Ubuntu):
status: New → Incomplete
milestone: none → ubuntu-10.04
importance: Undecided → Wishlist
Changed in libimobiledevice (Ubuntu):
importance: Undecided → Wishlist
Paul Sladen (sladen) on 2010-04-04
description: updated
Paul Sladen (sladen) on 2010-04-05
Changed in usbutils (Ubuntu):
importance: Undecided → Wishlist
status: New → Incomplete
milestone: none → ubuntu-10.04
Changed in usbmuxd (Debian):
status: Unknown → New
Martin Pitt (pitti) wrote :

The usbmuxd change looks appropriate to me, approved.

Why the usbutils task? It seems unrelated.

Changed in usbmuxd (Ubuntu):
status: Incomplete → Confirmed
Paul Sladen (sladen) wrote :

usbutils: not /required/ just so that 'lsusb' can output something more helpful than "Unknown/Apple Computer Inc.".

The new usbmuxd IDs gets AFC working, the rest are placeholders depending on whether any further tweaks are needed higher up the stack.

Sebastien Bacher (seb128) wrote :

the libgpod change is in 0.7.93 which will be uploaded soon to lucid

Changed in libgpod (Ubuntu):
status: Incomplete → Fix Committed
Paul Sladen (sladen) on 2010-04-08
Changed in usbmuxd (Ubuntu):
status: Confirmed → Fix Committed
Paul Sladen (sladen) on 2010-04-08
description: updated
Changed in gvfs (Ubuntu):
status: New → Confirmed
milestone: none → ubuntu-10.04
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usbmuxd - 1.0.2-1ubuntu2

---------------
usbmuxd (1.0.2-1ubuntu2) lucid; urgency=low

  * 03-ipad-usb-id.patch: Add 05ac:129a matching for iPad Wifi.
    Backported from upstream git head. (LP: #555358)
 -- Paul Sladen <email address hidden> Tue, 06 Apr 2010 09:35:15 +0100

Changed in usbmuxd (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgpod - 0.7.93-0ubuntu1

---------------
libgpod (0.7.93-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - various bug fixes in HAL/udev iPhone callout which would make it fail
      to dump SysInfoExtended more often than not.
    - fix iPod Classic 80GB support
    - handle TV Shows, Movies and Music Videos on iPhone better
    - fix python bindings for the iPhone
    - fix OnTheGo playlist parsing (the 1st on-the-go playlist was always
      ignored).
    - automatically call itdb_shuffle_write when itdb_write is called if needed.
    - some gint32/guint32 changes were made in the public API, this shouldn't
      break anything, but please report a bug if it's an annoyance for you.
    - lower udev rule priority so that it runs after the usbmux udev rule.
    - define ipad ids (lp: #555358)
 -- Sebastien Bacher <email address hidden> Wed, 07 Apr 2010 13:36:42 +0200

Changed in libgpod (Ubuntu):
status: Fix Committed → Fix Released
Paul Sladen (sladen) wrote :

Rejected:
Rejected by archive administrator.

usbmuxd (1.0.2-1ubuntu2) lucid; urgency=low

  * 03-ipad-usb-id.patch: Add 05ac:129a matching for iPad Wifi.
    Backported from upstream git head. (LP: #555358)

Steve Langasek (vorlon) wrote :

rejected because it was uploaded twice; it can only be accepted once...

Sebastien Bacher (seb128) wrote :

gvfs (1.6.0+git20100414-0ubuntu1) lucid; urgency=low

  * New upstream git snapshot (since GNOME 2.30.1 will be too late for lucid):
    - afc: Detect iPad and set correct icon name

Changed in gvfs (Ubuntu):
status: Confirmed → Fix Released
Changed in gvfs:
status: Unknown → Fix Released
Changed in usbmuxd (Debian):
status: New → Fix Released
Scott Kitterman (kitterman) wrote :

Please update and resubscribe ubuntu-release if needed.

Julien Lavergne (gilir) wrote :

I don't think libimobiledevice need any change to support iPad, all is done by usbmuxd.

Changed in libimobiledevice (Ubuntu):
status: Incomplete → Invalid
Changed in gvfs:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.