Incorrect(?) USB Id in the database: 1941:8021 Watson W-8681

Bug #377967 reported by Sergey V. Udaltsov on 2009-05-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usbutils (Ubuntu)
Low
Unassigned

Bug Description

lsusb is reporting it as "Dream Link USB Missile Launcher". Actually it is a weather station (manufactured by Fine Offset Electronics WH1080, rebranded as Watson W-8681, see http://www.digitalham.co.uk/equipment/Watson_W8681.php).
Most probably, there is a conflict in the database. What is the ulmimate source of these ids?

There is no need to load any driver or smth - everything is handled by the client software (request for packaging is pending).

Probably, this rule would be nice to have for udev:

SYSFS{idProduct}=="8021", SYSFS{idVendor}=="1941", MODE="660", GROUP="plugdev"

I put it into the /etc/udev/rules.d/39-w8681.rules

Chris Coulson (chrisccoulson) wrote :

What does the output of "lsusb -v" show? It's likely that your hardware just uses a USB id already allocated to another vendor/model. If that is the case, then that is a bug in the device you have and I don't think there's much that anyone (other than the hardware vendor) can do about it.

Changed in usbutils (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Chris Coulson (chrisccoulson) wrote :

Ah, ok, the USB id is already in the bug title - silly me. Anyway, that USB id is allocated for another device, so that's a bug with your hardware.

Changed in usbutils (Ubuntu):
status: Incomplete → Invalid

lsusb -v

Bus 002 Device 003: ID 1941:8021 Dream Link USB Missile Launcher
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 1.10
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 8
  idVendor 0x1941 Dream Link
  idProduct 0x8021 USB Missile Launcher
  bcdDevice 1.00
  iManufacturer 0
  iProduct 0
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 34
    bNumInterfaces 1
    bConfigurationValue 1
etc...

What is the ultimate source of these ids? Is it IEEE or any other body? How could we check - what vendor actually owns 1941?

Chris, AFAIK there are multiple weather stations (different brands, same electronics) using the same ID (try googling). Perhaps it is not a bug in the single model, it is quite common. What makes you think that launcher is more appropriate for that assignment? Is there any central official registry for USB ids?

Changed in usbutils (Ubuntu):
status: Invalid → New
John C Barstow (jbowtie) wrote :

This USB id is also used by the USB drum kit sold by ThinkGeek, which also handles everything via client software.

I suspect that it's actually a generic serial-to-USB converter; that would explain why it shows up in such diverse products and also why these products require specific client software to drive them.

Could the description be changed to "generic serial-to-USB converter"?

Glyn M Burton (modiford) wrote :

I'm here because the same ID has shown up for USB drum kit privided by Tesco (of the UK) of all things.

Guess I'm not gonna perform comedy drum rolls any time soon...

Robert Ancell (robert-ancell) wrote :

The database already updated this to "WH1080 Weather Station / USB Missile Launcher":
https://usb-ids.gowdy.us/read/UD/1941/8021

Changed in usbutils (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers