[SRU] usbmount in karmic

Bug #530972 reported by Andres Rodriguez on 2010-03-02
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usbmount (Ubuntu)
Medium
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: usbmount

1. The reason behind this is usbmount 0.0.17 in Karmic tries to get a volume id using /lib/udev/vol_id, which is not anymore. By backporting this fix, we will ensure to change the use of /lib/udev/vol_id to /sbin/blkid.

2. The related bug and [1], have been already fixed both in Debian and Ubuntu lucid by uploading new upstream releases. However, in this case we are applying a merge of the patch originally reported in Debian [2].

3. To reproduce the bug please see [1]. To verify the fix, just install this fix and connect a USB Stick, and verify that it gets mounted, and check the syslog and a message similar to this will appear:

Mar 3 12:43:59 shift usbmount[8903]: executing command: mount -tvfat -osync,noexec,nodev,noatime /dev/sdc /media/usb0
Mar 3 12:43:59 shift usbmount[8903]: executing command: run-parts /etc/usbmount/mount.d

I've personally tested the package before and after the fix, and I can confirm that the fix fixes the problem.

Please see [1] for further information on the related bug:

[1]: https://bugs.launchpad.net/ubuntu/+source/usbmount/+bug/478487
[2]: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=548627

Build logs can be found here:

http://launchpadlibrarian.net/40094012/buildlog_ubuntu-karmic-i386.usbmount_0.0.17ubuntu1.1_FULLYBUILT.txt.gz

Changed in usbmount (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
importance: Undecided → Medium
status: New → In Progress
Andres Rodriguez (andreserl) wrote :

I've personally tested this and can confirm that this backport will fix the issue detailed in bug 478487.

Build logs can be found in my ppa: https://launchpad.net/~andreserl/+archive/other/+packages

I'm attaching the debdiff

Changed in usbmount (Ubuntu):
assignee: Andres Rodriguez (andreserl) → nobody
status: In Progress → Confirmed
description: updated
John Dong (jdong) wrote :

This should be a SRU, not a backport... https://wiki.ubuntu.com/StableReleaseUpdates

Scott Kitterman (kitterman) wrote :

Agreed. Definite SRU candidate (and an important one).

summary: - Please backport usbmount 0.0.19.1 to karmic from lucid
+ [SRU] usbmount in karmic
Andres Rodriguez (andreserl) wrote :

Attaching debdiff

description: updated
John Dong (jdong) wrote :

ACK from SRU team

Changed in usbmount (Ubuntu):
status: Confirmed → Fix Released
Benjamin Drung (bdrung) wrote :

Unsubscribing ubuntu-sponsors; you can upload the patch by yourself.

Benjamin Drung (bdrung) wrote :

uploaded

Changed in usbmount (Ubuntu Karmic):
status: New → Fix Committed

Accepted usbmount into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
cement_head (andorjkiss) wrote :

This "fix" screwed up my Cowan IAUDIO7 MP3 player. I had to uninstalL it - IT BREAKS USB DEVICES FOR ME.

Andres Rodriguez (andreserl) wrote :

Hi there. I;ve tested this fix with following USB devices, such as IPod, two sony usb sticks, and one generic brand. Im attaching the syslogs for each mount.

Andres Rodriguez (andreserl) wrote :
Andres Rodriguez (andreserl) wrote :
Andres Rodriguez (andreserl) wrote :
Andres Rodriguez (andreserl) wrote :

Hi.

On Tue, Apr 6, 2010 at 18:50, cement_head <email address hidden> wrote:
> This "fix" screwed up my Cowan IAUDIO7 MP3 player.  I had to uninstalL
> it - IT BREAKS USB DEVICES FOR ME.

Can you please give any further infomation regarding the "bug"? In
what sense did the update "screwed up" your mp3 player?

Unless you can provide some further data, I think that I will mark
this bug as incomplete, as it is not possible to help you with your
issues here.

Also, please keep in mind that if you don't provide extra information,
then when you upgrade, a newer version of usbmount will probably get
installed or, if you choose to pin the current version of usbmount,
then you will also have to take care of the vol_id change.

Looking at your e-mail address makes it clear that you can surely
provide a decent, detailed bug report.

Regards,

--
Rogério Brito : rbrito@{mackenzie,ime.usp}.br : GPG key 1024D/7C2CAEB8
http://www.ime.usp.br/~rbrito : http://meusite.mackenzie.com.br/rbrito
Projects: algorithms.berlios.de : lame.sf.net : vrms.alioth.debian.org

Martin Pitt (pitti) wrote :

Flagging this as failed/regression-proposed until more information arrives.

cement_head, can you please make sure that downgrading to the karmic final version makes your Cowan player work again? What's the nature of the regression?

Andres, what was the result of the testing?

Thanks!

tags: added: regression-proposed verification-failed
removed: verification-needed
Andres Rodriguez (andreserl) wrote :

Martin, the results of my testing are the correct functioning of usbmount. As mentioned above I've tested it with different USB Sticks and my iPod, with successful results (logs are attached above).

Thanks.

Andres Rodriguez (andreserl) wrote :

Rogério,

Could you please add the Proposed repo to a Karmic installation (https://wiki.ubuntu.com/Testing/EnableProposed) and test the SRU for usbmount due to you are upstream??

Thanks a lot.

Martin Pitt (pitti) wrote :

This was reported to introduce a regression in karmic-proposed. I'll remove the proposed package again soon, unless there is someone who still wants to pursue this?

Martin Pitt (pitti) wrote :

This SRU has been in karmic-proposed for 128 days, but failed verification and further followups. I removed the proposed package again.

Changed in usbmount (Ubuntu Karmic):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers