usbmount cannnot execute /lib/udev/vol_id

Bug #478487 reported by Sir Roden on 2009-11-08
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
usbmount (Debian)
Fix Released
Unknown
usbmount (Ubuntu)
Wishlist
Andres Rodriguez
Karmic
Medium
Unassigned

Bug Description

Binary package hint: usbmount

On a fresh new installed ubuntu server 9.10 usbmount is not working. See also the attached syslog dump. It tries to get the volume id through the /lib/udev/vol_id but that is not present anymore.

see also debian report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=548627

Ubuntu Release: 9.10
usbmount package:
Installed: 0.0.17ubuntu1
Candidate: 0.0.17ubuntu1
Version table:
 *** 0.0.17ubuntu1 0
500 http://nl.archive.ubuntu.com karmic/universe Packages
00 /var/lib/dpkg/status

Sir Roden (sirroden) wrote :

Yes, this is correct.

The version that was released with karmic does not work with the other userspace parts. I have already fixed this in a newer release, in Debian (version 0.0.18).

http://packages.debian.org/changelogs/pool/main/u/usbmount/current/changelog#versionversion0.0.18

I would suggest that you get your version from Debian in the mean time that Ubuntu does not update the package. I am, BTW, working to clean up the code and will quite probably upload a new version (0.0.19) real soon now (TM).

Changed in usbmount (Ubuntu):
status: New → Fix Committed
assignee: nobody → Rogério Theodoro de Brito (rbrito)
Changed in usbmount (Debian):
status: Unknown → Fix Released
Andres Rodriguez (andreserl) wrote :

Hi there!

I believe that we will have to backport usbmount 0.0.18 into karmic so that this bug gets fixed as well as to fix the data loss discussed in the other bug. I'll assign thsi bug to me.

Changed in usbmount (Ubuntu):
assignee: Rogério Theodoro de Brito (rbrito) → Andres E. Rodriguez Lazo (andreserl)
importance: Undecided → Wishlist
status: Fix Committed → In Progress

Hi, Andres.

On 2009-12-04, at 03:31, Andres E. Rodriguez Lazo wrote:
> I believe that we will have to backport usbmount 0.0.18 into karmic so
> that this bug gets fixed as well as to fix the data loss discussed in
> the other bug. I'll assign thsi bug to me.

Please, go ahead and let us fix this once and for all.

I am, BTW, planning on doing a new upstream release. Let me know when
you upload it (if you have any upload rights to Ubuntu).

Also, if you do, I have some other packages that would be loveable to
be sync'ed with Debian, both for karmic as well as for the LTS release.

Thanks,

--
Rogério Brito : rbrito@{mackenzie,ime.usp}.br : GPG key 1024D/7C2CAEB8
http://www.ime.usp.br/~rbrito : http://meusite.mackenzie.com.br/rbrito
Projects: algorithms.berlios.de : lame.sf.net : vrms.alioth.debian.org

Rocco (rocco) wrote :

Would be nice if this was fixed for Karmic.....

Mika Huurre (mika-huurre) wrote :

Installed 9.10 as command line system (alternate install).
usbmount gives the same error ("cannnot execute /lib/udev/vol_id").
So would be nice if fixed.

Eyvind Ljungquist (el-ucs) wrote :

Hi, I'm also running on 9.10 server edition.
Has anyone gotten usbmount to work here?

I had the same problem when running with 0.0.17. I then upgraded to 0.0.19 from debian repos.
After the upgrade, I still don't have working usbmount, but the error message has dissappeared from the syslog.
I'm running usbmount in verbose mode, so it should be populating syslog like version 0.0.17 did.
I can see usb devices are being detected and attached by the kernel (See log excerpt from syslog below), but nothing from usbmount. Usbmount config also included below.

cannnot execute /lib/udev/vol_id

Syslog exceprt:
 usb 1-5: new high speed USB device using ehci_hcd and address 7
 usb 1-5: configuration #1 chosen from 1 choice
 scsi8 : SCSI emulation for USB Mass Storage devices
 usb-storage: device found at 7
 usb-storage: waiting for device to settle before scanning
 usb-storage: device scan complete
 scsi 8:0:0:0: Direct-Access WDC WD50 00AAKS-65YGA0 PQ: 0 ANSI: 2
 sd 8:0:0:0: Attached scsi generic sg4 type 0
 sd 8:0:0:0: [sdc] 976773168 512-byte logical blocks: (500 GB/465 GiB)
 sd 8:0:0:0: [sdc] Write Protect is offd 8:0:0:0: [sdc] Mode Sense: 38 00 00 00
 sd 8:0:0:0: [sdc] Assuming drive cache: write through
 sd 8:0:0:0: [sdc] Assuming drive cache: write through
 sdc: sdc1
 sd 8:0:0:0: [sdc] Assuming drive cache: write through
 sd 8:0:0:0: [sdc] Attached SCSI disk

USBMount Config as provided in .deb package(comments removed, verbose changed to yes):
 ENABLED=1
 FILESYSTEMS="vfat ext2 ext3 ext4 hfsplus"
 MOUNTOPTIONS="sync,noexec,nodev,noatime,nodiratime"
 FS_MOUNTOPTIONS=""
 VERBOSE=yes

Best,
Eyvind

Andres Rodriguez (andreserl) wrote :

Hi all,

I've already requested a Stable Release Update that will contain the fix for this error in karmic.So, we are just waiting for it to be accepted and uploaded. Cheers

Martin Pitt (pitti) wrote :

This was said to be fixed in lucid already.

Changed in usbmount (Ubuntu):
status: In Progress → Fix Released
tags: added: verification-needed

Accepted usbmount into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Patrick Laxton (andy-b-84) wrote :

Hello,

I'm running my computer with Ubuntu since... I think it was Hardy, and I updated it since then (now it's a Karmic, of course).
I use some ppas (Spring, Chromium-daily, Medibuntu, ...) , and rand into this bug two weeks ago, when trying to mount my iPhone (which I don't want to jailbreak).
I first thought it was my fault, becaus I had to play with USB librairies in order to use GTKPod, but I can see it's not the case :)

So, I just installed this patched version : now my USB key successfully mounts.
But : its name is "usb0" instead of the one I gave it (which is not a big deal), and I cannot unmount it properly (which is a rather bigger deal, even if I can still unplug it :) ). Besides, I've tried to mount my USB hard drive (a 250 GB Iomega), and it just doesn't make anything. Below is my /var/log/syslog's content when I plug it :

Apr 10 13:26:25 Receps kernel: [ 1981.216026] usb 1-8: new high speed USB device using ehci_hcd and address 10
Apr 10 13:26:25 Receps kernel: [ 1981.349845] usb 1-8: configuration #1 chosen from 1 choice
Apr 10 13:26:25 Receps kernel: [ 1981.353511] scsi11 : SCSI emulation for USB Mass Storage devices
Apr 10 13:26:25 Receps kernel: [ 1981.354199] usb-storage: device found at 10
Apr 10 13:26:25 Receps kernel: [ 1981.354202] usb-storage: waiting for device to settle before scanning
Apr 10 13:26:30 Receps kernel: [ 1986.353427] usb-storage: device scan complete
Apr 10 13:26:30 Receps kernel: [ 1986.396287] scsi 11:0:0:0: Direct-Access SAMSUNG HM250HI PQ: 0 ANSI: 2 CCS
Apr 10 13:26:30 Receps kernel: [ 1986.396999] sd 11:0:0:0: Attached scsi generic sg6 type 0
Apr 10 13:26:30 Receps kernel: [ 1986.399651] sd 11:0:0:0: [sdf] 488397168 512-byte logical blocks: (250 GB/232 GiB)
Apr 10 13:26:30 Receps kernel: [ 1986.402398] sd 11:0:0:0: [sdf] Write Protect is off
Apr 10 13:26:30 Receps kernel: [ 1986.402402] sd 11:0:0:0: [sdf] Mode Sense: 28 00 00 00
Apr 10 13:26:30 Receps kernel: [ 1986.402405] sd 11:0:0:0: [sdf] Assuming drive cache: write through
Apr 10 13:26:30 Receps kernel: [ 1986.405393] sd 11:0:0:0: [sdf] Assuming drive cache: write through
Apr 10 13:26:30 Receps kernel: [ 1986.405397] sdf: sdf1
Apr 10 13:26:30 Receps kernel: [ 1986.431391] sd 11:0:0:0: [sdf] Assuming drive cache: write through
Apr 10 13:26:30 Receps kernel: [ 1986.431397] sd 11:0:0:0: [sdf] Attached SCSI disk

If you want to ask me anything, I would be very happy to answer you. Just use [Ubuntu] in the subject though, please :)

I'll subscribe to this ticket right now, too.

Steve Langasek (vorlon) on 2010-04-11
Changed in usbmount (Ubuntu Karmic):
status: New → Fix Committed
importance: Undecided → Medium
tags: added: verification-done
removed: verification-needed
Patrick Laxton (andy-b-84) wrote :

OK,

The problem really came from me, as I thought in the first place : I don't know exactly how nor when, but I uninstalled gvfs-backend . On synaptic, though, when I tried to install it, it said I couldn't : Every gvfs related package was in version 1.5, while the only available version for gvfs-backend was 1.4 , and it didn't want to install until the package "gvfs" was in version 1.4 .
So I had to play a bit with my packages, downgrade them all to 1.4, install gvfs-backend, then restart, and then, at last, all of my drives mount by themselves :)

Patrick

Martin Pitt (pitti) wrote :

This was reported to introduce a regression in karmic-proposed, see bug 530972. I'll remove the proposed package again soon, unless there is someone who still wants to pursue this?

Martin Pitt (pitti) wrote :

This SRU has been in karmic-proposed for 128 days, but failed verification and further followups. I removed the proposed package again.

Changed in usbmount (Ubuntu Karmic):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.