usbguard-applet-qt: started immediately leaving the user without mouse or keyboard

Bug #1809269 reported by kortcliptik on 2018-12-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
usbguard (Debian)
Fix Released
Unknown
usbguard (Ubuntu)
Undecided
Unassigned

Bug Description

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu

Description: Ubuntu 18.10
Release: 18.10

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center

usbguard-applet-qt:
  Installed: 0.7.2+ds-2
  Candidate: 0.7.2+ds-2
  Version table:
 *** 0.7.2+ds-2 500
        500 http://se.archive.ubuntu.com/ubuntu cosmic/universe amd64 Packages
        100 /var/lib/dpkg/status

3) What you expected to happen
Wanted to install and configure with whitelisting mouse, keyboard and some usb memory sticks. After that I thought I would activate or reboot to start the application.

4) What happened instead
The application started immediately leaving me without mouse or keyboard. I had to start a live usb to set "ImplicitPolicyTarget=allow" and then reboot into my system.

The same issue is reported here: https://github.com/USBGuard/usbguard/issues/246

They suggest "USBGuard shouldn't be started before you either generate a policy using the usbguard CLI tool or adjust the usbguard-daemon.conf (/etc/usbguard/usbguard-daemon.conf) file not to block present devices when the daemon starts. If Xubuntu packages usbguard in a way that starts it right after installation without a usable policy, then I can't do anything about that."

Juhani Numminen (jsonic) wrote :

Thanks for filing a bug. It is also helpful to briefly describe the bug in the "summary" field as well. I've paraphrased a sentence from your report for that purpose.

summary: - usbguard-applet-qt
+ usbguard-applet-qt: started immediately leaving the user without mouse
+ or keyboard
Changed in usbguard (Debian):
status: Unknown → Fix Committed
Changed in usbguard (Debian):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usbguard (Ubuntu):
status: New → Confirmed
VanillaMozilla (vanillamozilla) wrote :

This appears to be fixed for usbguard/0.7.4+ds-1, but not for earlier versions, including Bionic (see https://launchpad.net/ubuntu/+source/usbguard ).

If necessary, as it appears to be, I request a backport to Bionic. If I'm not mistaken, it looks like a simple fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.