usb-modeswitch disables graphical interface

Bug #486895 reported by Lunarts on 2009-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Undecided
Didier Raboud
usb-modeswitch-data (Debian)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: usb-modeswitch

using the current package for ubuntu karmic 9.10 makes my ubuntu desktop never enter the graphical interface. It stucks at command line interface asking login and password.

I uninstalled usb_modeswitch package and installed manually the most up to date one 1.0.5 and everything is allright. But I tried again just to check using the package version instead, and everytime the same problem happens, desktop stucks at command line interface and even entering login and password wont start the graphic interface...

I hope this is happening just with me, but if not, I would be gratefull if you fix that, because the package version seems to automatize a lot of stuff i had to do by hand using the most up to date but not package version of usb-modeswitch.

Lunarts (lunartsbr-gmail) wrote :

I did a clean copy of karmic, and the problem persists

Didier Raboud (odyx) wrote :

Hi felipemorales,

what "graphical interface" are you talking about? usb-modeswitch provides no graphical interface, so I don't see how it could create that problem.

usb-modeswitch is only meant to flip-flop switch your device without user interaction. Since version 1.0.5 it does nothing anymore (see README.Debian) without your proactive interaction.

Best regards, OdyX, Debian usb-modeswitch maintainer

Changed in usb-modeswitch (Ubuntu):
assignee: nobody → Didier Raboud (odyx)
Lunarts (lunartsbr-gmail) wrote :

Hey first it is felipemoraes =], second, thanks for answering.

When you turn on your computer with ubuntu and vista, it show you some computer info then it goes to grub, and from there ubuntu is started in 10 seconds or by you. All that is in command line.

Using the package of usb-modeswitch with my zte mf100 minimodem plugged in my computer prevents ubuntu from starting the login screen graphical interface, you know, the mode with all the eyecandy graphics made by ubuntu arts team and without any ugly command line stuff.

Ubuntu stays in comand line asking for login and password, entering the login and password do nothing too.

Josua Dietze (digidietze) wrote :

What happens if you unplug the modem for booting?

Lunarts (lunartsbr-gmail) wrote :

If I unplug the minimodem before ubuntu boot or when it stucks at comand line interface, then ubuntu proceeds to the normal graphical user interface.

What is interesting, is which after i installed the usb-modeswitch package and removed it, sometimes ubuntu stucks at comand line still, even using only the manual usb-modeswitch version currently. To test if this too is caused by usb-modeswitch package alone probably i would have to do a clean install of ubuntu and this time use only the most up to date unpackaged version to see if this issue happens stil. But im unable to do that until after january 10.

Lunarts (lunartsbr-gmail) wrote :

in my clean install of karmic, this time i have not used the package version of usb_modeswitch, I used the other usb_modeswitch way instead, and the problem is gone

Didier Raboud (odyx) on 2010-02-08
Changed in usb-modeswitch-data (Debian):
status: New → Fix Released
Didier Raboud (odyx) wrote :

Hi,

This is most probably fixed in usb-modeswitch 1.1.0-2 in Lucid (latest upstream release).

Best regards,

OdyX

Changed in usb-modeswitch (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers