Huawei E3372 is not switched to modem mode automatically

Bug #1562431 reported by Leo on 2016-03-27
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Medium
Unassigned

Bug Description

This "modem key" worked out of the box for me in ubuntu 15.10.

However now, in 16.04, the "usb mode switch" is not done automatically (both is the modem is plugged at boot or after).

I suppose it's an udev regression. So there is no kernel problem for me.

(first answered it in #1527914, also maybe related to #1431179)

WORKAROUND: After plugging in the device (lsusb):
Bus 002 Device 010: ID 12d1:1f01 Huawei Technologies Co., Ltd. E353/E3131 (Mass storage mode)

Execute at a terminal:
usb_modeswitch -J -v 0x12d1 -p 0x1f01

and now the device works as expected and can be selected in network manager. As per lsusb:
Bus 002 Device 011: ID 12d1:14dc Huawei Technologies Co., Ltd.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: udev 229-3ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: MATE
Date: Sun Mar 27 03:08:34 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-03-25 (1 days ago)
InstallationMedia: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323.1)
MachineType: LENOVO 20BWS02G00
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic root=UUID=3dd4b932-06dd-4c0b-8f63-1ee6b90969ed ro quiet splash vt.handoff=7
SourcePackage: systemd
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/27/2016
dmi.bios.vendor: LENOVO
dmi.bios.version: JBET56WW (1.21 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20BWS02G00
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrJBET56WW(1.21):bd01/27/2016:svnLENOVO:pn20BWS02G00:pvrThinkPadT450s:rvnLENOVO:rn20BWS02G00:rvrNotDefined:cvnLENOVO:ct10:cvrNone:
dmi.product.name: 20BWS02G00
dmi.product.version: ThinkPad T450s
dmi.sys.vendor: LENOVO

Leo (leo4ward) wrote :
Leo (leo4ward) wrote :

In fact it seems to be a little bit unpredictable. When I plugged the key to create this report, the modem switch has been done automatically...

Leo, thank you for reporting this and helping make Ubuntu better.

Did this problem not occur for you personally with a release prior to Xenial?

tags: added: latest-bios-1.21
Changed in systemd (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Leo (leo4ward) wrote :

It worked perfectly each time on 15.10.

However I was already using a 4.4.* upstream kernel when I bought this device, so no prior experience.

Triaged given latest release tested, and appears a regression.

tags: added: regression-release
Changed in systemd (Ubuntu):
status: Incomplete → Triaged
description: updated
Martin Pitt (pitti) on 2016-03-27
affects: systemd (Ubuntu) → usb-modeswitch (Ubuntu)
Francesca (alioth) wrote :

I am experiencing the same problem with Kubuntu 16.04 and an Huawei E1800 usb key modem. Indeed, as in the bug description, there is a workaround also for my device by issuing a switching message manually.

On kubuntu 16.04 usb_modeswitch (version 2.2.5+repack0-1ubuntu1 with data version 20151101-1) does not automatically perform the switch of huawei E1800 usb modem. This usb modem worked correctly out of the box with kubuntu 14.04.
On kubuntu 14.04 one can read the vendor and device id before and after the switch by using lsusb in rapid succession: before the switch it is identified as
12d1:1446 Huawei Technologies Co., Ltd. E1552/E1800/E173 (HSPA modem)
and after the switch as
12d1:1436 Huawei Technologies Co., Ltd. E173 3G Modem (modem-mode)
On kubuntu 16.04 it is identified by lsusb as
12d1:1446 Huawei Technologies Co., Ltd. Broadband stick (modem on)
and it does not switch automatically to the other device id.

Workaround: I can issue a usb_modeswitch command and make it switch manually:
sudo usb_modeswitch --verbose -J -v 0x12d1 -p 0x1446
then, looking at the lsusb output, I can read the correct id:
12d1:1436 Huawei Technologies Co., Ltd. Broadband stick
and the modem is correctly recognized by the network manager.

Luigi Tarenga (luigi-tarenga) wrote :

checkout my bug report #1593669 . I found a solution, maybe works for you.

regards
Luigi

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers