USB WWAN Modem is not detected until I run usb_modeswitch myself

Bug #1552652 reported by Will Cooke on 2016-03-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Undecided
Unassigned

Bug Description

Running on Xenial and updated this morning.

If I plug in my ZTE WCDMA WWAN modem (USB ID 19d2:0031) while my laptop is switched off, then power it on and log in then /sometimes/ it is detected (once out of about 10 goes). If I plug it in after I've already logged in it is yet to be detected correctly (tried about 10 times).

syslog.1.txt and usbmodeswitch.1.log are logs from boot up with the modem attached.

If I run:

sudo usb_modeswitch -W -v 19d2 -p 0103 -K

(see manual.usb_modeswitch.log) then the modem is picked up and available for use.

As a side note, in "Set up a Mobile Broadband Connection" I see two modems: "ZTE WCDMA Technologies MSM" and also "zte_0".

Will Cooke (willcooke) wrote :
Will Cooke (willcooke) wrote :
Will Cooke (willcooke) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-modeswitch (Ubuntu):
status: New → Confirmed

Is the modem now indeed 19d2:0031 after you've run the manual switching?

Seems like this may be indicative of an issue with the usb-modeswitch-data package, where some data isn't quite right (but for some reason switching with no extra config works).

Changed in usb-modeswitch (Ubuntu):
status: Confirmed → Incomplete
Will Cooke (willcooke) wrote :

lsusb before modeswitch:

Bus 002 Device 006: ID 19d2:0103 ZTE WCDMA Technologies MSM MF112

lsusb after:

Bus 002 Device 007: ID 19d2:0031 ZTE WCDMA Technologies MSM MF110/MF627/MF636

Will Cooke (willcooke) on 2016-03-10
Changed in usb-modeswitch (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers