FFe: Please merge or sync usb-modeswitch from Debian unstable/testing - current package is obsolete and latest usb-modeswitch-data will not work

Bug #1354823 reported by Susan Cragin on 2014-08-10
92
This bug affects 41 people
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Undecided
Unassigned

Bug Description

We believe that usb-modeswitch needs to be synched from Debian again:

New upstream versions of usb-modeswitch (2.2.0) and usb-modeswitch-data (20140529) released 4 months ago and were packaged in Debian unstable since June!

Lots of other Huawei related issues, like bug #1308895, bug #1192297 and lots of other bugs are fixed in updated usb-modeswitch (2.2.0+repack0-2) and usb-modeswitch-data (20140529-1) packages in Debian unstable.

Please merge usb-modeswitch 2.2.0+repack0-2 package from Debian unstable to Ubuntu Utopic.

Mathieu Trudel-Lapierre already did the merging job (see branch bellow) - please merge usb-modeswitch 2.2.0+repack0-2 package from Debian unstable to Ubuntu 14.10 (Utopic).

Here is usb-modeswitch 2.2.0+repack0-2 packaging code with patches:
lp:~mathieu-tl/ubuntu/utopic/usb-modeswitch/merge-2.2.0
https://code.launchpad.net/~mathieu-tl/ubuntu/utopic/usb-modeswitch/merge-2.2.0

Here is debian/changelog:

usb-modeswitch (2.2.0+repack0-2) unstable; urgency=medium
   * Add patch to set TMPDIR to /run, add Build-Depends version constraint to
     pull a libjim supporting the setting of TMPDIR (Closes: #751271)

usb-modeswitch (2.2.0+repack0-1) unstable; urgency=medium
  * New 2.2.0 upstream release
    - Introduction of parameter "HuaweiNewMode", wrapping the standard bulk
      message for all newer Huawei devices;
    - Support for generic fallback config files, combined with OS switch (per
      vendor ID);
  * Repack the upstream tarball:
    - Drop the code copy of jimtcl.
  * Bump usb-modeswitch-data depends to 20140529
  * Update VCS-* fields to canonical form
 -- Didier Raboud <email address hidden> Mon, 09 Jun 2014 11:21:08 +0200

And here is usb-modeswitch-data debian/changelog:
http://metadata.ftp-master.debian.org/changelogs/main/u/usb-modeswitch-data/unstable_changelog

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: usb-modeswitch 2.1.1+repack0-1ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-6.11-lowlatency 3.16.0-rc7
Uname: Linux 3.16.0-6-lowlatency x86_64
ApportVersion: 2.14.5-0ubuntu4
Architecture: amd64
Date: Sun Aug 10 07:19:28 2014
InstallationDate: Installed on 2014-07-25 (15 days ago)
InstallationMedia: Lubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140722)
SourcePackage: usb-modeswitch

Susan Cragin (susancragin) wrote :
summary: - usb-modeswitch is obsolete and usb-modeswitch-data will not install
+ Please merge or sync usb-modeswitch from Debian unstable/testing -
+ current package is obsolete and latest usb-modeswitch-data will not work

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-modeswitch (Ubuntu):
status: New → Confirmed
description: updated
tags: added: merge trusty
removed: amd64
summary: - Please merge or sync usb-modeswitch from Debian unstable/testing -
+ FFe: Please merge or sync usb-modeswitch from Debian unstable/testing -
current package is obsolete and latest usb-modeswitch-data will not work
description: updated

By all means, yes. I'll upload the code as soon as the freeze exception is granted.

Iain Lane (laney) wrote :

Can you share the upstream changelog / NEWS?

Mantas Kriaučiūnas (mantas) wrote :

http://draisberghof.de/usb_modeswitch/ChangeLog

Version 2.2.0, 2014/05/29
  Introduction of parameter "HuaweiNewMode", wrapping the standard bulk
  message for all newer Huawei devices; support for generic fall-back
  config files, combined with OS switch (per vendor ID), implementation
  to use a specific switching command on Android for all Huawei devices (see
  README of data package for details); this change was suggested by Huawei

http://draisberghof.de/usb_modeswitch/ChangeLogData
20140529:
    ATTENTION: requires usb-modeswitch version >= 2.2.0 due to new para-
    meter HuaweiNewMode (further reducing config file size);
    Added devices: Nexperia TM TD-SCDMA, Sunplus SU-3200U, Olivetti
    Olicard 160 and Olicard 500, Ericsson F5521gw, Sony Ericsson EC400,
    Huawei E180, Huawei/Vod. W5101 Router, Huawei E3531, Huawei E3131
    (Variant), Novatel MiFi 4082, Emobile D21LC, Prolink PCM100, Titan 3.5G,
    several nameless ZTE modems, several minor device configuration
    corrections (thanks once again to Lars Melin for the tedious device
    research and compilation!);
    Substantial change in handling of Huawei devices - generic udev rule and
    additional generic configuration files (as fallback for unknown models
    or as OS-specific catch-all); see README for details

Iain Lane (laney) wrote :

06/10 16:05:45 <Laney> you think it's safe?
06/10 16:05:57 <cyphermox_> yeah, safe enough

On your head be it. :)

FFe approved.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-modeswitch - 2.2.0+repack0-2ubuntu1

---------------
usb-modeswitch (2.2.0+repack0-2ubuntu1) utopic; urgency=medium

  * Merge from unstable; remaining changes: (LP: #1354823)
    - patch to rewrite dispatcher to C.
    - debian/patches/redirect_dispatcher_output.patch: redirect all dispatcher
      output when called from udev to /dev/null.
    - Replace libjim depends with libpipeline-dev, libudev-dev.
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 03 Oct 2014 10:46:39 -0400

Changed in usb-modeswitch (Ubuntu):
status: Confirmed → Fix Released
Tamir (sugip) wrote :

I have Ubuntu 14.10 and package usb_modeswitch version 2.2.0 (came with the standard updates), but the modem Huawei E3531 does not switch. Version:
tr@tr-lp:~$ usb_modeswitch --version
 * usb_modeswitch: handle USB devices with multiple modes
 * Version 2.2.0 (C) Josua Dietze 2014
 * Based on libusb1/libusbx

 ! PLEASE REPORT NEW CONFIGURATIONS !
tr@tr-lp:~$

Can the problem be something else?
For example there is a bug-report - https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1330262

Tamir (sugip) wrote :

Who have the opportunity to please give the necessary logs to the bug tracker Gnome https://bugzilla.gnome.org/show_bug.cgi?id=739657

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.